<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: https://ogp.me/ns#"> <!--<![endif]-->
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://www.whodiedtoday.com/xmlrpc.php" />
    <script type="text/javascript">
!function(){var e={};e.g=function(){if("object"==typeof globalThis)return globalThis;try{return this||new Function("return this")()}catch(e){if("object"==typeof window)return window}}(),function(n){let{ampUrl:t,isCustomizePreview:r,isAmpDevMode:o,noampQueryVarName:s,noampQueryVarValue:i,disabledStorageKey:a,mobileUserAgents:c,regexRegex:u}=n;if("undefined"==typeof sessionStorage)return;const d=new RegExp(u);if(!c.some((e=>{const n=e.match(d);return!(!n||!new RegExp(n[1],n[2]).test(navigator.userAgent))||navigator.userAgent.includes(e)})))return;e.g.addEventListener("DOMContentLoaded",(()=>{const e=document.getElementById("amp-mobile-version-switcher");if(!e)return;e.hidden=!1;const n=e.querySelector("a[href]");n&&n.addEventListener("click",(()=>{sessionStorage.removeItem(a)}))}));const g=o&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(sessionStorage.getItem(a)||r||g)return;const m=new URL(location.href),h=new URL(t);h.hash=m.hash,m.searchParams.has(s)&&i===m.searchParams.get(s)?sessionStorage.setItem(a,"1"):h.href!==m.href&&(window.stop(),location.replace(h.href))}({"ampUrl":"https:\/\/www.whodiedtoday.com\/dead-at-69-is-jon-zazula-megaforce-records\/?amp=1","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}();
</script>
<meta property="og:type" content="article">
<meta property="og:title" content="Dead at 69 is Jon Zazula, Co-Founder of Legendary Metal Label Megaforce Records.">
<meta property="og:site_name" content="Famous People Who Died">
<meta property="og:description" content="Jon Zazula passed away in Florida surrounded by his brother, daughters, granddaughters, and friends. He was one of Megaforce Records">
<meta property="og:url" content="https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/">
<meta property="og:locale" content="en_US">
<meta property="og:image" content="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records.jpeg">
<meta property="og:image:height" content="570">
<meta property="og:image:width" content="1140">
<meta property="article:published_time" content="2022-02-05T15:39:04-05:00">
<meta property="article:modified_time" content="2022-02-05T16:23:37-05:00">
<meta property="article:section" content="Famous People Death 2022">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Dead at 69 is Jon Zazula, Co-Founder of Legendary Metal Label Megaforce Records.">
<meta name="twitter:description" content="Jon Zazula passed away in Florida surrounded by his brother, daughters, granddaughters, and friends. He was one of Megaforce Records">
<meta name="twitter:url" content="https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/">
<meta name="twitter:site" content="">
<meta name="twitter:image:src" content="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records.jpeg">
<meta name="twitter:image:width" content="1140">
<meta name="twitter:image:height" content="570">
			<script type="text/javascript">
              var jnews_ajax_url = '/?ajax-request=jnews'
			</script>
			<script type="text/javascript">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</script>
<!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home -->
<title>Jon Zazula Megaforce Records co-founder dead at 69</title>
<meta name="description" content="Jon Zazula was one of the co-founders of Legendary Metal Label Megaforce Records. He is dead at 69 in Florida surrounded by family and friends."/>
<meta name="robots" content="follow, index, noarchive, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Jon Zazula Megaforce Records co-founder dead at 69" />
<meta property="og:description" content="Jon Zazula was one of the co-founders of Legendary Metal Label Megaforce Records. He is dead at 69 in Florida surrounded by family and friends." />
<meta property="og:url" content="https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/" />
<meta property="og:site_name" content="Famous People Who Died" />
<meta property="article:section" content="Famous People Death 2022" />
<meta property="og:updated_time" content="2022-02-05T16:23:37-05:00" />
<meta property="og:image" content="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records.jpeg" />
<meta property="og:image:secure_url" content="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records.jpeg" />
<meta property="og:image:width" content="1140" />
<meta property="og:image:height" content="570" />
<meta property="og:image:alt" content="Dead at 69 is Jon Zazula, Co-Founder of Legendary Metal Label Megaforce Records." />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:published_time" content="2022-02-05T15:39:04-05:00" />
<meta property="article:modified_time" content="2022-02-05T16:23:37-05:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Jon Zazula Megaforce Records co-founder dead at 69" />
<meta name="twitter:description" content="Jon Zazula was one of the co-founders of Legendary Metal Label Megaforce Records. He is dead at 69 in Florida surrounded by family and friends." />
<meta name="twitter:site" content="@cakafete" />
<meta name="twitter:creator" content="@cakafete" />
<meta name="twitter:image" content="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records.jpeg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="News Contributor" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":["Organization","Person"],"@id":"https://www.whodiedtoday.com/#person","name":"People Who Died Today","url":"https://www.whodiedtoday.com","email":"personal@fredwhite.ca","address":{"@type":"PostalAddress","streetAddress":"260 King Street East","addressLocality":"Hamilton","addressRegion":"Ontario","postalCode":"L8N1B7","addressCountry":"Canada"},"logo":{"@type":"ImageObject","@id":"https://www.whodiedtoday.com/#logo","url":"https://www.whodiedtoday.com/wp-content/uploads/2014/11/MTV_Star_Diem_Brown_Dies_From_Cancer.jpeg","caption":"People Who Died Today","inLanguage":"en-US","width":"1365","height":"455"},"telephone":"905 296 1073","image":{"@id":"https://www.whodiedtoday.com/#logo"}},{"@type":"WebSite","@id":"https://www.whodiedtoday.com/#website","url":"https://www.whodiedtoday.com","name":"People Who Died Today","publisher":{"@id":"https://www.whodiedtoday.com/#person"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records.jpeg","url":"https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records.jpeg","width":"1140","height":"570","caption":"Dead at 69 is Jon Zazula, Co-Founder of Legendary Metal Label Megaforce Records.","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.whodiedtoday.com/author/whodied-admin/","name":"News Contributor","url":"https://www.whodiedtoday.com/author/whodied-admin/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=96&amp;r=g","url":"https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=96&amp;r=g","caption":"News Contributor","inLanguage":"en-US"}},{"@type":"WebPage","@id":"https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/#webpage","url":"https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/","name":"Jon Zazula Megaforce Records co-founder dead at 69","datePublished":"2022-02-05T15:39:04-05:00","dateModified":"2022-02-05T16:23:37-05:00","author":{"@id":"https://www.whodiedtoday.com/author/whodied-admin/"},"isPartOf":{"@id":"https://www.whodiedtoday.com/#website"},"primaryImageOfPage":{"@id":"https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records.jpeg"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"Jon Zazula Megaforce Records co-founder dead at 69","keywords":"Jon Zazula","datePublished":"2022-02-05T15:39:04-05:00","dateModified":"2022-02-05T16:23:37-05:00","author":{"@id":"https://www.whodiedtoday.com/author/whodied-admin/"},"publisher":{"@id":"https://www.whodiedtoday.com/#person"},"description":"Jon Zazula was one of the co-founders of Legendary Metal Label Megaforce Records. He is dead at 69 in Florida surrounded by family and friends.","copyrightYear":"2022","copyrightHolder":{"@id":"https://www.whodiedtoday.com/#person"},"name":"Jon Zazula Megaforce Records co-founder dead at 69","@id":"https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/#richSnippet","isPartOf":{"@id":"https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/#webpage"},"image":{"@id":"https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records.jpeg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//www.whodiedtoday.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<link rel="alternate" type="application/rss+xml" title="Famous People Who Died &raquo; Feed" href="https://www.whodiedtoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Famous People Who Died &raquo; Comments Feed" href="https://www.whodiedtoday.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Famous People Who Died &raquo; Dead at 69 is Jon Zazula, Co-Founder of Legendary Metal Label Megaforce Records. Comments Feed" href="https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.whodiedtoday.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.whodiedtoday.com/wp-content/plugins/gutenberg/build/block-library/style.css?ver=12.5.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.whodiedtoday.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.8.0' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='jeg_customizer_font-css'  href='//fonts.googleapis.com/css?family=Inter%3Aregular%2C600%2C500&#038;display=swap&#038;ver=1.2.6' type='text/css' media='all' />
<link rel='preload' as='font' type='font/woff2' crossorigin id='font-awesome-webfont-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/fonts/font-awesome/fonts/fontawesome-webfont.woff2?v=4.7.0' type='text/css' media='all' />
<link rel='preload' as='font' type='font/woff' crossorigin id='jnews-icon-webfont-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/fonts/jegicon/fonts/jegicon.woff' type='text/css' media='all' />
<link rel='preload' as='font' type='font/woff2' crossorigin id='vc-font-awesome-brands-webfont-css'  href='https://www.whodiedtoday.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/webfonts/fa-brands-400.woff2' type='text/css' media='all' />
<link rel='preload' as='font' type='font/woff2' crossorigin id='vc-font-awesome-regular-webfont-css'  href='https://www.whodiedtoday.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/webfonts/fa-regular-400.woff2' type='text/css' media='all' />
<link rel='preload' as='font' type='font/woff2' crossorigin id='vc-font-awesome-solid-webfont-css'  href='https://www.whodiedtoday.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/webfonts/fa-solid-900.woff2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/fonts/font-awesome/font-awesome.min.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-icon-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/fonts/jegicon/jegicon.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jscrollpane-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/jquery.jscrollpane.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='oknav-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/okayNav.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/magnific-popup.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='chosen-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/chosen/chosen.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-main-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/main.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-pages-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/pages.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-single-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/single.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-responsive-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/responsive.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-pb-temp-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/pb-temp.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-js-composer-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/js-composer-frontend.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/style.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-darkmode-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/darkmode.css?ver=10.0.9' type='text/css' media='all' />
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>

<!-- Google Analytics snippet added by Site Kit -->
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-1472193-15' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.whodiedtoday.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-1472193-15", {"anonymize_ip":true});
</script>

<!-- End Google Analytics snippet added by Site Kit -->
<link rel="https://api.w.org/" href="https://www.whodiedtoday.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.whodiedtoday.com/wp-json/wp/v2/posts/9208" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.whodiedtoday.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.whodiedtoday.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9" />
<link rel='shortlink' href='https://www.whodiedtoday.com/?p=9208' />
<link rel="alternate" type="application/json+oembed" href="https://www.whodiedtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.whodiedtoday.com%2Fdead-at-69-is-jon-zazula-megaforce-records%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.whodiedtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.whodiedtoday.com%2Fdead-at-69-is-jon-zazula-megaforce-records%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.50.0" />
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<link rel="amphtml" href="https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/?amp=1">
<!-- Google AdSense snippet added by Site Kit -->
<script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-4823718395360608" crossorigin="anonymous" type="text/javascript"></script>

<!-- End Google AdSense snippet added by Site Kit -->
<style>#amp-mobile-version-switcher{left:0;position:absolute;width:100%;z-index:100}#amp-mobile-version-switcher>a{background-color:#444;border:0;color:#eaeaea;display:block;font-family:-apple-system,BlinkMacSystemFont,Segoe UI,Roboto,Oxygen-Sans,Ubuntu,Cantarell,Helvetica Neue,sans-serif;font-size:16px;font-weight:600;padding:15px 0;text-align:center;text-decoration:none}#amp-mobile-version-switcher>a:active,#amp-mobile-version-switcher>a:focus,#amp-mobile-version-switcher>a:hover{text-decoration:underline}</style><link rel="alternate" type="text/html" media="only screen and (max-width: 640px)" href="https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/?amp=1"><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/www.whodiedtoday.com\/#organization","url":"https:\/\/www.whodiedtoday.com\/","name":"","logo":{"@type":"ImageObject","url":""},"sameAs":["#","#","#"]}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/www.whodiedtoday.com\/#website","url":"https:\/\/www.whodiedtoday.com\/","name":"","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.whodiedtoday.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="icon" href="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo-32x32.jpeg" sizes="32x32" />
<link rel="icon" href="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo-192x192.jpeg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo-180x180.jpeg" />
<meta name="msapplication-TileImage" content="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo-270x270.jpeg" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	</head>
<body class="post-template-default single single-post postid-9208 single-format-standard wp-embed-responsive non-logged-in jeg_toggle_dark jeg_single_tpl_7 jeg_single_fullwidth jeg_single_narrow jnews jsc_normal wpb-js-composer js-comp-ver-6.8.0 vc_responsive">

    
    
    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header normal">
    <div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper  jeg_navbar_normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
			<a href="https://www.whodiedtoday.com/" style="padding: 0px 0px 0px 0px;">
				<img class='jeg_logo_img' src="" srcset=" 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/whodiedtoday-mail-logo.jpeg 2x" alt="Writy."data-light-src="" data-light-srcset=" 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/whodiedtoday-mail-logo.jpeg 2x" data-dark-src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark.png" data-dark-srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark.png 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark@2x.png 2x">			</a>
		</div>
	</div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-9161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9161 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com">Home</a></li>
<li id="menu-item-8715" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8715 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/famous-people-death-2022/">2022</a></li>
<li id="menu-item-8716" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8716 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/who-died-today-2021/">2021</a></li>
<li id="menu-item-8717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8717 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/famous-people-who-died-today-in-2020/">2020</a></li>
<li id="menu-item-9163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9163 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/celebrity-actor-who-died/">Celebrity</a></li>
<li id="menu-item-9188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9188 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/who-died-on-dominica/">Dominica</a></li>
<li id="menu-item-9162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9162 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/who-important-died-today/">More Important people</a></li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_dark_mode">
                    <label class="dark_mode_switch">
                        <input type="checkbox" class="jeg_dark_mode_toggle" >
                        <span class="slider round"></span>
                    </label>
                 </div><!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.whodiedtoday.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><!-- Button -->
<div class="jeg_nav_item jeg_button_1">
    		<a href="#"
		   class="btn default "
		   target="_blank">
			<i class=""></i>
			Get Started		</a>
		</div>                    </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header normal">
    <div class="jeg_container">
        <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignleft">
                    <div class="jeg_nav_item jeg_logo">
    <div class="site-title">
    	<a href="https://www.whodiedtoday.com/">
    	    <img class='jeg_logo_img' src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg 2x" alt="Writy."data-light-src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg" data-light-srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg 2x" data-dark-src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark.png" data-dark-srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark.png 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark@2x.png 2x">    	</a>
    </div>
</div>                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                <div class="item_wrap jeg_nav_aligncenter">
                    <div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-9161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9161 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com">Home</a></li>
<li id="menu-item-8715" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8715 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/famous-people-death-2022/">2022</a></li>
<li id="menu-item-8716" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8716 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/who-died-today-2021/">2021</a></li>
<li id="menu-item-8717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8717 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/famous-people-who-died-today-in-2020/">2020</a></li>
<li id="menu-item-9163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9163 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/celebrity-actor-who-died/">Celebrity</a></li>
<li id="menu-item-9188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9188 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/who-died-on-dominica/">Dominica</a></li>
<li id="menu-item-9162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9162 bgnav" data-item-row="default" ><a href="https://www.whodiedtoday.com/who-important-died-today/">More Important people</a></li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
                <div class="item_wrap jeg_nav_alignright">
                    <div class="jeg_nav_item jeg_dark_mode">
                    <label class="dark_mode_switch">
                        <input type="checkbox" class="jeg_dark_mode_toggle" >
                        <span class="slider round"></span>
                    </label>
                 </div><!-- Search Form -->
<div class="jeg_nav_item jeg_nav_search">
	<div class="jeg_search_wrapper jeg_search_no_expand round">
	    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	    <form action="https://www.whodiedtoday.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div>	</div>
</div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="https://www.whodiedtoday.com/">
		        <img class='jeg_logo_img' src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/whodiedtoday-mail-logo.jpeg" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/whodiedtoday-mail-logo.jpeg 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/whodiedtoday-mail-logo.jpeg 2x" alt="WHODIED."data-light-src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/whodiedtoday-mail-logo.jpeg" data-light-srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/whodiedtoday-mail-logo.jpeg 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/whodiedtoday-mail-logo.jpeg 2x" data-dark-src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark.png" data-dark-srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark.png 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark@2x.png 2x">		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="https://www.whodiedtoday.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>

            <div class="post-wrapper">

        <div class="post-wrap" >

            
            <div class="jeg_main jeg_sidebar_none">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">
	<div class="container">

		<div class="jeg_ad jeg_article_top jnews_article_top_ads">
			<div class='ads-wrapper  '></div>		</div>

		
			
			<div class="jeg_featured featured_image"><a href="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records.jpeg"><div class="thumbnail-container" style="padding-bottom:50%"><picture class="wp-post-image" title="Dead at 69 is Jon Zazula, Co-Founder of Legendary Metal Label Megaforce Records. 1 Jon Zazula">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records-1140x570.jpeg.webp"/>
<img width="1140" height="570" src="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Dead-at-69-is-Jon-Zazula-Co-Founder-of-Legendary-Metal-Label-Megaforce-Records-1140x570.jpeg" alt="Dead at 69 is Jon Zazula, Co-Founder of Legendary Metal Label Megaforce Records."/>
</picture>
</div></a></div>
			<div class="row">
				<div class="jeg_main_content col-md-no-sidebar-narrow">

					<div class="jeg_inner_content">
						<div class="entry-header">
							
							<h1 class="jeg_post_title">Dead at 69 is Jon Zazula, Co-Founder of Legendary Metal Label Megaforce Records.</h1>

							
							<div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1">

	<div class="meta_left">
									<div class="jeg_meta_author">
					<img alt='News Contributor' src='https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=80&#038;r=g' srcset='https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=160&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' loading='lazy'/>					<span class="meta_text">by</span>
					<a href="https://www.whodiedtoday.com/author/whodied-admin/">News Contributor</a>				</div>
					
					<div class="jeg_meta_date">
				<a href="https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/">February 5, 2022</a>
			</div>
		
					<div class="jeg_meta_category">
				<span><span class="meta_text">in</span>
					<a href="https://www.whodiedtoday.com/famous-people-death-2022/" rel="category tag">Famous People Death 2022</a>				</span>
			</div>
		
			</div>

	<div class="meta_right">
							<div class="jeg_meta_comment"><a href="https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/#comments"><i
						class="fa fa-comment-o"></i> 0</a></div>
			</div>
</div>
</div>
						</div>

						
						<div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
						<div class="entry-content with-share">
							<div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal">
															</div>

							<div class="content-inner ">
								
<p>Jon Zazula passed away in Florida surrounded by his brother, daughters, granddaughters, and friends. He was one of Megaforce Records co-founders, that launched the iconic label and released the first albums from Metallica, Anthrax, and many others, together with his wife Marsha in 1982. His wife Marsha passed away of cancer in January of last year. Jon Zazula died on Tuesday, a rep for the label confirms to&nbsp;<em>Variety</em>. He was 69 years old.</p>



<p>Known as &#8220;Jonny Z,&#8221; Zazula was the more freewheeling half of the company&#8217;s founding duo, known for his raucous laughter and, sometimes, his temper. Along with Metallica (whose first two albums the label released), Anthrax, Testament, former Kiss guitarist Ace Frehley, Ministry, King&#8217;s X, Overkill and Raven were among the biggest acts affiliated with the company, which also included Crazed Management. &#8220;Jonny and Marsha,&#8221; nearly always side-by-side, we&#8217;re a friendly and familiar presence at metal concerts and events during the era.</p><div class='jnews_inline_related_post_wrapper right'>
                        <div class='jnews_inline_related_post'>
                <div  class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_9208_0_62014c689e492   " data-unique="jnews_module_9208_0_62014c689e492">
					<div class="jeg_block_heading jeg_block_heading_8 jeg_subcat_right">
                     <h3 class="jeg_block_title"><span>You might also like</span></h3>
                     
                 </div>
					<div class="jeg_block_container">
                    
                    <div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_sm format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.whodiedtoday.com/wkrp-actor-howard-hesseman-died-at-81/"><div class="thumbnail-container  size-715 "><picture class="wp-post-image" loading="lazy" title="WKRP&#039;s actor Howard Hesseman dead at 81 2 Jon Zazula">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/02/WKRPs-actor-Howard-Hesseman-dies-at-81-120x86.jpeg.webp"/>
<img width="120" height="86" src="https://www.whodiedtoday.com/wp-content/uploads/2022/02/WKRPs-actor-Howard-Hesseman-dies-at-81-120x86.jpeg" alt="WKRP&#039;s actor Howard Hesseman died at 81" loading="lazy"/>
</picture>
</div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://www.whodiedtoday.com/wkrp-actor-howard-hesseman-died-at-81/">WKRP&#8217;s actor Howard Hesseman dead at 81</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.whodiedtoday.com/wkrp-actor-howard-hesseman-died-at-81/" ><i class="fa fa-clock-o"></i> February 5, 2022</a></div></div>
                    </div>
                </article><article class="jeg_post jeg_pl_sm format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/"><div class="thumbnail-container  size-715 "><picture class="wp-post-image" loading="lazy" title="Bob Wall, who Co-Star in Bruce Lee&#039;s &#039;Enter the Dragon,&#039; Dead at 82 3 Jon Zazula">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-120x86.jpeg.webp"/>
<img width="120" height="86" src="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-120x86.jpeg" alt="Bob Wall, who Co-Star in Bruce Lee&#039;s &#039;Enter the Dragon,&#039; Dead at 82" loading="lazy"/>
</picture>
</div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/">Bob Wall, who Co-Star in Bruce Lee&#8217;s &#8216;Enter the Dragon,&#8217; Dead at 82</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/" ><i class="fa fa-clock-o"></i> February 5, 2022</a></div></div>
                    </div>
                </article></div>
                    <div class='module-overlay'>
				    <div class='preloader_type preloader_dot'>
				        <div class="module-preloader jeg_preloader dot">
				            <span></span><span></span><span></span>
				        </div>
				        <div class="module-preloader jeg_preloader circle">
				            <div class="jnews_preloader_circle_outer">
				                <div class="jnews_preloader_circle_inner"></div>
				            </div>
				        </div>
				        <div class="module-preloader jeg_preloader square">
				            <div class="jeg_square">
				                <div class="jeg_square_inner"></div>
				            </div>
				        </div>
				    </div>
				</div>
                </div>
                <div class="jeg_block_navigation">
                    <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                    
                    
                </div>
					
					<script>var jnews_module_9208_0_62014c689e492 = {"header_icon":"","first_title":"You might also like","second_title":"","url":"","header_type":"heading_8","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"2","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":9208,"include_category":"7831","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"2","pagination_scroll_limit":0,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_21"};</script>
				</div>
            </div>
                    </div>



<p>The Zazulas&#8217; metal dynasty began in the early 1980s as a small independent record store called Rock and Roll Heaven, located at the Route 18 flea market in East Brunswick, New Jersey. The couple originally intended to focus on John Lennon and Jimi Hendrix artists. Still, Marsha decided to sell rare import copies of albums from burgeoning &#8220;New Wave of British Heavy Metal&#8221; acted such as Iron Maiden, Def Leppard, and other rising European bands and stocked the store with like-minded people publications such as Kerrang and Sounds. The couple began promoting shows — including an early show with the Canadian metal band Anvil — in the area.</p>



<p>The couple&#8217;s reputation grew, and before long, a demo from a San Francisco-based band called Metallica found its way to them. Realizing the group was, as Jon put it, &#8220;lightning in a bottle,&#8221; the couple brought the quartet to their home in New Jersey and created Megaforce Records to launch the group. Metallica&#8217;s debut album, &#8220;Kill &#8216;Em All,&#8221; was released in July of 1983, effectively launching the thrash metal movement.</p>



<p>While the label lost Metallica to Elektra Records in 1984, shortly after releasing the group&#8217;s second album, &#8220;Ride the Lightning,&#8221; Megaforce remained a powerful force in heavy metal throughout the 1980s. In the early 1990s, the organization released albums by the above artists and many others via distribution deals with Atlantic, Island, Caroline, and other labels.</p>



<p>&#8220;It&#8217;s all a blessing when you work hard, stay smart and go into the game, and then eventually something comes your way, and you&#8217;re ready for it, and you&#8217;re able to jump up on it and ride it,&#8221;&nbsp;<a target="_blank" href="https://variety.com/2020/music/news/jonny-z-metallica-new-book-1234833024/" rel="noreferrer noopener nofollow">Zazula told&nbsp;<em>Variety</em>&nbsp;in 2020</a>. &#8220;We were very fortunate, Marsha and I, to choose a band that became the biggest band in the world — not to mention a bunch of other great bands that made history.&#8221;</p>



<p>The label varied its roster during the 1990s and continues to this day. Jonny chronicled much of the label&#8217;s history in his book &#8220;Heavy Tales: The Metal, The Music, The Madness.&#8221;</p>



<p>The Zazulas effectively retired a few years back, settling in Florida. However, Jon Zazula continued to be involved with music, hosting a radio show titled &#8220;Jonny Z&#8217;s Defcon 4&#8221; on Cranium Radio. He also worked on a successful benefit to raise money for the victims of Hurricane Sandy that Twisted Sister headlined and inducted into the Hall of Heavy Metal History with a Lifetime Achievement Award.</p>



<p><a href="https://www.whodiedtoday.com/">Home</a></p>
								
								
															</div>


						</div>
						
												<div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '><a href='' rel="noopener" class='adlink ads_image '>
                                    <img src='data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==' class='lazyload' data-src='https://www.whodiedtoday.com/wp-content/uploads/2022/01/ad_1456x180.jpg' alt='' data-pin-no-hover="true">
                                </a><a href='' rel="noopener" class='adlink ads_image_tablet '>
                                    <img src='data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==' class='lazyload' data-src='https://www.whodiedtoday.com/wp-content/uploads/2022/01/ad_1456x180.jpg' alt='' data-pin-no-hover="true">
                                </a></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container ">
	<div class="jeg_authorbox">
		<div class="jeg_author_image">
			<img alt='News Contributor' src='https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=80&#038;r=g' srcset='https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=160&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' loading='lazy'/>		</div>
		<div class="jeg_author_content">
			<h3 class="jeg_author_name">
				<a href="https://www.whodiedtoday.com/author/whodied-admin/">
					News Contributor				</a>
			</h3>
			<p class="jeg_author_desc">
							</p>

							<div class="jeg_author_socials">
									</div>
			
		</div>
	</div>
</div><div class="jnews_related_post_container"><div  class="jeg_postblock_4 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_9208_1_62014c689fec1   " data-unique="jnews_module_9208_1_62014c689fec1">
					<div class="jeg_block_heading jeg_block_heading_5 jeg_subcat_right">
                     <h3 class="jeg_block_title"><span>Related Stories</span></h3>
                     
                 </div>
					<div class="jeg_posts jeg_block_container">
                    
                    <div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_md_3 format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.whodiedtoday.com/wkrp-actor-howard-hesseman-died-at-81/"><div class="thumbnail-container  size-715 "><picture class="wp-post-image" loading="lazy" title="WKRP&#039;s actor Howard Hesseman dead at 81 4 Jon Zazula">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/02/WKRPs-actor-Howard-Hesseman-dies-at-81-350x250.jpeg.webp"/>
<img width="350" height="250" src="https://www.whodiedtoday.com/wp-content/uploads/2022/02/WKRPs-actor-Howard-Hesseman-dies-at-81-350x250.jpeg" alt="WKRP&#039;s actor Howard Hesseman died at 81" loading="lazy"/>
</picture>
</div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://www.whodiedtoday.com/wkrp-actor-howard-hesseman-died-at-81/">WKRP&#8217;s actor Howard Hesseman dead at 81</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.whodiedtoday.com/author/whodied-admin/">News Contributor</a></div><div class="jeg_meta_date"><a href="https://www.whodiedtoday.com/wkrp-actor-howard-hesseman-died-at-81/"><i class="fa fa-clock-o"></i> February 5, 2022</a></div><div class="jeg_meta_comment"><a href="https://www.whodiedtoday.com/wkrp-actor-howard-hesseman-died-at-81/#comments" ><i class="fa fa-comment-o"></i> 0 </a></div></div>
                        <div class="jeg_post_excerpt">
                            <p>Howard Hesseman, a prolific character actor who became a beloved TV mainstay through his roles on sitcoms&nbsp;WKRP in Cincinnati&nbsp;and&nbsp;Head of...</p>
                        </div>
                    </div>
                </article><article class="jeg_post jeg_pl_md_3 format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/"><div class="thumbnail-container  size-715 "><picture class="wp-post-image" loading="lazy" title="Bob Wall, who Co-Star in Bruce Lee&#039;s &#039;Enter the Dragon,&#039; Dead at 82 5 Jon Zazula">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-350x250.jpeg.webp"/>
<img width="350" height="250" src="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-350x250.jpeg" alt="Bob Wall, who Co-Star in Bruce Lee&#039;s &#039;Enter the Dragon,&#039; Dead at 82" loading="lazy"/>
</picture>
</div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/">Bob Wall, who Co-Star in Bruce Lee&#8217;s &#8216;Enter the Dragon,&#8217; Dead at 82</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.whodiedtoday.com/author/whodied-admin/">News Contributor</a></div><div class="jeg_meta_date"><a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/"><i class="fa fa-clock-o"></i> February 5, 2022</a></div><div class="jeg_meta_comment"><a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/#comments" ><i class="fa fa-comment-o"></i> 0 </a></div></div>
                        <div class="jeg_post_excerpt">
                            <p>The martial arts expert and stuntman Bob Wall, best known for playing henchman O'Hara opposite Bruce Lee in the 1973...</p>
                        </div>
                    </div>
                </article><article class="jeg_post jeg_pl_md_3 format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.whodiedtoday.com/samuel-lay-86-died-of-natural-causes/"><div class="thumbnail-container  size-715 "><picture class="wp-post-image" loading="lazy" title="Dead at 86 Samuel Lay, the Chicago blues drummer and vocalist 6 Jon Zazula">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/Dead-at-86-is-Samuel-Lay-Chicago-blues-drummer-and-vocalist-350x250.jpeg.webp"/>
<img width="350" height="250" src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/Dead-at-86-is-Samuel-Lay-Chicago-blues-drummer-and-vocalist-350x250.jpeg" alt="Dead at 86 is Samuel Lay Chicago blues drummer and vocalist" loading="lazy"/>
</picture>
</div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://www.whodiedtoday.com/samuel-lay-86-died-of-natural-causes/">Dead at 86 Samuel Lay, the Chicago blues drummer and vocalist</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.whodiedtoday.com/author/whodied-admin/">News Contributor</a></div><div class="jeg_meta_date"><a href="https://www.whodiedtoday.com/samuel-lay-86-died-of-natural-causes/"><i class="fa fa-clock-o"></i> January 31, 2022</a></div><div class="jeg_meta_comment"><a href="https://www.whodiedtoday.com/samuel-lay-86-died-of-natural-causes/#comments" ><i class="fa fa-comment-o"></i> 0 </a></div></div>
                        <div class="jeg_post_excerpt">
                            <p>Samuel Lay&nbsp;(March 20, 1935 – January 29, 2022) was an American drummer and vocalist. From the late 1950s, the blues...</p>
                        </div>
                    </div>
                </article><article class="jeg_post jeg_pl_md_3 format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.whodiedtoday.com/dead-at-30-is-cheslie-kryst-former-miss-usa/"><div class="thumbnail-container  size-715 "><picture class="wp-post-image" loading="lazy" title="Dead at 30 is Cheslie Kryst, former Miss USA pageant winner. 7 Jon Zazula">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/Dead-at-30-is-Cheslie-Kryst-former-Miss-USA-pageant-winner-350x250.jpeg.webp"/>
<img width="350" height="250" src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/Dead-at-30-is-Cheslie-Kryst-former-Miss-USA-pageant-winner-350x250.jpeg" alt="Dead at 30 is Cheslie Kryst, former Miss USA pageant winner" loading="lazy"/>
</picture>
</div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://www.whodiedtoday.com/dead-at-30-is-cheslie-kryst-former-miss-usa/">Dead at 30 is Cheslie Kryst, former Miss USA pageant winner.</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.whodiedtoday.com/author/whodied-admin/">News Contributor</a></div><div class="jeg_meta_date"><a href="https://www.whodiedtoday.com/dead-at-30-is-cheslie-kryst-former-miss-usa/"><i class="fa fa-clock-o"></i> January 31, 2022</a></div><div class="jeg_meta_comment"><a href="https://www.whodiedtoday.com/dead-at-30-is-cheslie-kryst-former-miss-usa/#comments" ><i class="fa fa-comment-o"></i> 0 </a></div></div>
                        <div class="jeg_post_excerpt">
                            <p>Kryst was an American television presenter, model, and beauty pageant titleholder crowned Miss USA 2019. As Miss USA, she represented...</p>
                        </div>
                    </div>
                </article></div>
                    <div class='module-overlay'>
				    <div class='preloader_type preloader_dot'>
				        <div class="module-preloader jeg_preloader dot">
				            <span></span><span></span><span></span>
				        </div>
				        <div class="module-preloader jeg_preloader circle">
				            <div class="jnews_preloader_circle_outer">
				                <div class="jnews_preloader_circle_inner"></div>
				            </div>
				        </div>
				        <div class="module-preloader jeg_preloader square">
				            <div class="jeg_square">
				                <div class="jeg_square_inner"></div>
				            </div>
				        </div>
				    </div>
				</div>
                </div>
                <div class="jeg_block_navigation">
                    <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                    
                    
                </div>
					
					<script>var jnews_module_9208_1_62014c689fec1 = {"header_icon":"","first_title":"Related Stories","second_title":"","url":"","header_type":"heading_5","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"4","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":9208,"include_category":"7831","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":20,"excerpt_ellipsis":"...","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"4","pagination_scroll_limit":"3","ads_type":"disable","ads_position":1,"ads_random":"","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_4"};</script>
				</div></div><div class="jnews_popup_post_container">    <section class="jeg_popup_post">
        <span class="caption">Next Post</span>

                    <div class="jeg_popup_content">
                <div class="jeg_thumb">
                                        <a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/">
                        <div class="thumbnail-container  size-1000 "><picture class="wp-post-image" loading="lazy" title="Bob Wall, who Co-Star in Bruce Lee&#039;s &#039;Enter the Dragon,&#039; Dead at 82 8 Jon Zazula">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-75x75.jpeg.webp"/>
<img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-75x75.jpeg" alt="Bob Wall, who Co-Star in Bruce Lee&#039;s &#039;Enter the Dragon,&#039; Dead at 82" loading="lazy"/>
</picture>
</div>                    </a>
                </div>
                <h3 class="post-title">
                    <a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/">
                        Bob Wall, who Co-Star in Bruce Lee's 'Enter the Dragon,' Dead at 82                    </a>
                </h3>
            </div>
                
        <a href="#" class="jeg_popup_close"><i class="fa fa-close"></i></a>
    </section>
</div><div class="jnews_comment_container">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/dead-at-69-is-jon-zazula-megaforce-records/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.whodiedtoday.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="comment-form-privacy_policy">
										<label for="privacy_policy">Privacy Policy Agreement <span class="required">*</span></label>
										<input id="privacy_policy" name="privacy_policy"  required='required' type='checkbox'> I agree to the Terms &amp; Conditions and <a href="#">Privacy Policy</a>.
									</p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='9208' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="df259f074d" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="122"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>					</div>

				</div>
							</div>

		
		<div class="jeg_ad jeg_article jnews_article_bottom_ads">
			<div class='ads-wrapper  '></div>		</div>

	</div>
</div>
                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-9208 single-format-standard wp-embed-responsive non-logged-in jeg_toggle_dark jeg_single_tpl_7 jeg_single_fullwidth jeg_single_narrow jnews jsc_normal wpb-js-composer js-comp-ver-6.8.0 vc_responsive"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_6 normal">
    <div class="jeg_footer_container jeg_container">

        <div class="jeg_footer_content">
            <div class="container">
                <div class="jeg_footer_primary clearfix">
                    <div class="footer_widget widget_jnews_about" id="jnews_about-3">        <div class="jeg_about jeg_aligncenter">
									            <p>We update regularly posting relative news on well-known people in society who pass!</p>

			                <div class="jeg_about_autograph">
                    <img class='lazyload' data-src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/whodiedtoday-mail-logo.jpeg"
                         data-srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/whodiedtoday-mail-logo.jpeg 1x,  2x"
                         alt="">
                </div>
			        </div>
		</div><div class="footer_widget widget_jnews_social" id="jnews_social-2">
        <div class="jeg_social_wrap ">
			
            <div class="socials_widget   circle">
				<a href="https://facebook.com" target="_blank" rel="external noopener nofollow" class="jeg_facebook">
                                            <i class="fa fa-facebook"></i>
                                            
                                        </a><a href="https://twitter.com/" target="_blank" rel="external noopener nofollow" class="jeg_twitter">
                                            <i class="fa fa-twitter"></i>
                                            
                                        </a><a href="https://instagram.com" target="_blank" rel="external noopener nofollow" class="jeg_instagram">
                                            <i class="fa fa-instagram"></i>
                                            
                                        </a><a href="https://youtube.com" target="_blank" rel="external noopener nofollow" class="jeg_youtube">
                                            <i class="fa fa-youtube-play"></i>
                                            
                                        </a>            </div>

						<style scoped></style>        </div>

		</div>                </div>
            </div>
        </div>

                            <div class="jeg_footer_instagram_wrapper jeg_container">
                                            </div>
                                    <div class="jeg_footer_tiktok_wrapper jeg_container">
                                            </div>
                
        
        <div class="jeg_footer_bottom">
            <div class="container">

                <!-- secondary footer right -->
                <div class="footer_right">

                    
                    <ul class="jeg_menu_footer"><li id="menu-item-8948" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8948"><a href="https://www.review-products.ca/amazoncanada/">Shop Amazon Canada</a></li>
<li id="menu-item-8949" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8949"><a href="https://www.review-products.ca/">Review Products</a></li>
<li id="menu-item-8950" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8950"><a href="https://www.sakafete.com">Latest Trending News</a></li>
<li id="menu-item-8951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8951"><a href="https://www.estopandshop.com">Shop Amazon US</a></li>
<li id="menu-item-8952" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8952"><a href="https://www.youtube.com/channel/UCG141C5l22DPXMypQiFA2lA">Subscribe on Youtube</a></li>
<li id="menu-item-9115" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9115"><a href="https://www.whodiedtoday.com/famous-people-death-2022/">2022</a></li>
<li id="menu-item-9118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9118"><a href="https://www.whodiedtoday.com/who-died-today-2021/">2021</a></li>
<li id="menu-item-9117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9117"><a href="https://www.whodiedtoday.com/who-died-today-2020/">2020</a></li>
<li id="menu-item-9116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9116"><a href="https://www.whodiedtoday.com/who-died-on-dominica/">Dominica Death</a></li>
</ul>
                    
                </div>

                <!-- secondary footer left -->
                
                
                                    <p class="copyright"> © 2022 <a href="http://jwww.fredwhite.ca" title="CAKAFETEINC FAMILY OF WEBSITES">CAKAFETEINC FAMILY OF WEBSITES</a> - Review -Products <a href="http://www.review-products.ca" title="review-products.ca">Review Products</a>. </p>
                
            </div>
        </div>

        
    </div>
</div><!-- /.footer -->        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.whodiedtoday.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8948"><a href="https://www.review-products.ca/amazoncanada/">Shop Amazon Canada</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8949"><a href="https://www.review-products.ca/">Review Products</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8950"><a href="https://www.sakafete.com">Latest Trending News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8951"><a href="https://www.estopandshop.com">Shop Amazon US</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8952"><a href="https://www.youtube.com/channel/UCG141C5l22DPXMypQiFA2lA">Subscribe on Youtube</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9115"><a href="https://www.whodiedtoday.com/famous-people-death-2022/">2022</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9118"><a href="https://www.whodiedtoday.com/who-died-today-2021/">2021</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9117"><a href="https://www.whodiedtoday.com/who-died-today-2020/">2020</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9116"><a href="https://www.whodiedtoday.com/who-died-on-dominica/">Dominica Death</a></li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="#" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="#" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="#" target='_blank' rel='external noopener nofollow' class="jeg_instagram"><i class="fa fa-instagram"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>© 2022 <a href="http://jwww.fredwhite.ca" title="CAKAFETEINC FAMILY OF WEBSITES">CAKAFETEINC FAMILY OF WEBSITES</a> - Review -Products <a href="http://www.review-products.ca" title="review-products.ca">Review Products</a>.</p>
</div>    </div>
</div>    </div>
</div><script type="text/javascript">var jfla = ["view_counter"]</script><div class="jnews-cookie-law-policy">This website uses cookies. By continuing to use this website you are giving consent to cookies being used. Visit our <a href="#">Privacy and Cookie Policy</a>. <button data-expire="7" class="btn btn-cookie">I Agree</button></div><div class="jeg_read_progress_wrapper"><div class="jeg_progress_container top"><span class="progress-bar"></span></div></div>		<div id="amp-mobile-version-switcher" hidden>
			<a rel="" href="https://www.whodiedtoday.com/dead-at-69-is-jon-zazula-megaforce-records/?amp=1">
				Go to mobile version			</a>
		</div>

				<link rel='stylesheet' id='jnews-scheme-css'  href='https://www.whodiedtoday.com/wp-content/themes/jnews/data/import/writy/scheme.css?ver=10.0.9' type='text/css' media='all' />
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-includes/js/comment-reply.min.js?ver=5.9' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-includes/js/hoverIntent.min.js?ver=1.10.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/plugins/js_composer/assets/lib/bower/isotope/dist/isotope.pkgd.min.js?ver=6.8.0' id='isotope-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/lazysizes.js?ver=10.0.9' id='lazysizes-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/ls.bgset.js?ver=10.0.9' id='bgset-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/superfish.js?ver=10.0.9' id='superfish-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/theia-sticky-sidebar.js?ver=10.0.9' id='theia-sticky-sidebar-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.waypoints.js?ver=10.0.9' id='waypoint-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.scrollTo.js?ver=10.0.9' id='scrollto-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.parallax.js?ver=10.0.9' id='parallax-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.okayNav.js?ver=10.0.9' id='okaynav-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.mousewheel.js?ver=10.0.9' id='mousewheel-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/modernizr-custom.js?ver=10.0.9' id='modernizr-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.smartresize.js?ver=10.0.9' id='smartresize-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/chosen.jquery.js?ver=10.0.9' id='chosen-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.magnific-popup.js?ver=10.0.9' id='magnific-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.jnewsgif.js?ver=10.0.9' id='jnews-gif-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.jsticky.js?ver=10.0.9' id='jnews-sticky-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.transit.min.js?ver=10.0.9' id='jquery-transit-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.module.js?ver=10.0.9' id='jnews-landing-module-js'></script>
<script type='text/javascript' id='jnews-main-js-extra'>
/* <![CDATA[ */
var jnewsoption = {"login_reload":"https:\/\/www.whodiedtoday.com\/dead-at-69-is-jon-zazula-megaforce-records","popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"9208","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"whodiedtoday.com","zoom_button":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/main.js?ver=10.0.9' id='jnews-main-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/zoom-button.js?ver=10.0.9' id='jnews-zoom-button-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/popup-post.js?ver=10.0.9' id='jnews-popup-post-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/darkmode.js?ver=10.0.9' id='jnews-darkmode-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=10.0.9' id='html5shiv-js'></script>
<![endif]-->
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>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</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"Dead at 69 is Jon Zazula, Co-Founder of Legendary Metal Label Megaforce Records.","published":"2022-02-05 15:39:04","updated":"2022-02-05 21:23:37"}</script>
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><script>

  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setDocumentTitle", document.domain + "/" + document.title]);
  _paq.push(["setCookieDomain", "*.www.whodiedtoday.com"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="https://www.cakafeteinc.com/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();


</script><script type="text/javascript">;!function(){"use strict";window.jnews=window.jnews||{},window.jnews.first_load=window.jnews.first_load||{},window.jnews.first_load=function(){var e=this,t=jnews.library,n="object"==typeof jnews&&"object"==typeof jnews.library;e.data=null,e.run_ajax=!0,e.run_loginregister=!0,e.clear=function(){e.run_ajax=!0,e.run_loginregister=!0,e.data=null},e.init=function(){n&&(t.globalBody.querySelectorAll(".jeg_popup_account").length&&jnews.loginregister&&e.run_loginregister&&(e.run_loginregister=!1,jnews.loginregister.init(),jnews.loginregister.hook_form()),jfla.length&&e.run_ajax&&(e.run_ajax=!1,e.do_ajax({action:"jnews_first_load_action",jnews_id:jnewsoption.postid,load_action:jfla})))},e.update_counter=function(){if(n){var o={total_view:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_views_count .counts"),total_share:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_share_count .counts"),total_comment:t.globalBody.querySelectorAll(".jeg_meta_comment a span")};t.forEach(Object.entries(e.data.counter),(function([e,n]){o[e].length&&t.forEach(o[e],(function(e,o){t.setText(e,n)}))}))}},e.do_ajax=function(o){if(n){var a=new XMLHttpRequest;a.onreadystatechange=function(){XMLHttpRequest.DONE===a.readyState&&200==a.status&&(e.data=JSON.parse(a.responseText),e.data.counter&&"object"==typeof e.data.counter&&e.update_counter())},a.open("POST",jnews_ajax_url,!0),a.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=UTF-8"),a.send(t.httpBuildQuery(o))}}},window.jnews.first_load=new window.jnews.first_load,jnews.first_load.init()}();</script></body>
</html>
