<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">

<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<!--Start who died today tracing code -->
<script>
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setDocumentTitle", document.domain + "/" + document.title]);
  _paq.push(["setCookieDomain", "*.www.whodiedtoday.com"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="https://cakafeteinc.com/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="https://cakafeteinc.com/matomo.php?idsite=1&amp;rec=1" style="border:0;" alt="" /></p></noscript>
<!-- End Who died today tracing Code -->
	<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-4823718395360608"
     crossorigin="anonymous"></script>
<script type="text/javascript">
!function(e){var t={};function n(r){if(t[r])return t[r].exports;var o=t[r]={i:r,l:!1,exports:{}};return e[r].call(o.exports,o,o.exports,n),o.l=!0,o.exports}n.m=e,n.c=t,n.d=function(e,t,r){n.o(e,t)||Object.defineProperty(e,t,{enumerable:!0,get:r})},n.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},n.t=function(e,t){if(1&t&&(e=n(e)),8&t)return e;if(4&t&&"object"==typeof e&&e&&e.__esModule)return e;var r=Object.create(null);if(n.r(r),Object.defineProperty(r,"default",{enumerable:!0,value:e}),2&t&&"string"!=typeof e)for(var o in e)n.d(r,o,function(t){return e[t]}.bind(null,o));return r},n.n=function(e){var t=e&&e.__esModule?function(){return e.default}:function(){return e};return n.d(t,"a",t),t},n.o=function(e,t){return Object.prototype.hasOwnProperty.call(e,t)},n.p="",n(n.s=0)}([function(e,t,n){(function(e){!function({ampUrl:t,isCustomizePreview:n,isAmpDevMode:r,noampQueryVarName:o,noampQueryVarValue:i,disabledStorageKey:a,mobileUserAgents:s,regexRegex:u}){if("undefined"==typeof sessionStorage)return;const c=new RegExp(u);if(!s.some(e=>{const t=e.match(c);return!(!t||!new RegExp(t[1],t[2]).test(navigator.userAgent))||navigator.userAgent.includes(e)}))return;e.addEventListener("DOMContentLoaded",()=>{const e=document.getElementById("amp-mobile-version-switcher");if(!e)return;e.hidden=!1;const t=e.querySelector("a[href]");t&&t.addEventListener("click",()=>{sessionStorage.removeItem(a)})});const f=r&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(sessionStorage.getItem(a)||n||f)return;const d=new URL(location.href),l=new URL(t);l.hash=d.hash,d.searchParams.has(o)&&i===d.searchParams.get(o)?sessionStorage.setItem(a,"1"):l.href!==d.href&&(window.stop(),location.replace(l.href))}({"ampUrl":"https:\/\/www.whodiedtoday.com\/lester-bird-former-antigua-and-barbuda-pm-died-at-83\/?amp=1","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}).call(this,n(1))},function(e,t){var n;n=function(){return this}();try{n=n||new Function("return this")()}catch(e){"object"==typeof window&&(n=window)}e.exports=n}]);
</script>

<!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home -->
<title>Sir Lester Bird the second PM of Antigua and Barbuda dead at 83</title>
<meta name="description" content="Former Prime Minister and National Hero Sir Lester Bird passed away on August 9, 2021."/>
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Sir Lester Bird the second PM of Antigua and Barbuda dead at 83" />
<meta property="og:description" content="Former Prime Minister and National Hero Sir Lester Bird passed away on August 9, 2021." />
<meta property="og:url" content="https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/" />
<meta property="og:site_name" content="whodiedtoday.com" />
<meta property="article:tag" content="Antigua and Barbuda" />
<meta property="article:tag" content="Antigua and Barbuda Labour Party" />
<meta property="article:tag" content="Antigua-Barbuda" />
<meta property="article:tag" content="Antigus" />
<meta property="article:tag" content="Breaking News" />
<meta property="article:tag" content="died" />
<meta property="article:tag" content="dies" />
<meta property="article:tag" content="News" />
<meta property="article:tag" content="Prime Minister" />
<meta property="article:section" content="Gone But Not Forgotten" />
<meta property="og:updated_time" content="2021-09-04T14:19:15-04:00" />
<meta property="og:image" content="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83.jpeg" />
<meta property="og:image:secure_url" content="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83.jpeg" />
<meta property="og:image:width" content="1365" />
<meta property="og:image:height" content="455" />
<meta property="og:image:alt" content="Former Prime Minister and National Hero Sir Lester Bird passed away on August 9, 2021." />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Sir Lester Bird the second PM of Antigua and Barbuda dead at 83" />
<meta name="twitter:description" content="Former Prime Minister and National Hero Sir Lester Bird passed away on August 9, 2021." />
<meta name="twitter:image" content="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83.jpeg" />
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":["Organization","Person"],"@id":"https://www.whodiedtoday.com/#person","name":"Who Died Today","url":"https://www.whodiedtoday.com","email":"personal@fredwhite.ca","address":{"@type":"PostalAddress","streetAddress":"260 King Street East","addressLocality":"Hamilton","addressRegion":"Ontario","postalCode":"L8N1B7","addressCountry":"Canada"},"logo":{"@type":"ImageObject","@id":"https://www.whodiedtoday.com/#logo","url":"https://www.whodiedtoday.com/wp-content/uploads/2014/11/MTV_Star_Diem_Brown_Dies_From_Cancer.jpeg","caption":"Who Died Today","inLanguage":"en-US","width":"1365","height":"455"},"telephone":"905 296 1073","image":{"@id":"https://www.whodiedtoday.com/#logo"}},{"@type":"WebSite","@id":"https://www.whodiedtoday.com/#website","url":"https://www.whodiedtoday.com","name":"Who Died Today","publisher":{"@id":"https://www.whodiedtoday.com/#person"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83.jpeg","url":"https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83.jpeg","width":"1365","height":"455","caption":"Former Prime Minister and National Hero Sir Lester Bird passed away on August 9, 2021.","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.whodiedtoday.com/author/whodied-admin/","name":"News Contributor","url":"https://www.whodiedtoday.com/author/whodied-admin/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=96&amp;r=g","url":"https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=96&amp;r=g","caption":"News Contributor","inLanguage":"en-US"}},{"@type":"WebPage","@id":"https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/#webpage","url":"https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/","name":"Sir Lester Bird the second PM of Antigua and Barbuda dead at 83","datePublished":"2021-09-04T14:19:14-04:00","dateModified":"2021-09-04T14:19:15-04:00","author":{"@id":"https://www.whodiedtoday.com/author/whodied-admin/"},"isPartOf":{"@id":"https://www.whodiedtoday.com/#website"},"primaryImageOfPage":{"@id":"https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83.jpeg"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"Sir Lester Bird the second PM of Antigua and Barbuda dead at 83","keywords":"lester bird","datePublished":"2021-09-04T14:19:14-04:00","dateModified":"2021-09-04T14:19:15-04:00","author":{"@id":"https://www.whodiedtoday.com/author/whodied-admin/"},"publisher":{"@id":"https://www.whodiedtoday.com/#person"},"description":"Former Prime Minister and National Hero Sir Lester Bird passed away on August 9, 2021.","name":"Sir Lester Bird the second PM of Antigua and Barbuda dead at 83","@id":"https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/#richSnippet","isPartOf":{"@id":"https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/#webpage"},"image":{"@id":"https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83.jpeg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//www.whodiedtoday.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel="alternate" type="application/rss+xml" title="whodiedtoday.com &raquo; Feed" href="https://www.whodiedtoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="whodiedtoday.com &raquo; Comments Feed" href="https://www.whodiedtoday.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="whodiedtoday.com &raquo; Sir Lester Bird the second PM of Antigua and Barbuda dead at 83 Comments Feed" href="https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.whodiedtoday.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.whodiedtoday.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='themezee-magazine-blocks-css'  href='https://www.whodiedtoday.com/wp-content/plugins/themezee-magazine-blocks/assets/css/themezee-magazine-blocks.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='dynamico-stylesheet-css'  href='https://www.whodiedtoday.com/wp-content/themes/dynamico/style.css?ver=1.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='dynamico-pro-css'  href='https://www.whodiedtoday.com/wp-content/plugins/dynamico-pro/assets/css/dynamico-pro.css?ver=1.0.2' type='text/css' media='all' />
<style id='dynamico-pro-inline-css' type='text/css'>
:root {--dynamico--text-font: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --dynamico--title-font: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --dynamico--title-font-weight: bold; --dynamico--navi-font: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --dynamico--widget-title-font: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; }
</style>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/dynamico/assets/js/svgxuse.min.js?ver=1.2.6' id='svgxuse-js'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-1472193-15' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.whodiedtoday.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-1472193-15", {"anonymize_ip":true});
</script>
<link rel="https://api.w.org/" href="https://www.whodiedtoday.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.whodiedtoday.com/wp-json/wp/v2/posts/7776" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.whodiedtoday.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.whodiedtoday.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8" />
<link rel='shortlink' href='https://www.whodiedtoday.com/?p=7776' />
<link rel="alternate" type="application/json+oembed" href="https://www.whodiedtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.whodiedtoday.com%2Flester-bird-former-antigua-and-barbuda-pm-died-at-83%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.whodiedtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.whodiedtoday.com%2Flester-bird-former-antigua-and-barbuda-pm-died-at-83%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.40.0" /><link rel="amphtml" href="https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/?amp=1"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-4823718395360608","enable_page_level_ads":true,"tag_partner":"site_kit"});</script><style>#amp-mobile-version-switcher{position:absolute;width:100%;left:0;z-index:100}#amp-mobile-version-switcher>a{display:block;padding:15px 0;font-family:-apple-system,BlinkMacSystemFont,Segoe UI,Roboto,Oxygen-Sans,Ubuntu,Cantarell,Helvetica Neue,sans-serif;font-size:16px;font-weight:600;color:#eaeaea;text-align:center;text-decoration:none;background-color:#444;border:0}#amp-mobile-version-switcher>a:active,#amp-mobile-version-switcher>a:focus,#amp-mobile-version-switcher>a:hover{text-decoration:underline}</style><link rel="alternate" type="text/html" media="only screen and (max-width: 640px)" href="https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/?amp=1"><link rel="icon" href="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-300x300.png" />
		<style type="text/css" id="wp-custom-css">
			@font-face {
  font-family: 'WildCoorg';
  font-style: normal;
  font-weight: 400;
  font-display: swap; /* Add this to your @font-face rule */
  src: url('usr/share/fonts/truetype/ubuntu/Ubuntu-Th.ttf') format('Regular'),
          url('usr/share/fonts/truetype/ubuntu/Ubuntu-Th.ttf') format('Regular'),
            url('usr/share/fonts/truetype/ubuntu/Ubuntu-Th.ttf') format('Regular');
}

.content {
  font-family: 'WildCoorg', sans-serif; /* sans-serif will be used as temporary font until WildCoorg is available */
}		</style>
		</head>

<body class="post-template-default single single-post postid-7776 single-format-standard wp-custom-logo centered-theme-layout has-sidebar site-title-hidden site-description-hidden is-blog-page">

	
	<div id="page" class="site">
		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
			<div id="header-top" class="header-bar-wrap">

				<div id="header-bar" class="header-bar">

					
						<button class="secondary-menu-toggle menu-toggle" aria-controls="secondary-menu" aria-expanded="false" >
							<svg class="icon icon-ellipsis" aria-hidden="true" role="img"> <use xlink:href="https://www.whodiedtoday.com/wp-content/themes/dynamico/assets/icons/genericons-neue.svg#ellipsis"></use> </svg><svg class="icon icon-close" aria-hidden="true" role="img"> <use xlink:href="https://www.whodiedtoday.com/wp-content/themes/dynamico/assets/icons/genericons-neue.svg#close"></use> </svg>							<span class="menu-toggle-text">Menu</span>
						</button>

						<div class="secondary-navigation">

							<nav class="top-navigation" role="navigation"  aria-label="Secondary Menu">

								<ul id="secondary-menu" class="menu"><li id="menu-item-7035" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-7035"><a href="https://www.whodiedtoday.com/">Home</a></li>
<li id="menu-item-6588" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6588"><a href="https://www.whodiedtoday.com/who-died-today-2021/">Who died today 2021</a></li>
<li id="menu-item-859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-859"><a href="https://www.whodiedtoday.com/those-who-have-left-us-2/">Those who have left us</a></li>
<li id="menu-item-857" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-857"><a href="https://www.whodiedtoday.com/gone-but-not-forgotten/">Gone-but-not-forgotten</a></li>
<li id="menu-item-1311" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1311"><a href="https://www.whodiedtoday.com/people-that-died-today-celebs-who-died-today/">celebs-who-died-today</a></li>
<li id="menu-item-6589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6589"><a href="https://www.whodiedtoday.com/laid-to-rest/">Laid-to-rest</a></li>
<li id="menu-item-860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-860"><a href="https://www.whodiedtoday.com/who-died-on-dominica/">Dominica</a></li>
</ul>							</nav><!-- .top-navigation -->

						</div><!-- .secondary-navigation -->

						
				</div>

			</div>

			
			<div class="before-header-widget-area widget-area">
				<aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></aside>			</div>

			
		<header id="masthead" class="site-header" role="banner">

			<div class="header-main">

				
			<div class="site-logo">
				<a href="https://www.whodiedtoday.com/" class="custom-logo-link" rel="home"><picture class="custom-logo">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1.png.webp 481w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1-300x38.png.webp 300w" sizes="(max-width: 481px) 100vw, 481px"/>
<img width="481" height="61" src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1.png" alt="whodiedtoday.com" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1.png 481w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1-300x38.png 300w" sizes="(max-width: 481px) 100vw, 481px"/>
</picture>
</a>			</div>

			
				
<div class="site-branding">

	
			<p class="site-title"><a href="https://www.whodiedtoday.com/" rel="home">whodiedtoday.com</a></p>

			
			<p class="site-description">People who died today—a family member, friend, co-worker, celebrity, Hollywood actor, sports personality, or other.</p>

			
</div><!-- .site-branding -->

				
	<div class="header-content">

		
			<div class="header-widgets">

				<aside id="search-11" class="header-widget widget_search">
<form role="search" method="get" class="search-form" action="https://www.whodiedtoday.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field"
			placeholder="Search &hellip;"
			value="" name="s"
			title="Search for:" />
	</label>
	<button type="submit" class="search-submit">
		<svg class="icon icon-search" aria-hidden="true" role="img"> <use xlink:href="https://www.whodiedtoday.com/wp-content/themes/dynamico/assets/icons/genericons-neue.svg#search"></use> </svg>		<span class="screen-reader-text">Search</span>
	</button>
</form>
</aside>
			</div><!-- .header-widgets -->

		
		
	</div>

	
			</div><!-- .header-main -->

			


		</header><!-- #masthead -->

		
		
		
		<div id="content" class="site-content">

			<main id="main" class="site-main" role="main">

				
<article id="post-7776" class="post-7776 post type-post status-publish format-standard has-post-thumbnail hentry category-gone-but-not-forgotten category-recently-died tag-antigua-and-barbuda tag-antigua-and-barbuda-labour-party tag-antigua-barbuda tag-antigus tag-breaking-news tag-died tag-dies tag-news tag-prime-minister">

	
			<figure class="post-image post-image-single">
				<picture class="attachment-dynamico-ultra-wide size-dynamico-ultra-wide wp-post-image" loading="lazy" title="Sir Lester Bird the second PM of Antigua and Barbuda dead at 83 1 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83.jpeg.webp 1365w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83-300x100.jpeg.webp 300w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83-1024x341.jpeg.webp 1024w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83-768x256.jpeg.webp 768w" sizes="(max-width: 1365px) 100vw, 1365px"/>
<img width="1365" height="455" src="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83.jpeg" alt="Former Prime Minister and National Hero Sir Lester Bird passed away on August 9, 2021." loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83.jpeg 1365w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83-300x100.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83-1024x341.jpeg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83-768x256.jpeg 768w" sizes="(max-width: 1365px) 100vw, 1365px"/>
</picture>

							</figure><!-- .post-image -->

			
	<header class="post-header entry-header">

		<h1 class="post-title entry-title">Sir Lester Bird the second PM of Antigua and Barbuda dead at 83</h1>
		<div class="entry-meta"><span class="posted-on"><a href="https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/" rel="bookmark"><time class="entry-date published" datetime="2021-09-04T14:19:14-04:00">September 4, 2021</time><time class="updated" datetime="2021-09-04T14:19:15-04:00">September 4, 2021</time></a></span><span class="posted-by"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel="author">News Contributor</a></span></span><span class="entry-comments"> <a href="https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/#respond">No comments</a></span></div>
	</header><!-- .entry-header -->

	
<div class="entry-content">

	
<p>Lester Bird was born in&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/New_York_City" rel="noreferrer noopener nofollow">New York City</a>&nbsp;on 21 February 1938. Lester and his elder brother&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/Vere_Bird_Jr." rel="noreferrer noopener nofollow">Vere Bird Jr.</a>, also a British-educated lawyer, were considered sometime rivals, with&nbsp;<em>The New York Times</em>&nbsp;writing in 1990 that Lester had always overshadowed his brother, according to those who have known them both. He was educated at Antigua Grammar School and was brought up as a Methodist. Lester Bird was a&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/Cricket" rel="noreferrer noopener nofollow">cricketer</a>&nbsp;in his youth, playing for the&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/Leeward_Islands" rel="noreferrer noopener nofollow">Leeward Islands</a>&nbsp;and a long-jump champion.&nbsp;</p>



<p>He won a bronze medal in the long jump at the 1959 Pan American Games in Chicago while representing the British West Indies. He attended the University of Michigan, an All-American long jumper, in 1960 and graduated in 1962. Bird completed his study of law in Britain and was&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/Called_to_the_bar" rel="noreferrer noopener nofollow">called to the bar</a>&nbsp;at Gray&#8217;s Inn in 1969. From 1969 to 1976, Bird engaged in private practice in Antigua.<a target="_blank" href="https://en.wikipedia.org/wiki/Lester_Bird#cite_note-East-1" rel="noreferrer noopener nofollow">[</a></p>



<p>Bird&#8217;s political career began in 1971 when he was nominated to the Senate. The frequently dominant Antigua Labour Party was in opposition for five years. The former PM of Antigua was named chairman of the ALP and the&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/Leader_of_the_opposition" rel="noreferrer noopener nofollow">opposition leader</a>&nbsp;in the Senate. Lester served as leader of the opposition until he was elected to the House of Representatives at the 1976 elections when the ALP returned to power.</p>



<p>Bird joined his father&#8217;s government as Deputy Prime Minister. In addition to serving as Deputy Prime Minister, Bird also served as Minister of Economic Development, Tourism, and Energy. Bird&#8217;s tenure as Minister of Tourism and Minister of Economic Development was controversial. He benefited from tourism partnerships with foreign investors, including in the construction of the Royal Antiguan Hotel.</p>



<p>Following independence in 1981, Bird gained the external affairs portfolio and was the first chairman of the Organization of Eastern Caribbean States in 1982. He was chairman of OECS for the second time in 1989. The ALP government and Bird himself won&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/1994_Antigua_and_Barbuda_general_election" rel="noreferrer noopener nofollow">re-election in 1994</a>&nbsp;and 1999.&nbsp;</p>



<figure class="wp-block-image size-large is-style-rounded"><a href="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-dead-at-83.jpeg"><picture loading="lazy" class="wp-image-7780" title="Sir Lester Bird the second PM of Antigua and Barbuda dead at 83 2 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-dead-at-83-1024x341.jpeg.webp 1024w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-dead-at-83-300x100.jpeg.webp 300w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-dead-at-83-768x256.jpeg.webp 768w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-dead-at-83.jpeg.webp 1365w" sizes="(max-width: 1024px) 100vw, 1024px"/>
<img loading="lazy" width="1024" height="341" src="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-dead-at-83-1024x341.jpeg" alt="Sir Lester Bird the second PM of Antigua and Barbuda died at 83" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-dead-at-83-1024x341.jpeg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-dead-at-83-300x100.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-dead-at-83-768x256.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-dead-at-83.jpeg 1365w" sizes="(max-width: 1024px) 100vw, 1024px"/>
</picture>
</a><figcaption>Sir Lester Bird the second PM of Antigua and Barbuda dead at 83 1</figcaption></figure>



<p>These elections and the 1989 elections were highly controversial; the 1989 elections were &#8220;marred by irregularities and fraud&#8221; and charges made by the opposition, described as credible by Freedom House, that the ALP used bribery and intimidation to exert undue influence on the elections supervisor. The 1999 election was deemed neither free nor fair in an independent report which concluded that the opposition United Progressive Party (UPP) &#8220;conceivably could have won a majority of seats in parliament&#8221; if the election had been fair.</p>



<p>The ALP had been divided by a succession crisis between Lester Bird and Vere Bird, Jr., since 1989. Lester Bird lost his deputy prime minister post in 1991 but retained the external affairs ministry and the planning and trade portfolio. Sir Vere Bird was initially thought to have favored Vere Jr. until an arms scandal in which the elder son had been found to have smuggled weapons from Antigua to the&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/Colombia" rel="noreferrer noopener nofollow">Colombian</a>&nbsp;Medellín Cartel.</p>



<p>Vere Bird, Jr., then Minister of Public Works, was dismissed from office. An inquiry led by Sir Louis Blom-Cooper, Q.C., recommended that he never be allowed to hold office again (although he subsequently did return to office), boosting Lester Bird&#8217;s chances to follow his father in the prime ministership and reducing pressure for Vere Bird to step down.</p>



<p>In 1992, another scandal involving Sir Vere Bird&#8217;s siphoning of public funds into a personal account furthered calls for him to step down, with three opposition parties uniting to form the UPP under the leadership of Baldwin Spencer. Following a successful&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/General_strike" rel="noreferrer noopener nofollow">general strike</a>&nbsp;called by the UPP, Sir Vere announced in March 1992 he would step down at the 1994 general elections.&nbsp;</p>



<p>The ALP succession crisis continued following this, with a special convention to elect a successor on 24 May 1992, resulting in a deadlock between Lester Bird and John St. Luce, the information minister finally settled the ALP leadership question at the party&#8217;s September 1993 convention, at which Lester won the leadership of the party, defeating St Luce, 169 votes to 131. The party post of ALP chairman went to Vere Jr.</p>



<p>In the March 1994 elections, the ALP under Bird&#8217;s leadership won 11 out of 17 seats even as the opposition criticized the ALP over corruption issues. The ALP pledged open government, an ombudsman to deal with citizen complaints, and new jobs during the election, especially tourism. Bird assumed the prime ministership on 9 March 1994.&nbsp;</p>



<p>He appointed St. Luce (but not his brother Vere Jr.) to the cabinet. (Vere Jr. was subsequently named special adviser). Lester Bird took the portfolios for external affairs, planning, social services, and information for himself. In a 1996 cabinet reshuffle, he also took the communications,&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/Civil_aviation" rel="noreferrer noopener nofollow">civil aviation</a>, international transport, and&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/Gambling" rel="noreferrer noopener nofollow">gaming</a>&nbsp;portfolios.</p>



<p>In the 1999 elections, the ALP increased its parliamentary majority by one seat, holding 12 seats. The Bird was reconfirmed as prime minister and elevated Vere Jr. to the cabinet as minister of agriculture, marking his full political rehabilitation. Bird also shuffled his portfolios and by December 2002 held the foreign affairs, finance, legal affairs, justice, and national security ministries in addition to being the prime minister.</p>



<p>In the March 2004 election, the ALP was defeated by the United Progressive Party (UPP) led by Baldwin Spencer. Bird&#8217;s party lost eight seats, and he was defeated by&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/Errol_Cort" rel="noreferrer noopener nofollow">Errol Cort</a>, who became Minister of Finance in the new UPP government.</p>



<p>Lester Bird remained the ALP&#8217;s political leader following the party&#8217;s 2004 defeat. He led the party in the March 2009 election; although the ALP lost the election, it gained three seats from the UPP, and Bird defeated Cort by 96 votes in the St John&#8217;s Rural East constituency, where he had lost in 2004. He subsequently held the position of Leader of Her Majesty&#8217;s Loyal Opposition.</p>



<p>The later Bird was succeeded as ALP leader by Gaston Browne in 2012, who led the party to victory in June 2014 general election. Bird won a seat and again defeated Errol Cort.</p>



<p>In 2014, he was made a&nbsp;<a target="_blank" href="https://en.wikipedia.org/wiki/Order_of_the_National_Hero_(Antigua_and_Barbuda)" rel="noreferrer noopener nofollow">Knight of the Order of the National Hero</a>&nbsp;(KNH) by Antigua and Barbuda.</p>
	
</div><!-- .entry-content -->

		
	<div class="entry-tags"><span class="entry-tags-label">Tagged with </span><a href="https://www.whodiedtoday.com/tag/antigua-and-barbuda/" rel="tag">Antigua and Barbuda</a>, <a href="https://www.whodiedtoday.com/tag/antigua-and-barbuda-labour-party/" rel="tag">Antigua and Barbuda Labour Party</a>, <a href="https://www.whodiedtoday.com/tag/antigua-barbuda/" rel="tag">Antigua-Barbuda</a>, <a href="https://www.whodiedtoday.com/tag/antigus/" rel="tag">Antigus</a>, <a href="https://www.whodiedtoday.com/tag/breaking-news/" rel="tag">Breaking News</a>, <a href="https://www.whodiedtoday.com/tag/died/" rel="tag">died</a>, <a href="https://www.whodiedtoday.com/tag/dies/" rel="tag">dies</a>, <a href="https://www.whodiedtoday.com/tag/news/" rel="tag">News</a>, <a href="https://www.whodiedtoday.com/tag/prime-minister/" rel="tag">Prime Minister</a></div>	<div class="entry-categories"> <ul class="post-categories">
	<li><a href="https://www.whodiedtoday.com/gone-but-not-forgotten/" rel="category tag">Gone But Not Forgotten</a></li>
	<li><a href="https://www.whodiedtoday.com/recently-died/" rel="category tag">Recently Died</a></li></ul></div>
</article>

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.whodiedtoday.com/jacques-rogge-ioc-president-for-12-years-dead-at-79/" rel="prev"><span class="nav-link-text">Previous Post</span><h3 class="entry-title">Jacques Rogge, IOC president for 12 years, dead at 79</h3></a></div><div class="nav-next"><a href="https://www.whodiedtoday.com/honorable-edward-registe-of-da-dead-at-age-50/" rel="next"><span class="nav-link-text">Next Post</span><h3 class="entry-title">Edward Registe, a Minister in Dominica&#8217;s Government dead at age 50</h3></a></div></div>
	</nav><div class="themezee-related-posts related-posts"><header class="related-posts-header"><h2 class="related-posts-title entry-title">Related Posts</h2></header>
	<div class="related-posts-grid">

		<div class="related-posts-columns related-posts-three-columns clearfix">

		
			<div class="related-post-column clearfix">

				<article id="post-7757">

					<a href="https://www.whodiedtoday.com/actor-ed-asner-who-portrayed-lou-grant-carl-from-up-dead-at-91/" rel="bookmark"><picture class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image" loading="lazy" title="Ed Asner, the actor who portrayed Lou Grant, Carl from &#039;Up,&#039; dead at 91 3 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Ed-Asner-the-actor-who-portrayed-Lou-Grant-Carl-from-Up-dead-at-91-800x440.jpeg.webp"/>
<img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Ed-Asner-the-actor-who-portrayed-Lou-Grant-Carl-from-Up-dead-at-91-800x440.jpeg" alt="Ed Asner the actor who portrayed Lou Grant Carl from Up dead at 91" loading="lazy"/>
</picture>
</a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/actor-ed-asner-who-portrayed-lou-grant-carl-from-up-dead-at-91/" rel="bookmark">Ed Asner, the actor who portrayed Lou Grant, Carl from &#8216;Up,&#8217; dead at 91</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/actor-ed-asner-who-portrayed-lou-grant-carl-from-up-dead-at-91/" title="4:12 PM" rel="bookmark"><time class="entry-date published updated" datetime="2021-08-29T16:12:21-04:00">August 29, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel="author">News Contributor</a></span></span>
		</div>

	
				</article>

			</div>

		
			<div class="related-post-column clearfix">

				<article id="post-7732">

					<a href="https://www.whodiedtoday.com/nanci-griffith-grammy-winning-singer-songwriter-dead-at-68/" rel="bookmark"><picture class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image" loading="lazy" title="Nanci Griffith, Grammy-Winning Singer-Songwriter, Dead at 68 4 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Nanci-Griffith-Grammy-Winning-Singer-Songwriter-Dead-at-68-800x440.jpeg.webp"/>
<img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Nanci-Griffith-Grammy-Winning-Singer-Songwriter-Dead-at-68-800x440.jpeg" alt="Nanci Griffith, Grammy-Winning Singer-Songwriter, Dead at 68" loading="lazy"/>
</picture>
</a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/nanci-griffith-grammy-winning-singer-songwriter-dead-at-68/" rel="bookmark">Nanci Griffith, Grammy-Winning Singer-Songwriter, Dead at 68</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/nanci-griffith-grammy-winning-singer-songwriter-dead-at-68/" title="5:27 PM" rel="bookmark"><time class="entry-date published updated" datetime="2021-08-13T17:27:18-04:00">August 13, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel="author">News Contributor</a></span></span>
		</div>

	
				</article>

			</div>

		
			<div class="related-post-column clearfix">

				<article id="post-7678">

					<a href="https://www.whodiedtoday.com/chucky-thompson-90s-hip-hop-and-rb-producer-died/" rel="bookmark"><picture class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image" loading="lazy" title="Chucky Thompson, ’90s Hip-Hop and R&amp;B Producer With Bad Boy’s Hitmen, is dead 5 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Chucky-Thompson-Hip-Hop-and-RB-Producer-is-dead-800x440.jpeg.webp"/>
<img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Chucky-Thompson-Hip-Hop-and-RB-Producer-is-dead-800x440.jpeg" alt="Chucky Thompson, ’90s Hip-Hop and R&amp;B Producer With Bad Boy’s Hitmen, is dead" loading="lazy"/>
</picture>
</a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/chucky-thompson-90s-hip-hop-and-rb-producer-died/" rel="bookmark">Chucky Thompson, ’90s Hip-Hop and R&#038;B Producer With Bad Boy’s Hitmen, is dead</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/chucky-thompson-90s-hip-hop-and-rb-producer-died/" title="9:05 PM" rel="bookmark"><time class="entry-date published updated" datetime="2021-08-09T21:05:32-04:00">August 9, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel="author">News Contributor</a></span></span>
		</div>

	
				</article>

			</div>

		
			<div class="related-post-column clearfix">

				<article id="post-7632">

					<a href="https://www.whodiedtoday.com/j-r-richard-power-pitcher-for-astros-dies-at-71/" rel="bookmark"><picture class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image" loading="lazy" title="J.R. Richard, power pitcher for Astros in the &#039;70s, dead at 71 6 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/J.R.-Richard-power-pitcher-for-Astros-in-the-70s-dies-at-71-800x440.jpeg.webp"/>
<img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/J.R.-Richard-power-pitcher-for-Astros-in-the-70s-dies-at-71-800x440.jpeg" alt="J.R. Richard, power pitcher for Astros in the &#039;70s, dies at 71" loading="lazy"/>
</picture>
</a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/j-r-richard-power-pitcher-for-astros-dies-at-71/" rel="bookmark">J.R. Richard, power pitcher for Astros in the &#8217;70s, dead at 71</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/j-r-richard-power-pitcher-for-astros-dies-at-71/" title="9:28 PM" rel="bookmark"><time class="entry-date published updated" datetime="2021-08-05T21:28:35-04:00">August 5, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel="author">News Contributor</a></span></span>
		</div>

	
				</article>

			</div>

		
			<div class="related-post-column clearfix">

				<article id="post-7621">

					<a href="https://www.whodiedtoday.com/anthony-barajas-a-tiktok-star-died-at-age-19/" rel="bookmark"><picture class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image" loading="lazy" title="Anthony Barajas, a Tik Tok Star, Dead at age 19 7 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Anthony-Barajas-a-TikTok-Star-Died-at-age-19-800x440.jpeg.webp"/>
<img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Anthony-Barajas-a-TikTok-Star-Died-at-age-19-800x440.jpeg" alt="Anthony Barajas, a TikTok Star, Died at age 19" loading="lazy"/>
</picture>
</a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/anthony-barajas-a-tiktok-star-died-at-age-19/" rel="bookmark">Anthony Barajas, a Tik Tok Star, Dead at age 19</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/anthony-barajas-a-tiktok-star-died-at-age-19/" title="8:59 PM" rel="bookmark"><time class="entry-date published updated" datetime="2021-08-01T20:59:24-04:00">August 1, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel="author">News Contributor</a></span></span>
		</div>

	
				</article>

			</div>

		
			<div class="related-post-column clearfix">

				<article id="post-7611">

					<a href="https://www.whodiedtoday.com/noah-gesser-16-year-old-rising-soccer-star-is-dead/" rel="bookmark"><picture class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image" loading="lazy" title="Noah Gesser 16-Year-Old Rising Soccer Star is dead 8 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Noah-Gesser-16-Year-Old-Rising-Soccer-Star-Died-in-Car-Crash-800x440.jpeg.webp"/>
<img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Noah-Gesser-16-Year-Old-Rising-Soccer-Star-Died-in-Car-Crash-800x440.jpeg" alt="Noah Gesser 16-Year-Old Rising Soccer Star Died in Car Crash" loading="lazy"/>
</picture>
</a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/noah-gesser-16-year-old-rising-soccer-star-is-dead/" rel="bookmark">Noah Gesser 16-Year-Old Rising Soccer Star  is dead</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/noah-gesser-16-year-old-rising-soccer-star-is-dead/" title="10:35 AM" rel="bookmark"><time class="entry-date published updated" datetime="2021-08-01T10:35:08-04:00">August 1, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel="author">News Contributor</a></span></span>
		</div>

	
				</article>

			</div>

		
		</div>

	</div>

</div>
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/lester-bird-former-antigua-and-barbuda-pm-died-at-83/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.whodiedtoday.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='7776' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="26d0e0db27" /></p><input type="hidden" id="ak_js" name="ak_js" value="226"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->

		</main><!-- #main -->

		
	<section id="secondary" class="sidebar widget-area" role="complementary">

		<div id="tzwb-recent-posts-5" class="widget tzwb-recent-posts"><h3 class="widget-title">Latest Death</h3>
		<div class="tzwb-content tzwb-clearfix">

			<ul class="tzwb-posts-list">
				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/dead-at-54-is-actor-michael-k-williams/" title="Dead at 54 is Actor Michael K. Williams, who starred as Omar on &#8216;The Wire.&#8217;">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Dead at 54 is Actor Michael K. Williams, who starred as Omar on &#039;The Wire.&#039; 9 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Dead-at-54-is-Actor-Michael-K.-Williams-who-starred-as-Omar-on-The-Wire-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Dead-at-54-is-Actor-Michael-K.-Williams-who-starred-as-Omar-on-The-Wire-150x150.jpeg" alt="Dead at 54 is Actor Michael K. Williams, who starred as Omar on &#039;The Wire.&#039;" loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/dead-at-54-is-actor-michael-k-williams/" title="Dead at 54 is Actor Michael K. Williams, who starred as Omar on &#8216;The Wire.&#8217;">
						Dead at 54 is Actor Michael K. Williams, who starred as Omar on &#8216;The Wire.&#8217;					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/jean-paul-belmondo-star-of-breathless-dead-at-88/" title="Jean-Paul Belmondo, star of &#8216;Breathless,&#8217; dead at 88">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Jean-Paul Belmondo, star of &#039;Breathless,&#039; dead at 88 10 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Jean-Paul-Belmondo-star-of-Breathless-dead-at-88-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Jean-Paul-Belmondo-star-of-Breathless-dead-at-88-150x150.jpeg" alt="Jean-Paul Belmondo, star of &#039;Breathless,&#039; dead at 88" loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/jean-paul-belmondo-star-of-breathless-dead-at-88/" title="Jean-Paul Belmondo, star of &#8216;Breathless,&#8217; dead at 88">
						Jean-Paul Belmondo, star of &#8216;Breathless,&#8217; dead at 88					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/jacques-rogge-ioc-president-for-12-years-dead-at-79/" title="Jacques Rogge, IOC president for 12 years, dead at 79">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Jacques Rogge, IOC president for 12 years, dead at 79 11 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Jacques-Rogge-IOC-president-for-12-years-dead-at-79-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Jacques-Rogge-IOC-president-for-12-years-dead-at-79-150x150.jpeg" alt="Jacques Rogge, IOC president for 12 years, dead at 79" loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/jacques-rogge-ioc-president-for-12-years-dead-at-79/" title="Jacques Rogge, IOC president for 12 years, dead at 79">
						Jacques Rogge, IOC president for 12 years, dead at 79					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/actor-ed-asner-who-portrayed-lou-grant-carl-from-up-dead-at-91/" title="Ed Asner, the actor who portrayed Lou Grant, Carl from &#8216;Up,&#8217; dead at 91">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Ed Asner, the actor who portrayed Lou Grant, Carl from &#039;Up,&#039; dead at 91 12 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Ed-Asner-the-actor-who-portrayed-Lou-Grant-Carl-from-Up-dead-at-91-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Ed-Asner-the-actor-who-portrayed-Lou-Grant-Carl-from-Up-dead-at-91-150x150.jpeg" alt="Ed Asner the actor who portrayed Lou Grant Carl from Up dead at 91" loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/actor-ed-asner-who-portrayed-lou-grant-carl-from-up-dead-at-91/" title="Ed Asner, the actor who portrayed Lou Grant, Carl from &#8216;Up,&#8217; dead at 91">
						Ed Asner, the actor who portrayed Lou Grant, Carl from &#8216;Up,&#8217; dead at 91					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/sonny-chiba-iconic-star-died-of-covid-19-complications/" title="Sonny Chiba Iconic ‘Kill Bill’ &#038; ‘Tokyo Drift’ Star  Died Of COVID-19 Complications">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Sonny Chiba Iconic ‘Kill Bill’ &amp; ‘Tokyo Drift’ Star Died Of COVID-19 Complications 13 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Sonny-Chiba-Iconic-‘Kill-Bill-‘Tokyo-Drift-Star-Died-Of-COVID-19-Complications-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Sonny-Chiba-Iconic-‘Kill-Bill-‘Tokyo-Drift-Star-Died-Of-COVID-19-Complications-150x150.jpeg" alt="Sonny Chiba Iconic ‘Kill Bill’ &amp; ‘Tokyo Drift’ Star Died Of COVID-19 Complications" loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/sonny-chiba-iconic-star-died-of-covid-19-complications/" title="Sonny Chiba Iconic ‘Kill Bill’ &#038; ‘Tokyo Drift’ Star  Died Of COVID-19 Complications">
						Sonny Chiba Iconic ‘Kill Bill’ &#038; ‘Tokyo Drift’ Star  Died Of COVID-19 Complications					</a>

							</ul>

		</div>

		</div><div id="tzwb-recent-posts-4" class="widget tzwb-recent-posts"><h3 class="widget-title">Random  Post Today</h3>
		<div class="tzwb-content tzwb-clearfix">

			<ul class="tzwb-posts-list">
				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/legendary-singer-betty-wright-dead-at-66/" title="Legendary singer Betty Wright dead at 66">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Legendary singer Betty Wright dead at 66 14 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-75x75.jpg.webp 75w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-150x150.jpg.webp 150w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-90x90.jpg.webp 90w" sizes="(max-width: 75px) 100vw, 75px"/>
<img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-75x75.jpg" alt="Betty Wright Legendary singer Betty Wright dead at 66" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/legendary-singer-betty-wright-dead-at-66/" title="Legendary singer Betty Wright dead at 66">
						Legendary singer Betty Wright dead at 66					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/west-indies-great-sir-everton-weekes-dead-at-95/" title="Sir Everton Weekes West Indies Cricket icon, dead at 95">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Sir Everton Weekes West Indies Cricket icon, dead at 95 15 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Sir-Everton-Weekes-West-Indies-Cricket-Great-Dead-at-95-75x75.jpg.webp 75w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Sir-Everton-Weekes-West-Indies-Cricket-Great-Dead-at-95-150x150.jpg.webp 150w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Sir-Everton-Weekes-West-Indies-Cricket-Great-Dead-at-95-90x90.jpg.webp 90w" sizes="(max-width: 75px) 100vw, 75px"/>
<img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Sir-Everton-Weekes-West-Indies-Cricket-Great-Dead-at-95-75x75.jpg" alt="Sir Everton Weekes West Indies Cricket Great, Dead at 95" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Sir-Everton-Weekes-West-Indies-Cricket-Great-Dead-at-95-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Sir-Everton-Weekes-West-Indies-Cricket-Great-Dead-at-95-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Sir-Everton-Weekes-West-Indies-Cricket-Great-Dead-at-95-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/west-indies-great-sir-everton-weekes-dead-at-95/" title="Sir Everton Weekes West Indies Cricket icon, dead at 95">
						Sir Everton Weekes West Indies Cricket icon, dead at 95					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/iconic-fashion-designer-oscar-de-la-renta-dies-at-82/" title="Iconic Fashion Designer Oscar de la Renta Dies at 82">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Iconic Fashion Designer Oscar de la Renta Dies at 82 16 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2014/10/oscar_de_la_renta_jef-75x75.jpg.webp 75w, https://www.whodiedtoday.com/wp-content/uploads/2014/10/oscar_de_la_renta_jef-150x150.jpg.webp 150w" sizes="(max-width: 75px) 100vw, 75px"/>
<img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2014/10/oscar_de_la_renta_jef-75x75.jpg" alt="Oscar de la Renta, legendary fashion designer, dies at 82" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2014/10/oscar_de_la_renta_jef-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2014/10/oscar_de_la_renta_jef-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2014/10/oscar_de_la_renta_jef-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/iconic-fashion-designer-oscar-de-la-renta-dies-at-82/" title="Iconic Fashion Designer Oscar de la Renta Dies at 82">
						Iconic Fashion Designer Oscar de la Renta Dies at 82					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/hussain-muhammad-ershad-dead-at-89/" title="Hussain Muhammad Ershad former Bangladesh army ruler dead at 89">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Hussain Muhammad Ershad former Bangladesh army ruler dead at 89 17 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2019/07/Hussain-Muhammad-Ershad-75x75.png.webp 75w, https://www.whodiedtoday.com/wp-content/uploads/2019/07/Hussain-Muhammad-Ershad-150x150.png.webp 150w" sizes="(max-width: 75px) 100vw, 75px"/>
<img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2019/07/Hussain-Muhammad-Ershad-75x75.png" alt="Hussain Muhammad Ershad died at 89" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2019/07/Hussain-Muhammad-Ershad-75x75.png 75w, https://www.whodiedtoday.com/wp-content/uploads/2019/07/Hussain-Muhammad-Ershad-150x150.png 150w, https://www.whodiedtoday.com/wp-content/uploads/2019/07/Hussain-Muhammad-Ershad-90x90.png 90w" sizes="(max-width: 75px) 100vw, 75px"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/hussain-muhammad-ershad-dead-at-89/" title="Hussain Muhammad Ershad former Bangladesh army ruler dead at 89">
						Hussain Muhammad Ershad former Bangladesh army ruler dead at 89					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/marvel-comics-legend-stan-lee/" title="Marvel Comics legend Stan Lee dead at 95">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Marvel Comics legend Stan Lee dead at 95 18 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2018/11/Marvel-Comics-legend-Stan-Lee-dead-at-95-75x75.jpg.webp 75w, https://www.whodiedtoday.com/wp-content/uploads/2018/11/Marvel-Comics-legend-Stan-Lee-dead-at-95-150x150.jpg.webp 150w" sizes="(max-width: 75px) 100vw, 75px"/>
<img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2018/11/Marvel-Comics-legend-Stan-Lee-dead-at-95-75x75.jpg" alt="Marvel Comics legend Stan Lee" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2018/11/Marvel-Comics-legend-Stan-Lee-dead-at-95-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2018/11/Marvel-Comics-legend-Stan-Lee-dead-at-95-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2018/11/Marvel-Comics-legend-Stan-Lee-dead-at-95-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/marvel-comics-legend-stan-lee/" title="Marvel Comics legend Stan Lee dead at 95">
						Marvel Comics legend Stan Lee dead at 95					</a>

							</ul>

		</div>

		</div><div id="archives-2" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://www.whodiedtoday.com/2021/09/'> September 2021 &nbsp;(4)</option>
	<option value='https://www.whodiedtoday.com/2021/08/'> August 2021 &nbsp;(21)</option>
	<option value='https://www.whodiedtoday.com/2021/07/'> July 2021 &nbsp;(8)</option>
	<option value='https://www.whodiedtoday.com/2021/06/'> June 2021 &nbsp;(7)</option>
	<option value='https://www.whodiedtoday.com/2021/05/'> May 2021 &nbsp;(4)</option>
	<option value='https://www.whodiedtoday.com/2021/04/'> April 2021 &nbsp;(5)</option>
	<option value='https://www.whodiedtoday.com/2021/03/'> March 2021 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2021/02/'> February 2021 &nbsp;(5)</option>
	<option value='https://www.whodiedtoday.com/2021/01/'> January 2021 &nbsp;(10)</option>
	<option value='https://www.whodiedtoday.com/2020/12/'> December 2020 &nbsp;(31)</option>
	<option value='https://www.whodiedtoday.com/2020/11/'> November 2020 &nbsp;(7)</option>
	<option value='https://www.whodiedtoday.com/2020/10/'> October 2020 &nbsp;(9)</option>
	<option value='https://www.whodiedtoday.com/2020/09/'> September 2020 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2020/08/'> August 2020 &nbsp;(7)</option>
	<option value='https://www.whodiedtoday.com/2020/07/'> July 2020 &nbsp;(17)</option>
	<option value='https://www.whodiedtoday.com/2020/06/'> June 2020 &nbsp;(5)</option>
	<option value='https://www.whodiedtoday.com/2020/05/'> May 2020 &nbsp;(14)</option>
	<option value='https://www.whodiedtoday.com/2020/04/'> April 2020 &nbsp;(17)</option>
	<option value='https://www.whodiedtoday.com/2020/03/'> March 2020 &nbsp;(21)</option>
	<option value='https://www.whodiedtoday.com/2020/02/'> February 2020 &nbsp;(11)</option>
	<option value='https://www.whodiedtoday.com/2020/01/'> January 2020 &nbsp;(9)</option>
	<option value='https://www.whodiedtoday.com/2019/12/'> December 2019 &nbsp;(6)</option>
	<option value='https://www.whodiedtoday.com/2019/10/'> October 2019 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2019/09/'> September 2019 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2019/08/'> August 2019 &nbsp;(4)</option>
	<option value='https://www.whodiedtoday.com/2019/07/'> July 2019 &nbsp;(7)</option>
	<option value='https://www.whodiedtoday.com/2019/06/'> June 2019 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2019/05/'> May 2019 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2019/03/'> March 2019 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2019/02/'> February 2019 &nbsp;(5)</option>
	<option value='https://www.whodiedtoday.com/2019/01/'> January 2019 &nbsp;(5)</option>
	<option value='https://www.whodiedtoday.com/2018/12/'> December 2018 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2018/11/'> November 2018 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2018/10/'> October 2018 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2018/09/'> September 2018 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2018/08/'> August 2018 &nbsp;(6)</option>
	<option value='https://www.whodiedtoday.com/2018/07/'> July 2018 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2018/06/'> June 2018 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2018/05/'> May 2018 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2018/04/'> April 2018 &nbsp;(7)</option>
	<option value='https://www.whodiedtoday.com/2018/02/'> February 2018 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2018/01/'> January 2018 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2017/12/'> December 2017 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2017/11/'> November 2017 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2017/10/'> October 2017 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2017/08/'> August 2017 &nbsp;(4)</option>
	<option value='https://www.whodiedtoday.com/2017/07/'> July 2017 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2017/06/'> June 2017 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2017/05/'> May 2017 &nbsp;(5)</option>
	<option value='https://www.whodiedtoday.com/2017/04/'> April 2017 &nbsp;(8)</option>
	<option value='https://www.whodiedtoday.com/2017/03/'> March 2017 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2017/02/'> February 2017 &nbsp;(7)</option>
	<option value='https://www.whodiedtoday.com/2017/01/'> January 2017 &nbsp;(11)</option>
	<option value='https://www.whodiedtoday.com/2016/12/'> December 2016 &nbsp;(24)</option>
	<option value='https://www.whodiedtoday.com/2016/11/'> November 2016 &nbsp;(34)</option>
	<option value='https://www.whodiedtoday.com/2016/10/'> October 2016 &nbsp;(24)</option>
	<option value='https://www.whodiedtoday.com/2016/09/'> September 2016 &nbsp;(36)</option>
	<option value='https://www.whodiedtoday.com/2016/08/'> August 2016 &nbsp;(20)</option>
	<option value='https://www.whodiedtoday.com/2016/07/'> July 2016 &nbsp;(30)</option>
	<option value='https://www.whodiedtoday.com/2016/06/'> June 2016 &nbsp;(13)</option>
	<option value='https://www.whodiedtoday.com/2016/05/'> May 2016 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2016/04/'> April 2016 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2016/03/'> March 2016 &nbsp;(7)</option>
	<option value='https://www.whodiedtoday.com/2016/02/'> February 2016 &nbsp;(6)</option>
	<option value='https://www.whodiedtoday.com/2016/01/'> January 2016 &nbsp;(8)</option>
	<option value='https://www.whodiedtoday.com/2015/12/'> December 2015 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2015/11/'> November 2015 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2015/10/'> October 2015 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2015/09/'> September 2015 &nbsp;(7)</option>
	<option value='https://www.whodiedtoday.com/2015/08/'> August 2015 &nbsp;(10)</option>
	<option value='https://www.whodiedtoday.com/2015/07/'> July 2015 &nbsp;(9)</option>
	<option value='https://www.whodiedtoday.com/2015/06/'> June 2015 &nbsp;(6)</option>
	<option value='https://www.whodiedtoday.com/2015/05/'> May 2015 &nbsp;(8)</option>
	<option value='https://www.whodiedtoday.com/2015/04/'> April 2015 &nbsp;(8)</option>
	<option value='https://www.whodiedtoday.com/2015/03/'> March 2015 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2015/02/'> February 2015 &nbsp;(8)</option>
	<option value='https://www.whodiedtoday.com/2015/01/'> January 2015 &nbsp;(18)</option>
	<option value='https://www.whodiedtoday.com/2014/12/'> December 2014 &nbsp;(7)</option>
	<option value='https://www.whodiedtoday.com/2014/11/'> November 2014 &nbsp;(11)</option>
	<option value='https://www.whodiedtoday.com/2014/10/'> October 2014 &nbsp;(21)</option>
	<option value='https://www.whodiedtoday.com/2014/09/'> September 2014 &nbsp;(6)</option>
	<option value='https://www.whodiedtoday.com/2014/08/'> August 2014 &nbsp;(10)</option>
	<option value='https://www.whodiedtoday.com/2014/07/'> July 2014 &nbsp;(5)</option>
	<option value='https://www.whodiedtoday.com/2014/06/'> June 2014 &nbsp;(6)</option>
	<option value='https://www.whodiedtoday.com/2014/05/'> May 2014 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2014/04/'> April 2014 &nbsp;(6)</option>
	<option value='https://www.whodiedtoday.com/2014/03/'> March 2014 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2014/02/'> February 2014 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2014/01/'> January 2014 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2013/12/'> December 2013 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2013/08/'> August 2013 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2013/07/'> July 2013 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2013/05/'> May 2013 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2013/04/'> April 2013 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2013/03/'> March 2013 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2013/02/'> February 2013 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2012/12/'> December 2012 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2012/11/'> November 2012 &nbsp;(4)</option>
	<option value='https://www.whodiedtoday.com/2012/10/'> October 2012 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2012/09/'> September 2012 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2012/08/'> August 2012 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2012/07/'> July 2012 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2012/05/'> May 2012 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2012/03/'> March 2012 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2012/02/'> February 2012 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2012/01/'> January 2012 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2011/12/'> December 2011 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2011/11/'> November 2011 &nbsp;(4)</option>
	<option value='https://www.whodiedtoday.com/2011/10/'> October 2011 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2011/08/'> August 2011 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2011/07/'> July 2011 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2011/06/'> June 2011 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2011/05/'> May 2011 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2011/04/'> April 2011 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2011/03/'> March 2011 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2011/01/'> January 2011 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2010/12/'> December 2010 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2010/11/'> November 2010 &nbsp;(4)</option>
	<option value='https://www.whodiedtoday.com/2010/10/'> October 2010 &nbsp;(10)</option>
	<option value='https://www.whodiedtoday.com/2010/09/'> September 2010 &nbsp;(8)</option>
	<option value='https://www.whodiedtoday.com/2010/08/'> August 2010 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2010/07/'> July 2010 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2008/11/'> November 2008 &nbsp;(4)</option>
	<option value='https://www.whodiedtoday.com/2008/05/'> May 2008 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2008/04/'> April 2008 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2008/03/'> March 2008 &nbsp;(4)</option>
	<option value='https://www.whodiedtoday.com/2008/02/'> February 2008 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2008/01/'> January 2008 &nbsp;(2)</option>
	<option value='https://www.whodiedtoday.com/2007/11/'> November 2007 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2007/10/'> October 2007 &nbsp;(3)</option>
	<option value='https://www.whodiedtoday.com/2007/09/'> September 2007 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2007/08/'> August 2007 &nbsp;(1)</option>
	<option value='https://www.whodiedtoday.com/2007/06/'> June 2007 &nbsp;(12)</option>
	<option value='https://www.whodiedtoday.com/2006/06/'> June 2006 &nbsp;(1)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</div><div id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Single post - 2 (weightloss.bobofindit.com) -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4823718395360608"
     data-ad-slot="6986591440"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="tag_cloud-2" class="widget widget_tag_cloud"><h3 class="widget-title">Tag Cloud</h3><div class="tagcloud"><a href="https://www.whodiedtoday.com/tag/actor/" class="tag-cloud-link tag-link-40 tag-link-position-1" style="font-size: 19.2pt;" aria-label="Actor (51 items)">Actor<span class="tag-link-count"> (51)</span></a>
<a href="https://www.whodiedtoday.com/tag/actors/" class="tag-cloud-link tag-link-331 tag-link-position-2" style="font-size: 10.8pt;" aria-label="Actors (14 items)">Actors<span class="tag-link-count"> (14)</span></a>
<a href="https://www.whodiedtoday.com/tag/actress/" class="tag-cloud-link tag-link-60 tag-link-position-3" style="font-size: 17.955555555556pt;" aria-label="actress (43 items)">actress<span class="tag-link-count"> (43)</span></a>
<a href="https://www.whodiedtoday.com/tag/america/" class="tag-cloud-link tag-link-1100 tag-link-position-4" style="font-size: 16.4pt;" aria-label="America (34 items)">America<span class="tag-link-count"> (34)</span></a>
<a href="https://www.whodiedtoday.com/tag/attorney/" class="tag-cloud-link tag-link-2350 tag-link-position-5" style="font-size: 9.7111111111111pt;" aria-label="Attorney (12 items)">Attorney<span class="tag-link-count"> (12)</span></a>
<a href="https://www.whodiedtoday.com/tag/author/" class="tag-cloud-link tag-link-2719 tag-link-position-6" style="font-size: 8.6222222222222pt;" aria-label="Author (10 items)">Author<span class="tag-link-count"> (10)</span></a>
<a href="https://www.whodiedtoday.com/tag/breaking-news/" class="tag-cloud-link tag-link-1258 tag-link-position-7" style="font-size: 16.244444444444pt;" aria-label="Breaking News (33 items)">Breaking News<span class="tag-link-count"> (33)</span></a>
<a href="https://www.whodiedtoday.com/tag/canada/" class="tag-cloud-link tag-link-32 tag-link-position-8" style="font-size: 12.044444444444pt;" aria-label="Canada (17 items)">Canada<span class="tag-link-count"> (17)</span></a>
<a href="https://www.whodiedtoday.com/tag/cancer/" class="tag-cloud-link tag-link-80 tag-link-position-9" style="font-size: 8pt;" aria-label="cancer (9 items)">cancer<span class="tag-link-count"> (9)</span></a>
<a href="https://www.whodiedtoday.com/tag/captain/" class="tag-cloud-link tag-link-3388 tag-link-position-10" style="font-size: 10.333333333333pt;" aria-label="Captain (13 items)">Captain<span class="tag-link-count"> (13)</span></a>
<a href="https://www.whodiedtoday.com/tag/caribbean/" class="tag-cloud-link tag-link-68 tag-link-position-11" style="font-size: 9.2444444444444pt;" aria-label="Caribbean (11 items)">Caribbean<span class="tag-link-count"> (11)</span></a>
<a href="https://www.whodiedtoday.com/tag/cbs/" class="tag-cloud-link tag-link-2132 tag-link-position-12" style="font-size: 11.111111111111pt;" aria-label="cbs (15 items)">cbs<span class="tag-link-count"> (15)</span></a>
<a href="https://www.whodiedtoday.com/tag/chairman/" class="tag-cloud-link tag-link-16 tag-link-position-13" style="font-size: 9.7111111111111pt;" aria-label="chairman (12 items)">chairman<span class="tag-link-count"> (12)</span></a>
<a href="https://www.whodiedtoday.com/tag/dead/" class="tag-cloud-link tag-link-42 tag-link-position-14" style="font-size: 12.977777777778pt;" aria-label="Dead (20 items)">Dead<span class="tag-link-count"> (20)</span></a>
<a href="https://www.whodiedtoday.com/tag/death/" class="tag-cloud-link tag-link-330 tag-link-position-15" style="font-size: 12.355555555556pt;" aria-label="Death (18 items)">Death<span class="tag-link-count"> (18)</span></a>
<a href="https://www.whodiedtoday.com/tag/died/" class="tag-cloud-link tag-link-63 tag-link-position-16" style="font-size: 17.955555555556pt;" aria-label="died (43 items)">died<span class="tag-link-count"> (43)</span></a>
<a href="https://www.whodiedtoday.com/tag/dies/" class="tag-cloud-link tag-link-62 tag-link-position-17" style="font-size: 17.955555555556pt;" aria-label="dies (43 items)">dies<span class="tag-link-count"> (43)</span></a>
<a href="https://www.whodiedtoday.com/tag/disaster-accident/" class="tag-cloud-link tag-link-3401 tag-link-position-18" style="font-size: 9.2444444444444pt;" aria-label="Disaster Accident (11 items)">Disaster Accident<span class="tag-link-count"> (11)</span></a>
<a href="https://www.whodiedtoday.com/tag/dominica/" class="tag-cloud-link tag-link-121 tag-link-position-19" style="font-size: 10.8pt;" aria-label="Dominica (14 items)">Dominica<span class="tag-link-count"> (14)</span></a>
<a href="https://www.whodiedtoday.com/tag/dominica-grammar-school/" class="tag-cloud-link tag-link-4213 tag-link-position-20" style="font-size: 8pt;" aria-label="Dominica Grammar School (9 items)">Dominica Grammar School<span class="tag-link-count"> (9)</span></a>
<a href="https://www.whodiedtoday.com/tag/entertainment/" class="tag-cloud-link tag-link-463 tag-link-position-21" style="font-size: 9.2444444444444pt;" aria-label="Entertainment (11 items)">Entertainment<span class="tag-link-count"> (11)</span></a>
<a href="https://www.whodiedtoday.com/tag/entertainment-culture/" class="tag-cloud-link tag-link-3234 tag-link-position-22" style="font-size: 11.577777777778pt;" aria-label="Entertainment Culture (16 items)">Entertainment Culture<span class="tag-link-count"> (16)</span></a>
<a href="https://www.whodiedtoday.com/tag/human-interest/" class="tag-cloud-link tag-link-3235 tag-link-position-23" style="font-size: 12.044444444444pt;" aria-label="Human Interest (17 items)">Human Interest<span class="tag-link-count"> (17)</span></a>
<a href="https://www.whodiedtoday.com/tag/instagram/" class="tag-cloud-link tag-link-3470 tag-link-position-24" style="font-size: 10.8pt;" aria-label="Instagram (14 items)">Instagram<span class="tag-link-count"> (14)</span></a>
<a href="https://www.whodiedtoday.com/tag/mayor/" class="tag-cloud-link tag-link-1083 tag-link-position-25" style="font-size: 8pt;" aria-label="mayor (9 items)">mayor<span class="tag-link-count"> (9)</span></a>
<a href="https://www.whodiedtoday.com/tag/nbc-news/" class="tag-cloud-link tag-link-2191 tag-link-position-26" style="font-size: 8.6222222222222pt;" aria-label="NBC News (10 items)">NBC News<span class="tag-link-count"> (10)</span></a>
<a href="https://www.whodiedtoday.com/tag/new-jersey/" class="tag-cloud-link tag-link-2616 tag-link-position-27" style="font-size: 9.7111111111111pt;" aria-label="New Jersey (12 items)">New Jersey<span class="tag-link-count"> (12)</span></a>
<a href="https://www.whodiedtoday.com/tag/news/" class="tag-cloud-link tag-link-465 tag-link-position-28" style="font-size: 22pt;" aria-label="News (79 items)">News<span class="tag-link-count"> (79)</span></a>
<a href="https://www.whodiedtoday.com/tag/philadelphia/" class="tag-cloud-link tag-link-512 tag-link-position-29" style="font-size: 8pt;" aria-label="Philadelphia (9 items)">Philadelphia<span class="tag-link-count"> (9)</span></a>
<a href="https://www.whodiedtoday.com/tag/politics/" class="tag-cloud-link tag-link-479 tag-link-position-30" style="font-size: 10.8pt;" aria-label="Politics (14 items)">Politics<span class="tag-link-count"> (14)</span></a>
<a href="https://www.whodiedtoday.com/tag/president/" class="tag-cloud-link tag-link-15 tag-link-position-31" style="font-size: 16.711111111111pt;" aria-label="president (35 items)">president<span class="tag-link-count"> (35)</span></a>
<a href="https://www.whodiedtoday.com/tag/prime-minister/" class="tag-cloud-link tag-link-3274 tag-link-position-32" style="font-size: 15pt;" aria-label="Prime Minister (27 items)">Prime Minister<span class="tag-link-count"> (27)</span></a>
<a href="https://www.whodiedtoday.com/tag/queen/" class="tag-cloud-link tag-link-3483 tag-link-position-33" style="font-size: 8.6222222222222pt;" aria-label="queen (10 items)">queen<span class="tag-link-count"> (10)</span></a>
<a href="https://www.whodiedtoday.com/tag/rt/" class="tag-cloud-link tag-link-1216 tag-link-position-34" style="font-size: 13.911111111111pt;" aria-label="RT (23 items)">RT<span class="tag-link-count"> (23)</span></a>
<a href="https://www.whodiedtoday.com/tag/singer/" class="tag-cloud-link tag-link-462 tag-link-position-35" style="font-size: 12.355555555556pt;" aria-label="Singer (18 items)">Singer<span class="tag-link-count"> (18)</span></a>
<a href="https://www.whodiedtoday.com/tag/social-media/" class="tag-cloud-link tag-link-1109 tag-link-position-36" style="font-size: 8.6222222222222pt;" aria-label="Social Media (10 items)">Social Media<span class="tag-link-count"> (10)</span></a>
<a href="https://www.whodiedtoday.com/tag/sports/" class="tag-cloud-link tag-link-1555 tag-link-position-37" style="font-size: 8.6222222222222pt;" aria-label="sports (10 items)">sports<span class="tag-link-count"> (10)</span></a>
<a href="https://www.whodiedtoday.com/tag/television/" class="tag-cloud-link tag-link-79 tag-link-position-38" style="font-size: 8.6222222222222pt;" aria-label="television (10 items)">television<span class="tag-link-count"> (10)</span></a>
<a href="https://www.whodiedtoday.com/tag/texas/" class="tag-cloud-link tag-link-652 tag-link-position-39" style="font-size: 13.288888888889pt;" aria-label="texas (21 items)">texas<span class="tag-link-count"> (21)</span></a>
<a href="https://www.whodiedtoday.com/tag/the-associated-press/" class="tag-cloud-link tag-link-3450 tag-link-position-40" style="font-size: 12.355555555556pt;" aria-label="the Associated Press (18 items)">the Associated Press<span class="tag-link-count"> (18)</span></a>
<a href="https://www.whodiedtoday.com/tag/the-new-york-times/" class="tag-cloud-link tag-link-3188 tag-link-position-41" style="font-size: 9.2444444444444pt;" aria-label="The New York Times (11 items)">The New York Times<span class="tag-link-count"> (11)</span></a>
<a href="https://www.whodiedtoday.com/tag/today/" class="tag-cloud-link tag-link-2318 tag-link-position-42" style="font-size: 8pt;" aria-label="Today (9 items)">Today<span class="tag-link-count"> (9)</span></a>
<a href="https://www.whodiedtoday.com/tag/twitter/" class="tag-cloud-link tag-link-1110 tag-link-position-43" style="font-size: 9.2444444444444pt;" aria-label="Twitter (11 items)">Twitter<span class="tag-link-count"> (11)</span></a>
<a href="https://www.whodiedtoday.com/tag/united-kingdom/" class="tag-cloud-link tag-link-1770 tag-link-position-44" style="font-size: 11.577777777778pt;" aria-label="United Kingdom (16 items)">United Kingdom<span class="tag-link-count"> (16)</span></a>
<a href="https://www.whodiedtoday.com/tag/united-states/" class="tag-cloud-link tag-link-869 tag-link-position-45" style="font-size: 12.666666666667pt;" aria-label="united states (19 items)">united states<span class="tag-link-count"> (19)</span></a></div>
</div>
	</section><!-- #secondary -->

	
	</div><!-- #content -->

	
			<div id="footer-widgets-bg" class="footer-widgets-background">

				<div id="footer-widgets-wrap" class="footer-widgets-wrap container">

					<div id="footer-widgets" class="footer-widgets clearfix"  role="complementary">

						
							<div class="footer-widget-column widget-area">
								<aside id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=12&l=ez&f=ifr&linkID=599d107ec24e5450556ee8903ecf5ddb&t=ecompare0e-20&tracking_id=ecompare0e-20" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></div></aside><aside id="block-2" class="widget widget_block"><iframe loading="lazy" src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=12&l=ur1&category=primewardrobe&banner=03DWP5NJ7FWGFBNBYWR2&f=ifr&linkID=6a6a157db2d09622073935c973dd996d&t=cakafete&tracking_id=cakafete" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></aside>							</div>

						
						
							<div class="footer-widget-column widget-area">
								<aside id="tzwb-recent-posts-7" class="widget tzwb-recent-posts">
		<div class="tzwb-content tzwb-clearfix">

			<ul class="tzwb-posts-list">
				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/anthony-barajas-a-tiktok-star-died-at-age-19/" title="Anthony Barajas, a Tik Tok Star, Dead at age 19">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Anthony Barajas, a Tik Tok Star, Dead at age 19 19 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Anthony-Barajas-a-TikTok-Star-Died-at-age-19-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Anthony-Barajas-a-TikTok-Star-Died-at-age-19-150x150.jpeg" alt="Anthony Barajas, a TikTok Star, Died at age 19" loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/anthony-barajas-a-tiktok-star-died-at-age-19/" title="Anthony Barajas, a Tik Tok Star, Dead at age 19">
						Anthony Barajas, a Tik Tok Star, Dead at age 19					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/covid-19-virus-surge-breaks-record-again-in-indian/" title="Pressure rises for India lockdown as covid-19 virus surge breaks record again.">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Pressure rises for India lockdown as covid-19 virus surge breaks record again. 20 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-75x75.jpg.webp 75w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-150x150.jpg.webp 150w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-90x90.jpg.webp 90w" sizes="(max-width: 75px) 100vw, 75px"/>
<img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-75x75.jpg" alt="Pressure rises for India lockdown as covid-19 virus surge breaks record again." loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/covid-19-virus-surge-breaks-record-again-in-indian/" title="Pressure rises for India lockdown as covid-19 virus surge breaks record again.">
						Pressure rises for India lockdown as covid-19 virus surge breaks record again.					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/rapper-dmx-has-died-at-age-50/" title="Rapper DMX is dead at age 50">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Rapper DMX is dead at age 50 21 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/04/Rapper-DMX-has-died-at-age-50-his-family-says-75x75.jpeg.webp 75w, https://www.whodiedtoday.com/wp-content/uploads/2021/04/Rapper-DMX-has-died-at-age-50-his-family-says-150x150.jpeg.webp 150w, https://www.whodiedtoday.com/wp-content/uploads/2021/04/Rapper-DMX-has-died-at-age-50-his-family-says-90x90.jpeg.webp 90w" sizes="(max-width: 75px) 100vw, 75px"/>
<img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2021/04/Rapper-DMX-has-died-at-age-50-his-family-says-75x75.jpeg" alt="Rapper DMX has died at age 50, his family says." loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/04/Rapper-DMX-has-died-at-age-50-his-family-says-75x75.jpeg 75w, https://www.whodiedtoday.com/wp-content/uploads/2021/04/Rapper-DMX-has-died-at-age-50-his-family-says-150x150.jpeg 150w, https://www.whodiedtoday.com/wp-content/uploads/2021/04/Rapper-DMX-has-died-at-age-50-his-family-says-90x90.jpeg 90w" sizes="(max-width: 75px) 100vw, 75px"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/rapper-dmx-has-died-at-age-50/" title="Rapper DMX is dead at age 50">
						Rapper DMX is dead at age 50					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/prince-philip-dead-at-age-99/" title="Prince Philip husband of Elizabeth II dead At Age 99 | whodiedtoday.com">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Prince Philip husband of Elizabeth II dead At Age 99 | whodiedtoday.com 22 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/04/Prince-Philip-husband-of-Elizabeth-II-dead-At-Age-99-75x75.jpeg.webp 75w, https://www.whodiedtoday.com/wp-content/uploads/2021/04/Prince-Philip-husband-of-Elizabeth-II-dead-At-Age-99-150x150.jpeg.webp 150w, https://www.whodiedtoday.com/wp-content/uploads/2021/04/Prince-Philip-husband-of-Elizabeth-II-dead-At-Age-99-90x90.jpeg.webp 90w" sizes="(max-width: 75px) 100vw, 75px"/>
<img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2021/04/Prince-Philip-husband-of-Elizabeth-II-dead-At-Age-99-75x75.jpeg" alt="Prince Philip husband of Elizabeth II dead At Age 99" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/04/Prince-Philip-husband-of-Elizabeth-II-dead-At-Age-99-75x75.jpeg 75w, https://www.whodiedtoday.com/wp-content/uploads/2021/04/Prince-Philip-husband-of-Elizabeth-II-dead-At-Age-99-150x150.jpeg 150w, https://www.whodiedtoday.com/wp-content/uploads/2021/04/Prince-Philip-husband-of-Elizabeth-II-dead-At-Age-99-90x90.jpeg 90w" sizes="(max-width: 75px) 100vw, 75px"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/prince-philip-dead-at-age-99/" title="Prince Philip husband of Elizabeth II dead At Age 99 | whodiedtoday.com">
						Prince Philip husband of Elizabeth II dead At Age 99 | whodiedtoday.com					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/american-business-herman-cain-dead-at-74/" title="Former Presidential Candidate Herman Cain Dead at 74">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Former Presidential Candidate Herman Cain Dead at 74 23 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Herman-Cain-December-13-1945-–-July-30-2020-75x75.jpg.webp 75w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Herman-Cain-December-13-1945-–-July-30-2020-150x150.jpg.webp 150w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Herman-Cain-December-13-1945-–-July-30-2020-90x90.jpg.webp 90w" sizes="(max-width: 75px) 100vw, 75px"/>
<img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Herman-Cain-December-13-1945-–-July-30-2020-75x75.jpg" alt="Herman Cain (December 13, 1945 – July 30, 2020" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Herman-Cain-December-13-1945-–-July-30-2020-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Herman-Cain-December-13-1945-–-July-30-2020-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Herman-Cain-December-13-1945-–-July-30-2020-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/american-business-herman-cain-dead-at-74/" title="Former Presidential Candidate Herman Cain Dead at 74">
						Former Presidential Candidate Herman Cain Dead at 74					</a>

							</ul>

		</div>

		</aside>							</div>

						
						
							<div class="footer-widget-column widget-area">
								<aside id="nav_menu-3" class="widget widget_nav_menu"><h3 class="widget-title">ABOUT THIS WEBSITE</h3><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-4234" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4234"><a href="https://www.whodiedtoday.com/about-us-page-tells-our-beginning-in-1996/">About us ; WHODIEDTODAY</a></li>
<li id="menu-item-4235" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4235"><a href="https://www.whodiedtoday.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-4233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4233"><a href="https://www.whodiedtoday.com/1-famous-person-who-died-today-in-the-world/">Famous People Who died today in 2020 somewhere in the world</a></li>
<li id="menu-item-4236" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4236"><a href="https://www.whodiedtoday.com/terms-and-conditions/">Terms And Conditions</a></li>
</ul></div></aside><aside id="block-3" class="widget widget_block"><iframe loading="lazy" src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=12&l=ur1&category=kitchen&banner=167N9JYG94SVHWHHA2R2&f=ifr&linkID=d241e58298a91da7f73ce0c55bdd198b&t=cakafete&tracking_id=cakafete" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></aside>							</div>

						
						
							<div class="footer-widget-column widget-area">
								<aside id="tzwb-recent-posts-6" class="widget tzwb-recent-posts">
		<div class="tzwb-content tzwb-clearfix">

			<ul class="tzwb-posts-list">
				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/dead-at-54-is-actor-michael-k-williams/" title="Dead at 54 is Actor Michael K. Williams, who starred as Omar on &#8216;The Wire.&#8217;">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Dead at 54 is Actor Michael K. Williams, who starred as Omar on &#039;The Wire.&#039; 24 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Dead-at-54-is-Actor-Michael-K.-Williams-who-starred-as-Omar-on-The-Wire-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Dead-at-54-is-Actor-Michael-K.-Williams-who-starred-as-Omar-on-The-Wire-150x150.jpeg" alt="Dead at 54 is Actor Michael K. Williams, who starred as Omar on &#039;The Wire.&#039;" loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/dead-at-54-is-actor-michael-k-williams/" title="Dead at 54 is Actor Michael K. Williams, who starred as Omar on &#8216;The Wire.&#8217;">
						Dead at 54 is Actor Michael K. Williams, who starred as Omar on &#8216;The Wire.&#8217;					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/jean-paul-belmondo-star-of-breathless-dead-at-88/" title="Jean-Paul Belmondo, star of &#8216;Breathless,&#8217; dead at 88">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Jean-Paul Belmondo, star of &#039;Breathless,&#039; dead at 88 25 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Jean-Paul-Belmondo-star-of-Breathless-dead-at-88-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Jean-Paul-Belmondo-star-of-Breathless-dead-at-88-150x150.jpeg" alt="Jean-Paul Belmondo, star of &#039;Breathless,&#039; dead at 88" loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/jean-paul-belmondo-star-of-breathless-dead-at-88/" title="Jean-Paul Belmondo, star of &#8216;Breathless,&#8217; dead at 88">
						Jean-Paul Belmondo, star of &#8216;Breathless,&#8217; dead at 88					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/honorable-edward-registe-of-da-dead-at-age-50/" title="Edward Registe, a Minister in Dominica&#8217;s Government dead at age 50">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Edward Registe, a Minister in Dominica&#039;s Government dead at age 50 26 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Edward-Registe-a-Minister-in-Dominicas-Government-dead-at-age-50-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Edward-Registe-a-Minister-in-Dominicas-Government-dead-at-age-50-150x150.jpeg" alt="Edward Registe, a Minister in Dominica&#039;s Government dead at age 50" loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/honorable-edward-registe-of-da-dead-at-age-50/" title="Edward Registe, a Minister in Dominica&#8217;s Government dead at age 50">
						Edward Registe, a Minister in Dominica&#8217;s Government dead at age 50					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/" title="Sir Lester Bird the second PM of Antigua and Barbuda dead at 83">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Sir Lester Bird the second PM of Antigua and Barbuda dead at 83 27 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/09/Sir-Lester-Bird-the-second-PM-of-Antigua-and-Barbuda-died-at-83-150x150.jpeg" alt="Former Prime Minister and National Hero Sir Lester Bird passed away on August 9, 2021." loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/" title="Sir Lester Bird the second PM of Antigua and Barbuda dead at 83">
						Sir Lester Bird the second PM of Antigua and Barbuda dead at 83					</a>

				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/jacques-rogge-ioc-president-for-12-years-dead-at-79/" title="Jacques Rogge, IOC president for 12 years, dead at 79">
							<picture class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image" loading="lazy" title="Jacques Rogge, IOC president for 12 years, dead at 79 28 lester bird">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Jacques-Rogge-IOC-president-for-12-years-dead-at-79-150x150.jpeg.webp"/>
<img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/08/Jacques-Rogge-IOC-president-for-12-years-dead-at-79-150x150.jpeg" alt="Jacques Rogge, IOC president for 12 years, dead at 79" loading="lazy"/>
</picture>
						</a>

				
					<a href="https://www.whodiedtoday.com/jacques-rogge-ioc-president-for-12-years-dead-at-79/" title="Jacques Rogge, IOC president for 12 years, dead at 79">
						Jacques Rogge, IOC president for 12 years, dead at 79					</a>

							</ul>

		</div>

		</aside>							</div>

						
					</div>

				</div>

			</div>

			
	<div class="footer-wrap">

		
		<footer id="colophon" class="site-footer">

			
			<div class="footer-menus">

			<nav id="footer-links" class="footer-navigation navigation clearfix" role="navigation"><ul id="menu-mainmenu" class="footer-navigation-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-7035"><a href="https://www.whodiedtoday.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6588"><a href="https://www.whodiedtoday.com/who-died-today-2021/">Who died today 2021</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-859"><a href="https://www.whodiedtoday.com/those-who-have-left-us-2/">Those who have left us</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-857"><a href="https://www.whodiedtoday.com/gone-but-not-forgotten/">Gone-but-not-forgotten</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1311"><a href="https://www.whodiedtoday.com/people-that-died-today-celebs-who-died-today/">celebs-who-died-today</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6589"><a href="https://www.whodiedtoday.com/laid-to-rest/">Laid-to-rest</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-860"><a href="https://www.whodiedtoday.com/who-died-on-dominica/">Dominica</a></li>
</ul></nav><!-- .footer-navigation -->
			</div>

						
	<div id="footer-line" class="site-info">

		<div id="search-7" class="widget widget_search"><h4 class="widget-title">SEARCH WEBSITE</h4>
<form role="search" method="get" class="search-form" action="https://www.whodiedtoday.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field"
			placeholder="Search &hellip;"
			value="" name="s"
			title="Search for:" />
	</label>
	<button type="submit" class="search-submit">
		<svg class="icon icon-search" aria-hidden="true" role="img"> <use xlink:href="https://www.whodiedtoday.com/wp-content/themes/dynamico/assets/icons/genericons-neue.svg#search"></use> </svg>		<span class="screen-reader-text">Search</span>
	</button>
</form>
</div>		
			<span class="footer-text">
				Who Died Today - CAKAFETEINC Family of Web Sites 
			</span>

					
	</div>

	
		</footer><!-- #colophon -->

	</div>

	
</div><!-- #page -->

		<div id="amp-mobile-version-switcher" hidden>
			<a rel="amphtml" href="https://www.whodiedtoday.com/lester-bird-former-antigua-and-barbuda-pm-died-at-83/?amp=1">
				Go to mobile version			</a>
		</div>

				<script type='text/javascript' id='dynamico-navigation-js-extra'>
/* <![CDATA[ */
var dynamicoScreenReaderText = {"expand":"Expand child menu","collapse":"Collapse child menu","icon":"<svg class=\"icon icon-expand\" aria-hidden=\"true\" role=\"img\"> <use xlink:href=\"https:\/\/www.whodiedtoday.com\/wp-content\/themes\/dynamico\/assets\/icons\/genericons-neue.svg#expand\"><\/use> <\/svg>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/dynamico/assets/js/navigation.js?ver=20201113' id='dynamico-navigation-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-includes/js/comment-reply.min.js?ver=5.8' id='comment-reply-js'></script>
<script type='text/javascript' id='dynamico-pro-scroll-to-top-js-extra'>
/* <![CDATA[ */
var dynamicoProScrollToTop = {"icon":"<svg class=\"icon icon-collapse\" aria-hidden=\"true\" role=\"img\"> <use xlink:href=\"https:\/\/www.whodiedtoday.com\/wp-content\/themes\/dynamico\/assets\/icons\/genericons-neue.svg#collapse\"><\/use> <\/svg>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/plugins/dynamico-pro/assets/js/scroll-to-top.min.js?ver=20210309' id='dynamico-pro-scroll-to-top-js'></script>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-includes/js/wp-embed.min.js?ver=5.8' id='wp-embed-js'></script>
<script defer type='text/javascript' src='https://www.whodiedtoday.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.12' id='akismet-form-js'></script>

</body>
</html>
