<!DOCTYPE html><html class="no-js mh-two-sb" lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta http-equiv="Content-type" content="text/html; charset=utf-8" /><meta name="google-site-verification" content="PHM0mx-rAwmtKRCrs0gEcSaaucGGUcr-s10gGwMAPzA" />  <script type="text/javascript">var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-1472193-15']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();</script>   <script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <link rel="icon" type="image/png" href="https://www.whodiedtoday.com/favicon-96x96.png"><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="https://gmpg.org/xfn/11" /><title>33-year-old Actress Naya Rivera Presumed Dead By Drowned</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://www.whodiedtoday.com/wp-content/cache/min/1/ba531e5b8b625d4a33c3c9e381c43d17.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="description" content="Actress Naya Rivera, best known as the snarky Santana Lopez on &quot;Glee,&quot; is assumed dead by drowning after she disappeared from a rented boat on a Southern"/><meta name="robots" content="index, nofollow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/><link rel="canonical" href="https://www.whodiedtoday.com/33-year-old-actress-naya-rivera-presumed-dead/" /><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="33-year-old Actress Naya Rivera Presumed Dead By Drowned"><meta property="og:description" content="Actress Naya Rivera, best known as the snarky Santana Lopez on &quot;Glee,&quot; is assumed dead by drowning after she disappeared from a rented boat on a Southern"><meta property="og:url" content="https://www.whodiedtoday.com/33-year-old-actress-naya-rivera-presumed-dead/"><meta property="og:site_name" content="Who Died Today and How Died Today"><meta property="article:publisher" content="https://www.facebook.com/celebritywhodiedtoday/"><meta property="article:author" content="https://www.facebook.com/cakafete"><meta property="article:tag" content="CBS 2 News Evening"><meta property="article:tag" content="Lake Piru"><meta property="article:tag" content="Naya Rivera"><meta property="article:section" content="Hot Trending News Today"><meta property="og:updated_time" content="2020-07-09T20:38:53-04:00"><meta property="fb:app_id" content="0554622171538732"><meta property="og:image" content="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera.jpg"><meta property="og:image:secure_url" content="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera.jpg"><meta property="og:image:width" content="1200"><meta property="og:image:height" content="675"><meta property="og:image:alt" content="Naya Rivera"><meta property="og:image:type" content="image/jpeg"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="33-year-old Actress Naya Rivera Presumed Dead By Drowned"><meta name="twitter:description" content="Actress Naya Rivera, best known as the snarky Santana Lopez on &quot;Glee,&quot; is assumed dead by drowning after she disappeared from a rented boat on a Southern"><meta name="twitter:site" content="@cakafete"><meta name="twitter:creator" content="@cakafete"><meta name="twitter:image" content="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera.jpg"> <script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@type":"BlogPosting","headline":"33-year-old Actress Naya Rivera Presumed Dead By Drowned","description":"Actress Naya Rivera, best known as the snarky Santana Lopez on &quot;Glee,&quot; is assumed dead by drowning after she disappeared from a rented boat on a Southern","datePublished":"2020-07-10T00:32:37-04:00","dateModified":"2020-07-09T20:38:53-04:00","publisher":{"@type":"Organization","name":"whodied-admin","logo":{"@type":"ImageObject","url":"https:\/\/whodiedtoday.com\/wp-content\/uploads\/2019\/05\/cropped-Whodiedtodaylogo.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.whodiedtoday.com\/33-year-old-actress-naya-rivera-presumed-dead\/"},"author":{"@type":"Person","name":"whodied-admin"},"image":{"@type":"ImageObject","url":"https:\/\/www.whodiedtoday.com\/wp-content\/uploads\/2020\/07\/5876_33-year-old-Actress-Naya-Rivera.jpg","width":1200,"height":675}}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//google.com' /><link rel='dns-prefetch' href='//youtube.com' /><link rel='dns-prefetch' href='//review-products.com' /><link rel='dns-prefetch' href='//facebook.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Who Died Today and How Died Today &raquo; Feed" href="https://www.whodiedtoday.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Who Died Today and How Died Today &raquo; Comments Feed" href="https://www.whodiedtoday.com/comments/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.11.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-1472193-15';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','https://www.whodiedtoday.com/wp-content/cache/busting/google-tracking/ga-871c39943ac31c498d591a714a31212c.js','__gaTracker');

		__gaTracker('create', 'UA-1472193-15', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='preload' id='wp-block-library-css' href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/style.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify}</style><link crossorigin="anonymous" rel='preload' id='mh-google-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700&#038;display=swap' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.whodiedtoday.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style><link rel='preload' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.7/css/jetpack.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <script type='text/javascript'>/* <![CDATA[ */ var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.whodiedtoday.com","hash_tracking":"false"}; /* ]]> */</script>  <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery.js'></script>   <link rel='https://api.w.org/' href='https://www.whodiedtoday.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.whodiedtoday.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.whodiedtoday.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://www.whodiedtoday.com/?p=5876' /><meta name="keywords" content="CBS 2 News Evening, Lake Piru, Naya Rivera" /><link rel='dns-prefetch' href='//c0.wp.com'/><style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="https://www.whodiedtoday.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]--><link rel="amphtml" href="https://www.whodiedtoday.com/33-year-old-actress-naya-rivera-presumed-dead/amp/"><link rel="icon" href="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-180x180.png" /><meta name="msapplication-TileImage" content="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-270x270.png" /> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body id="mh-mobile" class="post-template-default single single-post postid-5876 single-format-standard wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout2" itemscope="itemscope" itemtype="http://schema.org/WebPage"><aside class="mh-container mh-header-widget-1"><div id="custom_html-4" class="widget_text mh-widget mh-header-1 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4823718395360608" data-ad-slot="8078307907" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></aside><div class="mh-container mh-container-outer"><div class="mh-header-nav-mobile clearfix"></div><div class="mh-preheader"><div class="mh-container mh-container-inner mh-row clearfix"><div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix"></div><div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix"></div></div></div><header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader"><div class="mh-container mh-container-inner clearfix"><div class="mh-custom-header clearfix"><div class="mh-header-columns mh-row clearfix"><div class="mh-col-1-3 mh-site-identity"><div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand"> <a href="https://www.whodiedtoday.com/" class="custom-logo-link" rel="home"><picture class="custom-logo">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/04/cropped-new-whodiedtoday-logo.png.webp 371w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20371%20123&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 371px) 100vw, 371px"/>
<img width="371" height="123" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20371%20123&#039;%3E%3C/svg%3E" alt="Who Died Today and How Died Today" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/04/cropped-new-whodiedtoday-logo.png 371w, https://www.whodiedtoday.com/wp-content/uploads/2020/04/cropped-new-whodiedtoday-logo-300x99.png 300w" data-lazy-sizes="(max-width: 371px) 100vw, 371px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/04/cropped-new-whodiedtoday-logo.png"/>
</picture>
<noscript><picture class="custom-logo">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/04/cropped-new-whodiedtoday-logo.png.webp 371w" sizes="(max-width: 371px) 100vw, 371px"/>
<img width="371" height="123" src="https://www.whodiedtoday.com/wp-content/uploads/2020/04/cropped-new-whodiedtoday-logo.png" alt="Who Died Today and How Died Today" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/04/cropped-new-whodiedtoday-logo.png 371w, https://www.whodiedtoday.com/wp-content/uploads/2020/04/cropped-new-whodiedtoday-logo-300x99.png 300w" sizes="(max-width: 371px) 100vw, 371px"/>
</picture>
</noscript></a></div></div><aside class="mh-col-2-3 mh-header-widget-2"><div id="text-23" class="mh-widget mh-header-2 widget_text"><div class="textwidget"><p><a href="https://www.review-products.ca/"><img class="aligncenter size-full wp-image-3905" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20728%2090'%3E%3C/svg%3E" alt="review-products.ca" width="728" height="90" data-sitemapexclude="true" data-lazy-src="https://whodiedtoday.com/wp-content/uploads/2019/05/banner-review-products.png" /><noscript><img class="aligncenter size-full wp-image-3905" src="https://whodiedtoday.com/wp-content/uploads/2019/05/banner-review-products.png" alt="review-products.ca" width="728" height="90" data-sitemapexclude="true" /></noscript></a></p></div></div></aside></div></div></div><div class="mh-main-nav-wrap"><nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><div class="menu-mainmenu-container"><ul id="menu-mainmenu" class="menu"><li id="menu-item-860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-860"><a href="https://www.whodiedtoday.com/who-died-on-dominica/">Dominica</a></li><li id="menu-item-861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-861"><a href="https://www.whodiedtoday.com/laid-to-rest/">Laid To Rest</a></li><li id="menu-item-890" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-890"><a href="https://www.whodiedtoday.com/who-important-died-today/">Who Important Died Today</a></li><li id="menu-item-859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-859"><a href="https://www.whodiedtoday.com/those-who-have-left-us-2/">Those Who Have Left US</a></li><li id="menu-item-857" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-857"><a href="https://www.whodiedtoday.com/gone-but-not-forgotten/">Gone but not forgotten</a></li><li id="menu-item-856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-856"><a href="https://www.whodiedtoday.com/celebrity-video/">Video</a></li><li id="menu-item-1311" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1311"><a href="https://www.whodiedtoday.com/people-that-died-today-celebs-who-died-today/">celebs who died today</a></li></ul></div></nav></div></header><div class="mh-subheader"><div class="mh-container mh-container-inner mh-row clearfix"><div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix"><div class="mh-header-ticker mh-header-ticker-bottom"><div class="mh-ticker-bottom"><div class="mh-ticker-title mh-ticker-title-bottom"> News Ticker<i class="fa fa-chevron-right"></i></div><div class="mh-ticker-content mh-ticker-content-bottom"><ul id="mh-ticker-loop-bottom"><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://www.whodiedtoday.com/33-year-old-actress-naya-rivera-presumed-dead/" title="33-year-old Actress Naya Rivera Presumed dead by Drowned"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ July 10, 2020 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> 33-year-old Actress Naya Rivera Presumed dead by Drowned </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Hot Trending News Today </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://www.whodiedtoday.com/62-year-old-micheal-bruney-is-dead/" title="62-year-old Micheal Bruney (&#8216;Mickey&#8217;) is dead from lung cancer"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ July 8, 2020 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> 62-year-old Micheal Bruney (&#8216;Mickey&#8217;) is dead from lung cancer </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Gone But Not Forgotten </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://www.whodiedtoday.com/nick-cordero-the-41-hamilton-native-is-dead/" title="Nick Cordero, the 41-year-old Hamilton Native, is dead"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ July 6, 2020 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Nick Cordero, the 41-year-old Hamilton Native, is dead </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Recently Died </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://www.whodiedtoday.com/hugh-downs-american-broadcaster-dead-at-99/" title="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ July 2, 2020 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99 </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Famous People Who Died Today in 2020 </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://www.whodiedtoday.com/carl-reiner-hollywood-entertainer-dead-at-98/" title="Carl Reiner Hollywood entertainer is dead at 98"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ June 30, 2020 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Carl Reiner Hollywood entertainer is dead at 98 </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> people that died today - celebs who died today </span> </a></li></ul></div></div></div></div><div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix"><aside class="mh-header-search mh-header-search-bottom"><form role="search" method="get" class="search-form" action="https://www.whodiedtoday.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside></div></div></div><div class="mh-wrapper clearfix"><div class="mh-main clearfix"><div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.whodiedtoday.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.whodiedtoday.com/hot-trending-news-today/" itemprop="url"><span itemprop="title">Hot Trending News Today</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>33-year-old Actress Naya Rivera Presumed dead by Drowned</nav><article id="post-5876" class="post-5876 post type-post status-publish format-standard has-post-thumbnail hentry category-hot-trending-news-today tag-cbs-2-news-evening tag-lake-piru tag-naya-rivera"><header class="entry-header clearfix"><h1 class="entry-title">33-year-old Actress Naya Rivera Presumed dead by Drowned</h1><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/07/">July 10, 2020</a></span> <span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.whodiedtoday.com/author/whodied-admin/">whodied-admin</a></span> <span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.whodiedtoday.com/hot-trending-news-today/" rel="category tag">Hot Trending News Today</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on 33-year-old Actress Naya Rivera Presumed dead by Drowned</span></span></span></div></header><div id="text-26" class="mh-widget mh-posts-1 widget_text"><div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4823718395360608" data-ad-slot="8078307907" data-ad-format="auto" data-full-width-responsive="true"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div><div class="entry-content clearfix"><figure class="entry-thumbnail"> <picture title="33-year-old-Actress-Naya-Rivera.jpg">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-678x381.jpg.webp" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%200%200&#039;%3E%3C/svg%3E"/>
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%200%200&#039;%3E%3C/svg%3E" alt="" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-678x381.jpg"/>
</picture>
<noscript><picture title="33-year-old-Actress-Naya-Rivera.jpg">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-678x381.jpg.webp"/>
<img src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-678x381.jpg" alt=""/>
</picture>
</noscript></figure><div class="mh-social-top"><div class="mh-share-buttons clearfix"> <a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F&t=33-year-old+Actress+Naya+Rivera+Presumed+dead+by+Drowned', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"> <span class="mh-share-button"><i class="fa fa-facebook"></i></span> </a> <a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=33-year-old+Actress+Naya+Rivera+Presumed+dead+by+Drowned:&url=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"> <span class="mh-share-button"><i class="fa fa-twitter"></i></span> </a> <a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn"> <span class="mh-share-button"><i class="fa fa-linkedin"></i></span> </a> <a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F&media=https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera.jpg&description=33-year-old+Actress+Naya+Rivera+Presumed+dead+by+Drowned', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"> <span class="mh-share-button"><i class="fa fa-pinterest"></i></span> </a> <a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"> <span class="mh-share-button"><i class="fa fa-google-plus"></i></span> </a> <a class="mh-email" href="mailto:?subject=33-year-old%20Actress%20Naya%20Rivera%20Presumed%20dead%20by%20Drowned&amp;body=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F" title="Send this article to a friend" target="_blank"> <span class="mh-share-button"><i class="fa fa-envelope-o"></i></span> </a> <a class="mh-print" href="javascript:window.print()" title="Print this article"> <span class="mh-share-button"><i class="fa fa-print"></i></span> </a></div></div><figure><div class="rll-youtube-player" data-src="https://www.youtube.com/embed/014Xotsgbcg" data-id="014Xotsgbcg" data-query=""></div><noscript><iframe src="https://www.youtube.com/embed/014Xotsgbcg" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></noscript></figure><p>As found on <a href="https://www.youtube.com/watch?v=014Xotsgbcg" target="_blank" rel="noopener noreferrer nofollow">Youtube</a></p><p>Actress Naya Rivera, best known as the snarky Santana Lopez on &#8220;Glee,&#8221; is assumed dead by drowning after she disappeared from a rented boat on a Southern California lake Wednesday, that&#8217;s according to the Ventura County Sheriff&#8217;s Office.</p><p>Investigators believe Rivera drowned in what appears to be a tragic accident, according to a statement released Thursday by Ventura County Sheriff&#8217;s Office Capt. Eric Buschow.</p><p>Rivera&#8217;s son told investigators that he and his mother had been swimming in the lake, and he got back in the boat, but Rivera did not, according to Buschow. The child is in the company of the family.</p><figure class="wp-block-image size-large" data-amp-noloading="true" data-amp-lightbox="true"><picture class="wp-image-5879" title="Actor">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-1024x576.jpg.webp 1024w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-300x169.jpg.webp 300w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-768x432.jpg.webp 768w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-678x381.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing.jpg.webp 1200w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%200%200&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px"/>
<img src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%200%200&#039;%3E%3C/svg%3E" alt="33-year-old Actress Naya Rivera" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-1024x576.jpg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-300x169.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-768x432.jpg 768w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-678x381.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing.jpg 1200w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-1024x576.jpg"/>
</picture>
<noscript><picture class="wp-image-5879" title="Actor">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-1024x576.jpg.webp 1024w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-300x169.jpg.webp 300w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-768x432.jpg.webp 768w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-678x381.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing.jpg.webp 1200w" sizes="(max-width: 1024px) 100vw, 1024px"/>
<img src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-1024x576.jpg" alt="33-year-old Actress Naya Rivera" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-1024x576.jpg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-300x169.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-768x432.jpg 768w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing-678x381.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/33-year-old-Actress-Naya-Rivera-missing.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px"/>
</picture>
</noscript></figure><p>By about noon EDT Thursday, the effort to find Rivera had transitioned to a search and recovery effort. About 100 people were taking part in operations to find her body.</p><p>Helicopters divers and drones have been searching for her in Lake Piru in the Los Padres National Forest in Ventura County. According to authorities, Naya Rivera rented a pontoon boat with her 4-year-old son, but she has been missing for hours.</p><p>Nellie Piru is a reservoir and recreational lake. There was a massive search for her with boats and divers all in the water searching for Rivera.</p><p>The investigators said that another boat had noticed a boat with a small child late today, and no one else that boater then called for help. The investigators say the four-year-old boy told deputies he went swimming with his mother earlier and had not returned to the boat.</p><p>The 33 years old began as a child model and actress and starred in the Fox show Glee from 2009 to 2015. She shares her son with actor Ryan Dorsey.</p><p><a href="https://www.whodiedtoday.com/" class="rank-math-link">Top</a></p><div class="mh-social-bottom"><div class="mh-share-buttons clearfix"> <a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F&t=33-year-old+Actress+Naya+Rivera+Presumed+dead+by+Drowned', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"> <span class="mh-share-button"><i class="fa fa-facebook"></i></span> </a> <a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=33-year-old+Actress+Naya+Rivera+Presumed+dead+by+Drowned:&url=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"> <span class="mh-share-button"><i class="fa fa-twitter"></i></span> </a> <a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn"> <span class="mh-share-button"><i class="fa fa-linkedin"></i></span> </a> <a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F&media=https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera.jpg&description=33-year-old+Actress+Naya+Rivera+Presumed+dead+by+Drowned', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"> <span class="mh-share-button"><i class="fa fa-pinterest"></i></span> </a> <a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"> <span class="mh-share-button"><i class="fa fa-google-plus"></i></span> </a> <a class="mh-email" href="mailto:?subject=33-year-old%20Actress%20Naya%20Rivera%20Presumed%20dead%20by%20Drowned&amp;body=https%3A%2F%2Fwww.whodiedtoday.com%2F33-year-old-actress-naya-rivera-presumed-dead%2F" title="Send this article to a friend" target="_blank"> <span class="mh-share-button"><i class="fa fa-envelope-o"></i></span> </a> <a class="mh-print" href="javascript:window.print()" title="Print this article"> <span class="mh-share-button"><i class="fa fa-print"></i></span> </a></div></div></div><div class="entry-tags clearfix"><i class="fa fa-tag"></i><ul><li><a href="https://www.whodiedtoday.com/tag/cbs-2-news-evening/" rel="tag">CBS 2 News Evening</a></li><li><a href="https://www.whodiedtoday.com/tag/lake-piru/" rel="tag">Lake Piru</a></li><li><a href="https://www.whodiedtoday.com/tag/naya-rivera/" rel="tag">Naya Rivera</a></li></ul></div><div id="text-27" class="mh-widget mh-posts-2 widget_text"><div class="textwidget"><div id="amzn-assoc-ad-3e9cfe05-5685-4083-8933-bc64b0d4ce13"></div><p><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&#038;adInstanceId=3e9cfe05-5685-4083-8933-bc64b0d4ce13"></script></p></div></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev"> <a href="https://www.whodiedtoday.com/62-year-old-micheal-bruney-is-dead/" rel="prev"><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="33-year-old Actress Naya Rivera Presumed dead by Drowned 1">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="62-year-old Micheal Bruney (&#039;Mickey&#039;) is dead from lung cancer" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="33-year-old Actress Naya Rivera Presumed dead by Drowned 1">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg" alt="62-year-old Micheal Bruney (&#039;Mickey&#039;) is dead from lung cancer" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript><span>Previous</span><p>62-year-old Micheal Bruney (&#8216;Mickey&#8217;) is dead from lung cancer</p></a></div></nav><section class="mh-related-content"><h3 class="mh-widget-title mh-related-content-title"> <span class="mh-widget-title-inner">Related Articles</span></h3><div class="mh-related-wrap mh-row clearfix"><div class="mh-col-1-3 mh-posts-grid-col clearfix"><article class="post-2881 format-video mh-posts-grid-item clearfix"><figure class="mh-posts-grid-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.whodiedtoday.com/star-wars-actress-carrie-fisher-dies-at-age-60/" title="Star Wars Actress, Carrie Fisher, Dies At Age 60"><img width="326" height="183" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20183'%3E%3C/svg%3E" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="Star Wars Actress, Carrie Fisher, Dies At Age 60 2" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7.jpg 1280w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-300x169.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-768x432.jpg 768w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-1024x576.jpg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-153x86.jpg 153w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-170x96.jpg 170w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-50x28.jpg 50w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" title="Star Wars Actress, Carrie Fisher, Dies At Age 60 3" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7.jpg"><noscript><img width="326" height="183" src="https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="Star Wars Actress, Carrie Fisher, Dies At Age 60 2" srcset="https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7.jpg 1280w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-300x169.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-768x432.jpg 768w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-1024x576.jpg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-153x86.jpg 153w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-170x96.jpg 170w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-7-50x28.jpg 50w" sizes="(max-width: 326px) 100vw, 326px" title="Star Wars Actress, Carrie Fisher, Dies At Age 60 3"></noscript> </a><div class="mh-image-caption mh-posts-grid-caption"> Video</div></figure><h3 class="entry-title mh-posts-grid-title"> <a href="https://www.whodiedtoday.com/star-wars-actress-carrie-fisher-dies-at-age-60/" title="Star Wars Actress, Carrie Fisher, Dies At Age 60" rel="bookmark"> Star Wars Actress, Carrie Fisher, Dies At Age 60 </a></h3><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2016/12/">December 27, 2016</a></span> <span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.whodiedtoday.com/author/whodied-admin/">whodied-admin</a></span> <span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.whodiedtoday.com/celebrity-video/" rel="category tag">Video</a>, <a href="https://www.whodiedtoday.com/whodiedtoday/" rel="category tag">whodiedtoday</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Star Wars Actress, Carrie Fisher, Dies At Age 60</span></span></span></div><div class="mh-posts-grid-excerpt clearfix"><div class="mh-excerpt"><p>CBS 2&#039;s Marlie Hall reports.</p></div></div></article></div></div></section><div id="comments" class="mh-comments-wrap"></div></div><aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="text-22" class="mh-widget widget_text"><div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4823718395360608" data-ad-slot="8078307907" data-ad-format="auto" data-full-width-responsive="true"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div><div id="mh_magazine_facebook_page-2" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Follow us on Facebook</span></h4><div class="mh-magazine-facebook-page-widget"><div class="fb-page" data-href="https://www.facebook.com/celebritywhodiedtoday" data-width="300" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div></div></div><div id="mh_magazine_authors-2" class="mh-widget mh_magazine_authors"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Authors</span></h4><ul class="mh-user-widget mh-authors-widget clearfix"><li class="mh-user-item clearfix"><figure class="mh-user-avatar"> <a href="https://www.whodiedtoday.com/author/whodied-admin/" title="Articles by whodied-admin"> <img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=48&#038;d=mm&#038;r=g" /><noscript><img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src='https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /></noscript> </a></figure><div class="mh-user-meta"> <a class="mh-user-author-name" href="https://www.whodiedtoday.com/author/whodied-admin/" title="Articles by whodied-admin"> whodied-admin </a><p class="mh-user-data"> published 573 articles</p></div></li><li class="mh-user-item clearfix"><figure class="mh-user-avatar"> <a href="https://www.whodiedtoday.com/author/admin/" title="Articles by Administrator"> <img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=48&#038;d=mm&#038;r=g" /><noscript><img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src='https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /></noscript> </a></figure><div class="mh-user-meta"> <a class="mh-user-author-name" href="https://www.whodiedtoday.com/author/admin/" title="Articles by Administrator"> Administrator </a><p class="mh-user-data"> published 114 articles</p></div></li></ul></div><div id="mh_magazine_nip-2" class="mh-widget mh_magazine_nip"><ul class="mh-nip-widget clearfix"><li class="mh-nip-item post-5876 post type-post status-publish format-standard has-post-thumbnail category-hot-trending-news-today tag-cbs-2-news-evening tag-lake-piru tag-naya-rivera"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/33-year-old-actress-naya-rivera-presumed-dead/" title="33-year-old Actress Naya Rivera Presumed dead by Drowned"> <picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="33-year-old Actress Naya Rivera Presumed dead by Drowned 5">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="33-year-old Actress Naya Rivera Presumed dead by Drowned 4" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="33-year-old Actress Naya Rivera Presumed dead by Drowned 5">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-80x60.jpg" alt="33-year-old Actress Naya Rivera Presumed dead by Drowned 4" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5876_33-year-old-Actress-Naya-Rivera-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript><div class="mh-nip-overlay"></div> </a></li><li class="mh-nip-item post-5864 post type-post status-publish format-standard has-post-thumbnail category-gone-but-not-forgotten category-who-died-on-dominica tag-adrian-saunders tag-brian-bruney tag-caribbean-court-of-justice tag-corporation tag-counsel tag-dominicas-bar-association tag-given-names tag-guard tag-health-effects-of-tobacco tag-health-medical-pharma tag-lung-cancer tag-magistrate tag-media-personality tag-men tag-michael tag-michael-bruney tag-micheal tag-micheal-bruney tag-mickey tag-mikey tag-names"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/62-year-old-micheal-bruney-is-dead/" title="62-year-old Micheal Bruney (&#8216;Mickey&#8217;) is dead from lung cancer"> <picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="62-year-old Micheal Bruney (&#039;Mickey&#039;) is dead from lung cancer 6">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="62-year-old Micheal Bruney (&#039;Mickey&#039;) is dead from lung cancer" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="62-year-old Micheal Bruney (&#039;Mickey&#039;) is dead from lung cancer 6">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg" alt="62-year-old Micheal Bruney (&#039;Mickey&#039;) is dead from lung cancer" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/Michael-Mickey-Bruney-1958-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript><div class="mh-nip-overlay"></div> </a></li><li class="mh-nip-item post-5855 post type-post status-publish format-standard has-post-thumbnail category-recently-died category-who-important-died-today tag-actor tag-big-news tag-broadway tag-cdc tag-center-for-disease-control tag-corona tag-coronavirus tag-coronavirus-explained tag-coronavirus-latest-news tag-coronavirus-news tag-coronavirus-outbreak tag-coronavirus-pandemic tag-coronavirus-prevention tag-coronavirus-symptoms tag-coronavirus-update tag-coronavirus-us tag-covid-19 tag-covid-19-news tag-covid-19-outbreak tag-covid-19-updates tag-editors-picks tag-health tag-music tag-news tag-nick-cordero tag-outbreak tag-pandemic tag-pop-culture tag-quarantine tag-social-distancing tag-symptoms tag-the-latest-on-today tag-today"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/nick-cordero-the-41-hamilton-native-is-dead/" title="Nick Cordero, the 41-year-old Hamilton Native, is dead"> <picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Nick Cordero, the 41-year-old Hamilton Native, is dead 7">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="who important died today" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Nick Cordero, the 41-year-old Hamilton Native, is dead 7">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-80x60.jpg" alt="who important died today" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript><div class="mh-nip-overlay"></div> </a></li><li class="mh-nip-item post-5842 post type-post status-publish format-standard has-post-thumbnail category-famous-people-who-died-today-in-2020 category-recently-died tag-hugh-downs-20-20 tag-hugh-downs-2018 tag-hugh-downs-age tag-hugh-downs-and-barbara-walters-2020 tag-hugh-downs-dead-or-alive tag-hugh-downs-death tag-hugh-downs-health tag-hugh-downs-images tag-hugh-downs-last-interview tag-hugh-downs-obituary tag-hugh-downs-residence tag-hugh-downs-retired tag-kcal-9-news-afternoon tag-nbc tag-over-easy"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/hugh-downs-american-broadcaster-dead-at-99/" title="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99"> <picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99 9">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99 8" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99 9">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg" alt="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99 8" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript><div class="mh-nip-overlay"></div> </a></li><li class="mh-nip-item post-5824 post type-post status-publish format-standard has-post-thumbnail category-people-that-died-today-celebs-who-died-today category-recently-died category-who-important-died-today tag-carl-reiner tag-celebrity-interviews tag-entertainment tag-rob-reiner"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/carl-reiner-hollywood-entertainer-dead-at-98/" title="Carl Reiner Hollywood entertainer is dead at 98"> <picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Carl Reiner Hollywood entertainer is dead at 98 10">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Carl Reiner March 20 1922 – June 29 2020" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Carl Reiner Hollywood entertainer is dead at 98 10">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg" alt="Carl Reiner March 20 1922 – June 29 2020" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript><div class="mh-nip-overlay"></div> </a></li><li class="mh-nip-item post-5814 post type-post status-publish format-standard has-post-thumbnail category-famous-people-who-died-today-in-2020 category-recently-died category-who-important-died-today tag-andrew-dalton tag-atlantic-ocean tag-bing tag-california tag-democratic-party tag-detective tag-entertainment-culture tag-financier tag-jerry-oconnell tag-lisa-bonder tag-model-and-actress tag-movie-producer tag-people-from-california tag-president tag-private-detective tag-real-estate-heir tag-stanford-university tag-steve-bing tag-steve-bing-movie tag-websites"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/movieproducer-steve-bing-dead-at-55-by-sucide/" title="Steve Bing Movie producer, film financier, real estate heir, and major Democratic political donor dead at 55"> <picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Steve Bing Movie producer, film financier, real estate heir, and major Democratic political donor dead at 55 11">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Steve Bing" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Steve Bing Movie producer, film financier, real estate heir, and major Democratic political donor dead at 55 11">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg" alt="Steve Bing" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript><div class="mh-nip-overlay"></div> </a></li><li class="mh-nip-item post-5797 post type-post status-publish format-standard has-post-thumbnail category-famous-people-who-died-today-in-2020 category-recently-died category-who-important-died-today tag-jean-kennedy-smithvideo tag-news"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/jean-kennedy-smith-dead-at-92/" title="Jean Kennedy Smith, last surviving sibling of JFK, dead at 92"> <picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Jean Kennedy Smith, last surviving sibling of JFK, dead at 92 12">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Jean Kennedy Smith dead at 92" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Jean Kennedy Smith, last surviving sibling of JFK, dead at 92 12">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg" alt="Jean Kennedy Smith dead at 92" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript><div class="mh-nip-overlay"></div> </a></li><li class="mh-nip-item post-5787 post type-post status-publish format-standard has-post-thumbnail category-gone-but-not-forgotten category-recently-died tag-actor tag-actress tag-arjun-sarja tag-bollywood tag-bollywood-actor tag-cardiac-life-support-protocol tag-chief-minister tag-chiranjeevi-sarja tag-cinema-of-india tag-films tag-indian-culture tag-indian-films tag-kannada-artist tag-karnataka tag-sarja tag-shakti-prasad tag-sree-raam-films-international tag-the-innovative-film-award tag-unit-head tag-varadhanayaka"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/indian-actor-chiranjeevi-sarja-dead-at-39/" title="Bollywood actor Chiranjeevi Sarja dead at aged 39"> <picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Bollywood actor Chiranjeevi Sarja dead at aged 39 13">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Bollywood actor Chiranjeevi Sarja dead at aged 39" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Bollywood actor Chiranjeevi Sarja dead at aged 39 13">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg" alt="Bollywood actor Chiranjeevi Sarja dead at aged 39" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript><div class="mh-nip-overlay"></div> </a></li><li class="mh-nip-item post-5778 post type-post status-publish format-standard has-post-thumbnail category-famous-people-who-died-today-in-2020 category-recently-died category-who-important-died-today tag-1974-grammy-award tag-aaron tag-anita tag-anita-pointer tag-bonnie tag-bonnie-pointer tag-california tag-crossover tag-entertainment-culture tag-fairytale tag-first-grammy tag-fritz tag-grammy tag-grammy-winning-artist tag-grand-ole-opry tag-how-long tag-june tag-june-pointer tag-los-angeles tag-member-of-the-group tag-motown tag-motown-records tag-musical-groups tag-musician tag-musicians tag-oakland tag-pointer tag-pointer-sisters tag-roger-neal tag-ruth tag-singer tag-songs tag-the-associated-press tag-the-pointer-sisters tag-we-can tag-yes-we-can-can"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/bonnie-pointer-dead-at-69/" title="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69"> <picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69 14">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69 14">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg" alt="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript><div class="mh-nip-overlay"></div> </a></li></ul></div><div id="mh_magazine_youtube-2" class="mh-widget mh_magazine_youtube"><div class="mh-video-widget"><div class="mh-video-container"> <div class="rll-youtube-player" data-src="//www.youtube.com/embed/3SUXCTgUG5g" data-id="3SUXCTgUG5g" data-query="wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=0&amp;rel=0"></div><noscript><iframe seamless width="1280" height="720" src="//www.youtube.com/embed/3SUXCTgUG5g?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=0&amp;rel=0" allowfullscreen></iframe></noscript></div></div></div><div id="mh_magazine_custom_posts-2" class="mh-widget mh_magazine_custom_posts"><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-40 post type-post status-publish format-standard has-post-thumbnail category-gone-but-not-forgotten category-those-who-have-left-us-2 tag-car-hijacking tag-george-harrison tag-lucky-dube tag-songs tag-south-africa"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/will-never-be-forgotten-i-love-you/" title="Will Never Be Forgotten &#8211; I Love you"><img width="45" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2045%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Will Never Be Forgotten - I Love you 15" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2007/10/dubenews3.jpg 227w, https://www.whodiedtoday.com/wp-content/uploads/2007/10/dubenews3-160x211.jpg 160w" data-lazy-sizes="(max-width: 45px) 100vw, 45px" title="Will Never Be Forgotten - I Love you 16" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2007/10/dubenews3.jpg"><noscript><img width="45" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2007/10/dubenews3.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Will Never Be Forgotten - I Love you 15" srcset="https://www.whodiedtoday.com/wp-content/uploads/2007/10/dubenews3.jpg 227w, https://www.whodiedtoday.com/wp-content/uploads/2007/10/dubenews3-160x211.jpg 160w" sizes="(max-width: 45px) 100vw, 45px" title="Will Never Be Forgotten - I Love you 16"></noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/will-never-be-forgotten-i-love-you/" title="Will Never Be Forgotten &#8211; I Love you"> Will Never Be Forgotten &#8211; I Love you </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2007/10/">October 20, 2007</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Will Never Be Forgotten &#8211; I Love you</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-583 post type-post status-publish format-standard has-post-thumbnail category-gone-but-not-forgotten tag-america tag-louise-troh tag-texas tag-texas-health-presbyterian-hospital tag-washington"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/thomas-eric-duncan-first-patient-diagnosed-with-ebola-in-the-united-states-died-today-wednesday-october-8th-2014/" title="Thomas Eric Duncan first patient diagnosed with Ebola in the United States, died today Wednesday October 8th, 2014"><img width="80" height="45" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2045'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Thomas Eric Duncan first patient diagnosed with Ebola in the United States, died today Wednesday October 8th, 2014 17" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2014/10/ebola_Victim.jpg 280w, https://www.whodiedtoday.com/wp-content/uploads/2014/10/ebola_Victim-260x144.jpg 260w, https://www.whodiedtoday.com/wp-content/uploads/2014/10/ebola_Victim-160x89.jpg 160w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" title="Thomas Eric Duncan first patient diagnosed with Ebola in the United States, died today Wednesday October 8th, 2014 18" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2014/10/ebola_Victim.jpg"><noscript><img width="80" height="45" src="https://www.whodiedtoday.com/wp-content/uploads/2014/10/ebola_Victim.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Thomas Eric Duncan first patient diagnosed with Ebola in the United States, died today Wednesday October 8th, 2014 17" srcset="https://www.whodiedtoday.com/wp-content/uploads/2014/10/ebola_Victim.jpg 280w, https://www.whodiedtoday.com/wp-content/uploads/2014/10/ebola_Victim-260x144.jpg 260w, https://www.whodiedtoday.com/wp-content/uploads/2014/10/ebola_Victim-160x89.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" title="Thomas Eric Duncan first patient diagnosed with Ebola in the United States, died today Wednesday October 8th, 2014 18"></noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/thomas-eric-duncan-first-patient-diagnosed-with-ebola-in-the-united-states-died-today-wednesday-october-8th-2014/" title="Thomas Eric Duncan first patient diagnosed with Ebola in the United States, died today Wednesday October 8th, 2014"> Thomas Eric Duncan first patient diagnosed with Ebola in the United States, died today Wednesday October 8th, 2014 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2014/10/">October 8, 2014</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Thomas Eric Duncan first patient diagnosed with Ebola in the United States, died today Wednesday October 8th, 2014</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11 post type-post status-publish format-standard has-post-thumbnail category-gone-but-not-forgotten category-those-who-have-left-us tag-dominica-grammar-school tag-dominica-labour-party tag-hilda-strathmore-stevens tag-pat-stevens tag-roseau-mixed-school"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/remembering-pat-stevens/" title="Remembering Pat Stevens"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Remembering Pat Stevens 19" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2006/06/patstevens.jpg 240w, https://www.whodiedtoday.com/wp-content/uploads/2006/06/patstevens-160x120.jpg 160w, https://www.whodiedtoday.com/wp-content/uploads/2006/06/patstevens-193x145.jpg 193w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" title="Remembering Pat Stevens 20" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2006/06/patstevens.jpg"><noscript><img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2006/06/patstevens.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Remembering Pat Stevens 19" srcset="https://www.whodiedtoday.com/wp-content/uploads/2006/06/patstevens.jpg 240w, https://www.whodiedtoday.com/wp-content/uploads/2006/06/patstevens-160x120.jpg 160w, https://www.whodiedtoday.com/wp-content/uploads/2006/06/patstevens-193x145.jpg 193w" sizes="(max-width: 80px) 100vw, 80px" title="Remembering Pat Stevens 20"></noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/remembering-pat-stevens/" title="Remembering Pat Stevens"> Remembering Pat Stevens </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2006/06/">June 6, 2006</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Remembering Pat Stevens</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-1457 post type-post status-publish format-standard has-post-thumbnail category-gone-but-not-forgotten tag-dies-at-84-frank-gifford tag-frank-gifford tag-sportscaster-and-nfl-hall-of-famer"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/hall-famer-frank-gifford-dies-age-84/" title="Hall of Famer Frank Gifford dies at age 84"><img width="59" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2059%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Frank Gifford died suddenly at his home" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home.jpg 630w, https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home-295x300.jpg 295w, https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home-560x570.jpg 560w, https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home-260x265.jpg 260w, https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home-160x163.jpg 160w" data-lazy-sizes="(max-width: 59px) 100vw, 59px" title="Hall of Famer Frank Gifford dies at age 84 21" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home.jpg"><noscript><img width="59" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Frank Gifford died suddenly at his home" srcset="https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home.jpg 630w, https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home-295x300.jpg 295w, https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home-560x570.jpg 560w, https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home-260x265.jpg 260w, https://www.whodiedtoday.com/wp-content/uploads/2015/08/Frank-Gifford-died-suddenly-at-his-home-160x163.jpg 160w" sizes="(max-width: 59px) 100vw, 59px" title="Hall of Famer Frank Gifford dies at age 84 21"></noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/hall-famer-frank-gifford-dies-age-84/" title="Hall of Famer Frank Gifford dies at age 84"> Hall of Famer Frank Gifford dies at age 84 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2015/08/">August 9, 2015</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Hall of Famer Frank Gifford dies at age 84</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-2685 post type-post status-publish format-video has-post-thumbnail category-celebrity-video category-whodiedtoday tag-alberta-government tag-jim-prentice post_format-post-format-video"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/cassia-prentice-speaks-at-her-fathers-state-memorial-service/" title="Cassia Prentice speaks at her father&#8217;s state memorial service"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Cassia Prentice speaks at her father&#039;s state memorial service 22" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10.jpg 640w, https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10-300x225.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10-153x115.jpg 153w, https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10-170x128.jpg 170w, https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10-50x38.jpg 50w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" title="Cassia Prentice speaks at her father&#039;s state memorial service 23" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10.jpg"><noscript><img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Cassia Prentice speaks at her father&#039;s state memorial service 22" srcset="https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10.jpg 640w, https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10-300x225.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10-153x115.jpg 153w, https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10-170x128.jpg 170w, https://www.whodiedtoday.com/wp-content/uploads/2016/10/sddefault-10-50x38.jpg 50w" sizes="(max-width: 80px) 100vw, 80px" title="Cassia Prentice speaks at her father&#039;s state memorial service 23"></noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/cassia-prentice-speaks-at-her-fathers-state-memorial-service/" title="Cassia Prentice speaks at her father&#8217;s state memorial service"> Cassia Prentice speaks at her father&#8217;s state memorial service </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2016/10/">October 28, 2016</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.whodiedtoday.com/cassia-prentice-speaks-at-her-fathers-state-memorial-service/#comments" class="mh-comment-count-link" >1</a></span></div></div></li></ul></div></aside></div><aside class="mh-widget-col-1 mh-sidebar-2 mh-sidebar-wide" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-7" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4823718395360608" data-ad-slot="6986591440" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><div id="mh_magazine_custom_posts-9" class="mh-widget mh_magazine_custom_posts"><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-large clearfix post-5855 post type-post status-publish format-standard has-post-thumbnail category-recently-died category-who-important-died-today tag-actor tag-big-news tag-broadway tag-cdc tag-center-for-disease-control tag-corona tag-coronavirus tag-coronavirus-explained tag-coronavirus-latest-news tag-coronavirus-news tag-coronavirus-outbreak tag-coronavirus-pandemic tag-coronavirus-prevention tag-coronavirus-symptoms tag-coronavirus-update tag-coronavirus-us tag-covid-19 tag-covid-19-news tag-covid-19-outbreak tag-covid-19-updates tag-editors-picks tag-health tag-music tag-news tag-nick-cordero tag-outbreak tag-pandemic tag-pop-culture tag-quarantine tag-social-distancing tag-symptoms tag-the-latest-on-today tag-today"><div class="mh-custom-posts-large-inner clearfix"><figure class="mh-custom-posts-thumb-xl"> <a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.whodiedtoday.com/nick-cordero-the-41-hamilton-native-is-dead/" title="Nick Cordero, the 41-year-old Hamilton Native, is dead"><picture class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" title="Nick Cordero, the 41-year-old Hamilton Native, is dead 24">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-326x245.jpg.webp 326w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-80x60.jpg.webp 80w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20326%20245&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 326px) 100vw, 326px"/>
<img width="326" height="245" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20326%20245&#039;%3E%3C/svg%3E" alt="who important died today" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-326x245.jpg 326w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-80x60.jpg 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-326x245.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" title="Nick Cordero, the 41-year-old Hamilton Native, is dead 24">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-326x245.jpg.webp 326w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-80x60.jpg.webp 80w" sizes="(max-width: 326px) 100vw, 326px"/>
<img width="326" height="245" src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-326x245.jpg" alt="who important died today" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-326x245.jpg 326w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5855_Nick-Cordero-the-41-year-old-Hamilton-Native-is-dead-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px"/>
</picture>
</noscript> </a></figure><div class="mh-custom-posts-content"><div class="mh-custom-posts-header"><h3 class="mh-custom-posts-xl-title"> <a href="https://www.whodiedtoday.com/nick-cordero-the-41-hamilton-native-is-dead/" title="Nick Cordero, the 41-year-old Hamilton Native, is dead"> Nick Cordero, the 41-year-old Hamilton Native, is dead </a></h3><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/07/">July 6, 2020</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Nick Cordero, the 41-year-old Hamilton Native, is dead</span></span></span></div></div><div class="mh-excerpt">Nick Cordero, the Broadway star, died after a months-long battle with the coronavirus. Cordero, whose Broadway credits include Waitress and Rock of Ages, died on Sunday morning at the Cedars-Sinai Medical Center in Los Angeles, <a class="mh-excerpt-more" href="https://www.whodiedtoday.com/nick-cordero-the-41-hamilton-native-is-dead/" title="Nick Cordero, the 41-year-old Hamilton Native, is dead">[...]</a></div></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-5842 post type-post status-publish format-standard has-post-thumbnail category-famous-people-who-died-today-in-2020 category-recently-died tag-hugh-downs-20-20 tag-hugh-downs-2018 tag-hugh-downs-age tag-hugh-downs-and-barbara-walters-2020 tag-hugh-downs-dead-or-alive tag-hugh-downs-death tag-hugh-downs-health tag-hugh-downs-images tag-hugh-downs-last-interview tag-hugh-downs-obituary tag-hugh-downs-residence tag-hugh-downs-retired tag-kcal-9-news-afternoon tag-nbc tag-over-easy"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/hugh-downs-american-broadcaster-dead-at-99/" title="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99"><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99 26">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99 25" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99 26">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg" alt="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99 25" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5842_Hugh-Malcolm-Downs-February-14-1921-–-July-1-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/hugh-downs-american-broadcaster-dead-at-99/" title="Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99"> Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/07/">July 2, 2020</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Hugh Downs American broadcaster, television host, news anchor, TV producer dead at 99</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-5824 post type-post status-publish format-standard has-post-thumbnail category-people-that-died-today-celebs-who-died-today category-recently-died category-who-important-died-today tag-carl-reiner tag-celebrity-interviews tag-entertainment tag-rob-reiner"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/carl-reiner-hollywood-entertainer-dead-at-98/" title="Carl Reiner Hollywood entertainer is dead at 98"><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Carl Reiner Hollywood entertainer is dead at 98 27">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Carl Reiner March 20 1922 – June 29 2020" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Carl Reiner Hollywood entertainer is dead at 98 27">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg" alt="Carl Reiner March 20 1922 – June 29 2020" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Carl-Reiner-March-20-1922-–-June-29-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/carl-reiner-hollywood-entertainer-dead-at-98/" title="Carl Reiner Hollywood entertainer is dead at 98"> Carl Reiner Hollywood entertainer is dead at 98 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/06/">June 30, 2020</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Carl Reiner Hollywood entertainer is dead at 98</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-5814 post type-post status-publish format-standard has-post-thumbnail category-famous-people-who-died-today-in-2020 category-recently-died category-who-important-died-today tag-andrew-dalton tag-atlantic-ocean tag-bing tag-california tag-democratic-party tag-detective tag-entertainment-culture tag-financier tag-jerry-oconnell tag-lisa-bonder tag-model-and-actress tag-movie-producer tag-people-from-california tag-president tag-private-detective tag-real-estate-heir tag-stanford-university tag-steve-bing tag-steve-bing-movie tag-websites"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/movieproducer-steve-bing-dead-at-55-by-sucide/" title="Steve Bing Movie producer, film financier, real estate heir, and major Democratic political donor dead at 55"><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Steve Bing Movie producer, film financier, real estate heir, and major Democratic political donor dead at 55 28">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Steve Bing" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Steve Bing Movie producer, film financier, real estate heir, and major Democratic political donor dead at 55 28">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg" alt="Steve Bing" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Stephen-Leo-Bing-dead-at-55-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/movieproducer-steve-bing-dead-at-55-by-sucide/" title="Steve Bing Movie producer, film financier, real estate heir, and major Democratic political donor dead at 55"> Steve Bing Movie producer, film financier, real estate heir, and major Democratic political donor dead at 55 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/06/">June 24, 2020</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Steve Bing Movie producer, film financier, real estate heir, and major Democratic political donor dead at 55</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-5797 post type-post status-publish format-standard has-post-thumbnail category-famous-people-who-died-today-in-2020 category-recently-died category-who-important-died-today tag-jean-kennedy-smithvideo tag-news"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/jean-kennedy-smith-dead-at-92/" title="Jean Kennedy Smith, last surviving sibling of JFK, dead at 92"><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Jean Kennedy Smith, last surviving sibling of JFK, dead at 92 29">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Jean Kennedy Smith dead at 92" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Jean Kennedy Smith, last surviving sibling of JFK, dead at 92 29">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg" alt="Jean Kennedy Smith dead at 92" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Jean-Kennedy-Smith-dead-at-92-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/jean-kennedy-smith-dead-at-92/" title="Jean Kennedy Smith, last surviving sibling of JFK, dead at 92"> Jean Kennedy Smith, last surviving sibling of JFK, dead at 92 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/06/">June 18, 2020</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Jean Kennedy Smith, last surviving sibling of JFK, dead at 92</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-5787 post type-post status-publish format-standard has-post-thumbnail category-gone-but-not-forgotten category-recently-died tag-actor tag-actress tag-arjun-sarja tag-bollywood tag-bollywood-actor tag-cardiac-life-support-protocol tag-chief-minister tag-chiranjeevi-sarja tag-cinema-of-india tag-films tag-indian-culture tag-indian-films tag-kannada-artist tag-karnataka tag-sarja tag-shakti-prasad tag-sree-raam-films-international tag-the-innovative-film-award tag-unit-head tag-varadhanayaka"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/indian-actor-chiranjeevi-sarja-dead-at-39/" title="Bollywood actor Chiranjeevi Sarja dead at aged 39"><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Bollywood actor Chiranjeevi Sarja dead at aged 39 30">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Bollywood actor Chiranjeevi Sarja dead at aged 39" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Bollywood actor Chiranjeevi Sarja dead at aged 39 30">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg" alt="Bollywood actor Chiranjeevi Sarja dead at aged 39" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/actor-Chiranjeevi-Sarja-dead-at-39-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/indian-actor-chiranjeevi-sarja-dead-at-39/" title="Bollywood actor Chiranjeevi Sarja dead at aged 39"> Bollywood actor Chiranjeevi Sarja dead at aged 39 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/06/">June 10, 2020</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Bollywood actor Chiranjeevi Sarja dead at aged 39</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-5778 post type-post status-publish format-standard has-post-thumbnail category-famous-people-who-died-today-in-2020 category-recently-died category-who-important-died-today tag-1974-grammy-award tag-aaron tag-anita tag-anita-pointer tag-bonnie tag-bonnie-pointer tag-california tag-crossover tag-entertainment-culture tag-fairytale tag-first-grammy tag-fritz tag-grammy tag-grammy-winning-artist tag-grand-ole-opry tag-how-long tag-june tag-june-pointer tag-los-angeles tag-member-of-the-group tag-motown tag-motown-records tag-musical-groups tag-musician tag-musicians tag-oakland tag-pointer tag-pointer-sisters tag-roger-neal tag-ruth tag-singer tag-songs tag-the-associated-press tag-the-pointer-sisters tag-we-can tag-yes-we-can-can"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/bonnie-pointer-dead-at-69/" title="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69"><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69 31">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69 31">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg" alt="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/06/Patricia-Eva-Bonnie-Pointer-July-11-1950-–-June-8-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/bonnie-pointer-dead-at-69/" title="Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69"> Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/06/">June 9, 2020</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Bonnie Pointer founding of the Pointer Sisters and 1974 Grammy Award winner dead at 69</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-5760 post type-post status-publish format-standard has-post-thumbnail category-famous-people-who-died-today-in-2020 category-posting-categories category-recently-died category-who-important-died-today tag-activist-legend tag-aids-crisis tag-aids-crisis-activist tag-aids-pandemic tag-anthony-fauci tag-author tag-dr-fauci-and-larry-kramer tag-fauci-and-kramer tag-gay-liberation tag-gay-mens-health-crisis tag-gay-rights tag-hiv-aids tag-hiv-aids-awareness tag-in-memoriam tag-influential-aids-activist tag-larry-kramer tag-larry-kramer-death tag-larry-kramer-obituary tag-nonfiction tag-noveslist tag-obituary tag-pandemic tag-pbs tag-pbs-newshour tag-playwright-larry-kramer tag-remembering-larry-kramer tag-stonewall tag-writer tag-writing-legend"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/larry-kramer-aids-activist-dead-at-84/" title="Larry Kramer influential AIDS activist dead at 84"><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Larry Kramer influential AIDS activist dead at 84 33">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Larry Kramer influential AIDS activist dead at 84 32" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Larry Kramer influential AIDS activist dead at 84 33">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-80x60.jpg" alt="Larry Kramer influential AIDS activist dead at 84 32" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5760_Larry-Kramer-June-25-1935-–-May-27-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/larry-kramer-aids-activist-dead-at-84/" title="Larry Kramer influential AIDS activist dead at 84"> Larry Kramer influential AIDS activist dead at 84 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/05/">May 28, 2020</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Larry Kramer influential AIDS activist dead at 84</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-5684 post type-post status-publish format-standard has-post-thumbnail category-celebrityactor-who-died category-people-that-died-today-celebs-who-died-today category-recently-died tag-actor tag-ben-stiller-jerry-seinfeld tag-big-news tag-celebrity-deaths tag-comedy tag-comedy-legend tag-comic-actor tag-editors-picks tag-humor tag-jerry-stiller tag-jerry-stiller-best-moments tag-jerry-stiller-death tag-jerry-stiller-rip tag-jerry-stiller-roast tag-jerry-stiller-rush tag-jerry-stiller-seinfeld tag-jerry-stiller-seinfeld-secrets tag-jerry-stiller-serenity-now tag-jerry-stiller-zoolander tag-memorial tag-pop-culture tag-rest-in-peace tag-rip tag-seinfeld tag-seinfeld-jerry-stiller tag-television tag-the-latest-on-today tag-today"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/jerry-stiller-is-dead-at-92/" title="Jerry Stiller, ‘Seinfeld’ Co-star and Father of Ben Stiller is dead at 92"><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Jerry Stiller, ‘Seinfeld’ Co-star and Father of Ben Stiller is dead at 92 35">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Jerry Stiller, ‘Seinfeld’ Co-star and Father of Ben Stiller is dead at 92 34" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Jerry Stiller, ‘Seinfeld’ Co-star and Father of Ben Stiller is dead at 92 35">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-80x60.jpg" alt="Jerry Stiller, ‘Seinfeld’ Co-star and Father of Ben Stiller is dead at 92 34" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5684_Gerald-Isaac-Stiller-June-8-1927-–-May-11-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/jerry-stiller-is-dead-at-92/" title="Jerry Stiller, ‘Seinfeld’ Co-star and Father of Ben Stiller is dead at 92"> Jerry Stiller, ‘Seinfeld’ Co-star and Father of Ben Stiller is dead at 92 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/05/">May 11, 2020</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Jerry Stiller, ‘Seinfeld’ Co-star and Father of Ben Stiller is dead at 92</span></span></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-5693 post type-post status-publish format-standard has-post-thumbnail category-hot-trending-news-today category-people-that-died-today-celebs-who-died-today category-recently-died tag-grammy tag-k-c tag-mariah-carey tag-miami tag-steve-greenberg tag-sunshine tag-the-grammy tag-the-new-york-times tag-twitter tag-willie-clarke"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.whodiedtoday.com/legendary-singer-betty-wright-dead-at-66/" title="Legendary singer Betty Wright dead at 66"><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Legendary singer Betty Wright dead at 66 37">
<source type="image/webp" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-326x245.jpg.webp 326w" srcset="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" data-lazy-sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%2080%2060&#039;%3E%3C/svg%3E" alt="Legendary singer Betty Wright dead at 66 36" data-lazy-srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-326x245.jpg 326w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-80x60.jpg"/>
</picture>
<noscript><picture class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" title="Legendary singer Betty Wright dead at 66 37">
<source type="image/webp" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-80x60.jpg.webp 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-678x509.jpg.webp 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-326x245.jpg.webp 326w" sizes="(max-width: 80px) 100vw, 80px"/>
<img width="80" height="60" src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-80x60.jpg" alt="Legendary singer Betty Wright dead at 66 36" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-80x60.jpg 80w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-678x509.jpg 678w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/5693_stage-name-Betty-Wright-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/>
</picture>
</noscript> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://www.whodiedtoday.com/legendary-singer-betty-wright-dead-at-66/" title="Legendary singer Betty Wright dead at 66"> Legendary singer Betty Wright dead at 66 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.whodiedtoday.com/2020/05/">May 11, 2020</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Legendary singer Betty Wright dead at 66</span></span></span></div></div></li></ul></div></aside></div><footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix"><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols mh-footer-area mh-footer-1"><div id="custom_html-5" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe loading="lazy" src="about:blank" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0" data-rocket-lazyload="fitvidscompatible" data-lazy-src="//rcm-na.amazon-adsystem.com/e/cm?o=1&#038;p=12&#038;l=ur1&#038;category=primemain&#038;banner=1WK0VRNA75J95DFZRE02&#038;f=ifr&#038;linkID=ff1a8ad4fe0b7e5e1c6976bf0e3412a5&#038;t=ecompare0e-20&#038;tracking_id=ecompare0e-20"></iframe><noscript><iframe src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=12&l=ur1&category=primemain&banner=1WK0VRNA75J95DFZRE02&f=ifr&linkID=ff1a8ad4fe0b7e5e1c6976bf0e3412a5&t=ecompare0e-20&tracking_id=ecompare0e-20" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></noscript></div></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols mh-footer-area mh-footer-2"><div id="custom_html-6" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe loading="lazy" src="about:blank" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0" data-rocket-lazyload="fitvidscompatible" data-lazy-src="//rcm-na.amazon-adsystem.com/e/cm?o=1&#038;p=12&#038;l=ez&#038;f=ifr&#038;linkID=599d107ec24e5450556ee8903ecf5ddb&#038;t=ecompare0e-20&#038;tracking_id=ecompare0e-20"></iframe><noscript><iframe src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=12&l=ez&f=ifr&linkID=599d107ec24e5450556ee8903ecf5ddb&t=ecompare0e-20&tracking_id=ecompare0e-20" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></noscript></div></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols mh-footer-area mh-footer-3"></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols mh-footer-area mh-footer-4"><div id="mh_magazine_recent_comments-2" class="mh-footer-widget mh_magazine_recent_comments"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Recent Comments</span></h6><ul class="mh-user-widget mh-recent-comments-widget clearfix"><li class="mh-user-item clearfix"><figure class="mh-user-avatar"> <a href="https://www.whodiedtoday.com/a-tribute-to-jim-marshall-who-died-today-aged-88-rip/#comment-186" title="joe ardolino"> <img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g" /><noscript><img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' /></noscript> </a></figure><div class="mh-user-meta"> <span class="mh-recent-comments-author"> joe ardolino on </span> <a class="mh-recent-comments-link" href="https://www.whodiedtoday.com/a-tribute-to-jim-marshall-who-died-today-aged-88-rip/#comment-186" title="joe ardolino | A Tribute to Jim Marshall who died today aged 88 RiP"> A Tribute to Jim Marshall who died today aged 88 RiP </a></div></li><li class="mh-user-item clearfix"><figure class="mh-user-avatar"> <a href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-229" title="phiAndpi"> <img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g" /><noscript><img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' /></noscript> </a></figure><div class="mh-user-meta"> <span class="mh-recent-comments-author"> phiAndpi on </span> <a class="mh-recent-comments-link" href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-229" title="phiAndpi | Tribute to Sir Patrick Moore who died today."> Tribute to Sir Patrick Moore who died today. </a></div></li><li class="mh-user-item clearfix"><figure class="mh-user-avatar"> <a href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-221" title="Toy Pupanbai"> <img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g" /><noscript><img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' /></noscript> </a></figure><div class="mh-user-meta"> <span class="mh-recent-comments-author"> Toy Pupanbai on </span> <a class="mh-recent-comments-link" href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-221" title="Toy Pupanbai | Tribute to Sir Patrick Moore who died today."> Tribute to Sir Patrick Moore who died today. </a></div></li><li class="mh-user-item clearfix"><figure class="mh-user-avatar"> <a href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-222" title="An artist theory on the physics of &#039;Time&#039; as a physical process. Quantum Atom Theory"> <img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g" /><noscript><img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' /></noscript> </a></figure><div class="mh-user-meta"> <span class="mh-recent-comments-author"> An artist theory on the physics of &#039;Time&#039; as a physical process. Quantum Atom Theory on </span> <a class="mh-recent-comments-link" href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-222" title="An artist theory on the physics of &#039;Time&#039; as a physical process. Quantum Atom Theory | Tribute to Sir Patrick Moore who died today."> Tribute to Sir Patrick Moore who died today. </a></div></li><li class="mh-user-item clearfix"><figure class="mh-user-avatar"> <a href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-220" title="Toy Pupanbai"> <img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g" /><noscript><img alt='Avatar for whodied-admin' title='Gravatar for whodied-admin' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' /></noscript> </a></figure><div class="mh-user-meta"> <span class="mh-recent-comments-author"> Toy Pupanbai on </span> <a class="mh-recent-comments-link" href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-220" title="Toy Pupanbai | Tribute to Sir Patrick Moore who died today."> Tribute to Sir Patrick Moore who died today. </a></div></li></ul></div></div></div></footer><div class="mh-footer-nav-mobile"></div><nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><div class="mh-container mh-container-inner clearfix"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-4234" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4234"><a href="https://www.whodiedtoday.com/us/">About us</a></li><li id="menu-item-4235" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4235"><a href="https://www.whodiedtoday.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-4233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-4233"><a href="https://www.whodiedtoday.com/">Who Died Today</a></li><li id="menu-item-4236" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4236"><a href="https://www.whodiedtoday.com/terms-and-conditions/">Terms And Conditions</a></li></ul></div></div></nav><div class="mh-copyright-wrap"><div class="mh-container mh-container-inner clearfix"><p class="mh-copyright"> WHODIEDTODAY.COM - Copyright © 1996 - 2019. All Rights Reserved.</p></div></div> <a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a></div><div id="fb-root"></div>  <script type='text/javascript' src='https://stats.wp.com/e-202028.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7',blog:'75994832',post:'5876',tz:'-4',srv:'www.whodiedtoday.com'} ]);
	_stq.push([ 'clickTrackerInit', '75994832', '5876' ]);</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.whodiedtoday.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script src="https://videopal.me/js/vp_player.min.js?v=1.1.29" data-cfasync="false"></script>  <script>const wprRemoveCPCSS = () => { $elem = document.getElementById( "rocket-critical-css" ); if ( $elem ) { $elem.remove(); } }; if ( window.addEventListener ) { window.addEventListener( "load", wprRemoveCPCSS ); } else if ( window.attachEvent ) { window.attachEvent( "onload", wprRemoveCPCSS ); }</script><script src="https://www.whodiedtoday.com/wp-content/cache/min/1/f3809a23eba57c1b7a04c8975e71de68.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://www.whodiedtoday.com/wp-content/cache/min/1/ba531e5b8b625d4a33c3c9e381c43d17.css" data-minify="1" /></noscript><noscript><link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /></noscript><noscript><link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700&#038;display=swap' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.7/css/jetpack.css' type='text/css' media='all' /></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->