<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1" i-amphtml-binding>

<head><meta charset="UTF-8"><meta name="viewport" content="width=device-width"><link as="script" crossorigin="anonymous" href="https://cdn.ampproject.org/v0.mjs" rel="modulepreload"><link rel="preconnect" href="https://cdn.ampproject.org"><style amp-runtime="" i-amphtml-version="012106030132000">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</style><meta name="description" content="Mudcat Grant spent four years with the Twins where the right-hander posted a record of 50-35 with a 3.35 ERA. His best season came in 1965 where he went 21-7 with a 3.30 ERA."><meta name="robots" content="index, nofollow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="Dead At 85 Is Mudcat Grant, The 1st Black 20-game Winner In AL | Whodiedtoday.com"><meta property="og:description" content="Mudcat Grant spent four years with the Twins where the right-hander posted a record of 50-35 with a 3.35 ERA. His best season came in 1965 where he went 21-7 with a 3.30 ERA."><meta property="og:url" content="https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/"><meta property="og:site_name" content="whodiedtoday.com"><meta property="article:publisher" content="https://www.facebook.com/celebritywhodiedtoday/"><meta property="article:author" content="https://www.facebook.com/cakafete"><meta property="article:section" content="Who Died Today 2021"><meta property="fb:app_id" content="0554622171538732"><meta property="og:image" content="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg"><meta property="og:image:secure_url" content="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg"><meta property="og:image:width" content="1365"><meta property="og:image:height" content="455"><meta property="og:image:alt" content="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL."><meta property="og:image:type" content="image/jpeg"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="Dead At 85 Is Mudcat Grant, The 1st Black 20-game Winner In AL | Whodiedtoday.com"><meta name="twitter:description" content="Mudcat Grant spent four years with the Twins where the right-hander posted a record of 50-35 with a 3.35 ERA. His best season came in 1965 where he went 21-7 with a 3.30 ERA."><meta name="twitter:site" content="@cakafete"><meta name="twitter:creator" content="@cakafete"><meta name="twitter:image" content="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg"><meta name="generator" content="WordPress 5.7.2"><meta name="generator" content="Site Kit by Google 1.34.0"><meta name="generator" content="AMP Plugin v2.1.2; mode=standard"><meta name="msapplication-TileImage" content="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-300x300.png"><link rel="dns-prefetch" href="//www.whodiedtoday.com"><link rel="dns-prefetch" href="//s.w.org"><script async="" src="https://cdn.ampproject.org/v0.mjs" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0.js" crossorigin="anonymous"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.mjs" async="" custom-element="amp-analytics" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" crossorigin="anonymous" custom-element="amp-analytics"></script><script src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.mjs" async="" custom-element="amp-auto-ads" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js" crossorigin="anonymous" custom-element="amp-auto-ads"></script><script src="https://cdn.ampproject.org/v0/amp-bind-0.1.mjs" async="" custom-element="amp-bind" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" crossorigin="anonymous" custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.mjs" async="" custom-element="amp-form" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-form-0.1.js" crossorigin="anonymous" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-mustache-0.2.mjs" async="" custom-template="amp-mustache" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-mustache-0.2.js" crossorigin="anonymous" custom-template="amp-mustache"></script><link rel="icon" href="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-150x150.png" sizes="32x32"><link rel="icon" href="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-300x300.png" sizes="192x192"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home --><link rel="canonical" href="https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/"><script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":["Person","Organization"],"@id":"https://www.whodiedtoday.com/#person","name":"whodied-admin","logo":{"@type":"ImageObject","@id":"https://www.whodiedtoday.com/#logo","url":"https://www.whodiedtoday.com/wp-content/uploads/2020/04/cropped-new-whodiedtoday-logo.png","caption":"whodied-admin","inLanguage":"en-US","width":"371","height":"123"},"image":{"@type":"ImageObject","@id":"https://www.whodiedtoday.com/#logo","url":"https://www.whodiedtoday.com/wp-content/uploads/2020/04/cropped-new-whodiedtoday-logo.png","caption":"whodied-admin","inLanguage":"en-US","width":"371","height":"123"}},{"@type":"WebSite","@id":"https://www.whodiedtoday.com/#website","url":"https://www.whodiedtoday.com","name":"whodied-admin","publisher":{"@id":"https://www.whodiedtoday.com/#person"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg","url":"https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg","width":"1365","height":"455","caption":"Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL.","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.whodiedtoday.com/author/whodied-admin/","name":"whodied-admin","url":"https://www.whodiedtoday.com/author/whodied-admin/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=96&amp;r=g","url":"https://secure.gravatar.com/avatar/88efd05bf6f4c18dec9a5ca5f2e90ed6?s=96&amp;r=g","caption":"whodied-admin","inLanguage":"en-US"}},{"@type":"WebPage","@id":"https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/#webpage","url":"https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/","name":"Dead At 85 Is Mudcat Grant, The 1st Black 20-game Winner In AL | Whodiedtoday.com","datePublished":"2021-06-12T21:36:00-04:00","dateModified":"2021-06-12T21:36:00-04:00","author":{"@id":"https://www.whodiedtoday.com/author/whodied-admin/"},"isPartOf":{"@id":"https://www.whodiedtoday.com/#website"},"primaryImageOfPage":{"@id":"https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg"},"inLanguage":"en-US"},{"@type":"BlogPosting","headline":"Dead At 85 Is Mudcat Grant, The 1st Black 20-game Winner In AL | Whodiedtoday.com","keywords":"Mudcat Grant","datePublished":"2021-06-12T21:36:00-04:00","dateModified":"2021-06-12T21:36:00-04:00","author":{"@type":"Person","name":"whodied-admin"},"publisher":{"@id":"https://www.whodiedtoday.com/#person"},"description":"Mudcat Grant spent four years with the Twins where the right-hander posted a record of 50-35 with a 3.35 ERA. His best season came in 1965 where he went 21-7 with a 3.30 ERA.","name":"Dead At 85 Is Mudcat Grant, The 1st Black 20-game Winner In AL | Whodiedtoday.com","@id":"https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/#richSnippet","isPartOf":{"@id":"https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/#webpage"},"image":{"@id":"https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/#webpage"}}]}</script><!-- /Rank Math WordPress SEO plugin --><link rel="alternate" type="application/rss+xml" title="whodiedtoday.com » Feed" href="https://www.whodiedtoday.com/feed/"><link rel="alternate" type="application/rss+xml" title="whodiedtoday.com » Comments Feed" href="https://www.whodiedtoday.com/comments/feed/"><link rel="alternate" type="application/rss+xml" title="whodiedtoday.com » Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL Comments Feed" href="https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/feed/"><link rel="https://api.w.org/" href="https://www.whodiedtoday.com/wp-json/"><link rel="alternate" type="application/json" href="https://www.whodiedtoday.com/wp-json/wp/v2/posts/7075"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.whodiedtoday.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.whodiedtoday.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://www.whodiedtoday.com/?p=7075"><link rel="alternate" type="application/json+oembed" href="https://www.whodiedtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.whodiedtoday.com%2Fdead-at-85-is-mudcat-grant-former-twins-pitcher%2F"><link rel="alternate" type="text/xml+oembed" href="https://www.whodiedtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.whodiedtoday.com%2Fdead-at-85-is-mudcat-grant-former-twins-pitcher%2F&amp;format=xml"><link rel="apple-touch-icon" href="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-Whodiedtodaylogo-512x512-1-300x300.png"><title>Dead At 85 Is Mudcat Grant, The 1st Black 20-game Winner In AL | Whodiedtoday.com</title></head>

<body class="post-template-default single single-post postid-7075 single-format-standard wp-custom-logo centered-theme-layout has-sidebar site-title-hidden site-description-hidden is-amp-page is-blog-page">
<amp-auto-ads type="adsense" data-ad-client="ca-pub-4823718395360608" class="i-amphtml-layout-container" i-amphtml-layout="container"></amp-auto-ads>
	
	<div id="page" class="site">
		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
			<div id="header-top" class="header-bar-wrap">

				<div id="header-bar" class="header-bar">

					
						<button class="secondary-menu-toggle menu-toggle" aria-controls="secondary-menu" aria-expanded="false" data-amp-bind-aria-expanded="secondaryMenuExpanded? 'true' : 'false'" on="tap:AMP.setState({secondaryMenuExpanded: !secondaryMenuExpanded})" i-amphtml-binding>
							<svg class="icon icon-ellipsis" aria-hidden="true" role="img"> <use xlink:href="https://www.whodiedtoday.com/wp-content/themes/dynamico/assets/icons/genericons-neue.svg#ellipsis"></use> </svg><svg class="icon icon-close" aria-hidden="true" role="img"> <use xlink:href="https://www.whodiedtoday.com/wp-content/themes/dynamico/assets/icons/genericons-neue.svg#close"></use> </svg>							<span class="menu-toggle-text">Menu</span>
						</button>

						<div class="secondary-navigation">

							<nav class="top-navigation" role="navigation" data-amp-bind-class="'top-navigation' + ( secondaryMenuExpanded ? ' toggled-on' : '' )" aria-label="Secondary Menu" i-amphtml-binding>

								<ul id="secondary-menu" class="menu"><li id="menu-item-7035" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-7035"><a href="https://www.whodiedtoday.com/">Home</a></li>
<li id="menu-item-6588" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6588"><a href="https://www.whodiedtoday.com/who-died-today-2021/">Who died today 2021</a></li>
<li id="menu-item-859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-859"><a href="https://www.whodiedtoday.com/those-who-have-left-us-2/">Those who have left us</a></li>
<li id="menu-item-857" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-857"><a href="https://www.whodiedtoday.com/gone-but-not-forgotten/">Gone-but-not-forgotten</a></li>
<li id="menu-item-1311" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1311"><a href="https://www.whodiedtoday.com/people-that-died-today-celebs-who-died-today/">celebs-who-died-today</a></li>
<li id="menu-item-6589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6589"><a href="https://www.whodiedtoday.com/laid-to-rest/">Laid-to-rest</a></li>
<li id="menu-item-860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-860"><a href="https://www.whodiedtoday.com/who-died-on-dominica/">Dominica</a></li>
</ul>							</nav><!-- .top-navigation -->

						</div><!-- .secondary-navigation -->

						
				</div>

			</div>

			
		<header id="masthead" class="site-header" role="banner">

			<div class="header-main">

				
			<div class="site-logo">
				<a href="https://www.whodiedtoday.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="481" height="61" src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1.png" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="whodiedtoday.com" data-hero-candidate="" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1.png 481w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1-300x38.png 300w" sizes="(max-width: 481px) 100vw, 481px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic" data-hero i-amphtml-ssr><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYxIiB3aWR0aD0iNDgxIiB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZlcnNpb249IjEuMSIvPg=="></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" alt="whodiedtoday.com" src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1.png" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1.png 481w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/cropped-cropped-cropped-cropped-Whodiedtodaylogo-512x512-1-300x38.png 300w" sizes="(max-width: 481px) 100vw, 481px"></amp-img></a>			</div>

			
				
<div class="site-branding">

	
			<p class="site-title"><a href="https://www.whodiedtoday.com/" rel="home">whodiedtoday.com</a></p>

			
			<p class="site-description">People who died today—a family member, friend, co-worker, celebrity, Hollywood actor, sports personality, or other.</p>

			
</div><!-- .site-branding -->

				
	<div class="header-content">

		
			<div class="header-widgets">

				<aside id="search-11" class="header-widget widget_search">
<form role="search" method="get" class="search-form" action="https://www.whodiedtoday.com/" target="_top">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search …" value="" name="s" title="Search for:">
	</label>
	<button type="submit" class="search-submit">
		<svg class="icon icon-search" aria-hidden="true" role="img"> <use xlink:href="https://www.whodiedtoday.com/wp-content/themes/dynamico/assets/icons/genericons-neue.svg#search"></use> </svg>		<span class="screen-reader-text">Search</span>
	</button>
</form>
</aside>
			</div><!-- .header-widgets -->

		
		
	</div>

	
			</div><!-- .header-main -->

			


		</header><!-- #masthead -->

		
		
		
		<div id="content" class="site-content">

			<main id="main" class="site-main" role="main">

				
<article id="post-7075" class="post-7075 post type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-2021">

	
			<figure class="post-image post-image-single">
				<amp-img width="1365" height="455" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg" class="attachment-dynamico-ultra-wide size-dynamico-ultra-wide wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL." srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg 1365w, https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL.-300x100.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL.-1024x341.jpeg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL.-768x256.jpeg 768w" sizes="(max-width: 1365px) 100vw, 1365px" data-hero-candidate="" title="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL 1" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic" data-hero i-amphtml-ssr><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjQ1NSIgd2lkdGg9IjEzNjUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" loading="lazy" alt="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL." src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL..jpeg 1365w, https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL.-300x100.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL.-1024x341.jpeg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL.-768x256.jpeg 768w" sizes="(max-width: 1365px) 100vw, 1365px" title="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL 1"></amp-img>
							</figure><!-- .post-image -->

			
	<header class="post-header entry-header">

		<h1 class="post-title entry-title">Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL</h1>
		<div class="entry-meta"><span class="posted-on"><a href="https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-12T21:36:00-04:00">June 12, 2021</time></a></span><span class="posted-by"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by whodied-admin" rel="author">whodied-admin</a></span></span><span class="entry-comments"> <a href="https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/#respond">No comments</a></span></div>
	</header><!-- .entry-header -->

	
<div class="entry-content">

	
<p>MINNEAPOLIS (AP news): Mudcat Grant (Jim “Mudcat” Grant), the first Black 20-game winner in the American League and a key part of Minnesota’s first World Series team in 1965, has died. He was 85.</p>



<p>The Twins announced Grant’s death Saturday but gave no cause for his death. On behalf of the former right-hander’s family, Grant’s assistant informed the Twins of the death.</p>



<p>Grant spent less than four full seasons of his 14-year major league career with the Twins, but they were by far his best.</p>



<p>After being acquired in a trade with Cleveland on June 15, 1964, for George Banks and Lee Stange, Grant led the American League with 21 wins in 1965. Don Newcombe of the Brooklyn Dodgers was the first Black 20-game winner in the majors in 1951.</p>



<p>Grant’s career-best season helped the Twins post a 102-60 record for a spot in the World Series. He also led the league with six shutouts in 1965.</p>



<p>He started three times in that World Series against the Los Angeles Dodgers and won twice — including a 5-1, complete-game victory in Game 6, during which he also hit a three-run homer. Sandy Koufax and the Dodgers won Game 7.</p>



<p>Grant went 50-35 with a 3.35 ERA in 129 appearances, including 111 starts, with the Twins. He was traded to the Dodgers after the 1967 season and wound up pitching for Montreal, St. Louis, Oakland, and Pittsburgh.</p>



<p>Grant was long known by his unique nickname, though there are varying stories about its origination. The native of Lacoochee, Florida, where he grew up poor in a small, segregated town north of Tampa, signed with Cleveland at age 18 and made his major league debut for the Indians in 1958. He finished his 14-year career with a 145-119 record and a 3.63 ERA over 571 appearances, including 293 starts.</p>



<p>After retiring from the mound, Mudcat Grant worked in Cleveland’s community relations department and as a broadcaster while becoming an activist and advocate for Black participation in sports. He co-wrote a book published in 2006, “<a target="_blank" href="https://www.amazon.com/Black-Aces-Baseballs-African-American-Twenty-Game/dp/1593304870" rel="noreferrer noopener nofollow">The Black Aces</a>,” which chronicled the lives of his fellow Black 20-game winners like Bob Gibson and Ferguson Jenkins. In 2007, President George W. Bush honored Grant and “The Black Aces” at a <a target="_blank" href="https://georgewbush-whitehouse.archives.gov/news/releases/2007/02/20070212-5.html" rel="noreferrer noopener nofollow">White House ceremony</a> for Black history month.</p>



<p>“At certain points in our past, we didn’t have a lot of African American pitchers,” Bush said that day. “I want to thank you, Mudcat, for showing courage, character, and perseverance, and also thank you for setting an example.”</p>



<p>The Twins held a moment of silence for Mudcat Grant before their game against Houston on Saturday night after showing a brief montage of black-and-white highlights from his playing career.</p>



<p>He was a frequent visitor to the team’s annual winter fan festival and <a target="_blank" href="https://www.youtube.com/watch?v=w15y8ZY3tm0" rel="noreferrer noopener nofollow">maintained strong relationships with the Twins</a> long after his playing days. Grant was an accomplished musician, too, with a talent for the blues. He sang a cover of Louis Armstrong’s “What a Wonderful World” at the 2011 memorial service for his former Twins teammate, Harmon Killebrew.</p>



<p>“Will never forget his smile, his voice, or the way he could light up a room,” Twins president Dave St. Peter <a target="_blank" href="https://twitter.com/TwinsPrez/status/1403806105747312645" rel="noreferrer noopener nofollow">said on Twitter</a>.</p>



<p><a href="https://www.whodiedtoday.com/">Home</a></p>
	
</div><!-- .entry-content -->

		
		<div class="entry-categories"> <ul class="post-categories">
	<li><a href="https://www.whodiedtoday.com/who-died-today-2021/" rel="category tag">Who Died Today 2021</a></li></ul></div>
</article>

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.whodiedtoday.com/robert-hogan-the-veteran-tv-actor-dies-at-87/" rel="prev"><span class="nav-link-text">Previous Post</span><h3 class="entry-title">Robert Hogan, the Veteran TV actor, dies at 87</h3></a></div><div class="nav-next"><a href="https://www.whodiedtoday.com/ganga-stone-sustenance-to-aids-dead-at-79/" rel="next"><span class="nav-link-text">Next Post</span><h3 class="entry-title">Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79</h3></a></div></div>
	</nav><div class="themezee-related-posts related-posts"><header class="related-posts-header"><h2 class="related-posts-title entry-title">Related Posts</h2></header>
	<div class="related-posts-grid">

		<div class="related-posts-columns related-posts-three-columns clearfix">

		
			<div class="related-post-column clearfix">

				<article id="post-7083">

					<a href="https://www.whodiedtoday.com/ganga-stone-sustenance-to-aids-dead-at-79/" rel="bookmark"><amp-img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Ganga-Stone-the-lady-who-gave-sustenance-to-AIDS-patients-dead-at-79-800x440.jpeg" class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79" title="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79 2" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjQ0MCIgd2lkdGg9IjgwMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Ganga-Stone-the-lady-who-gave-sustenance-to-AIDS-patients-dead-at-79-800x440.jpeg" alt="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79" loading="lazy" title="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79 2"></noscript></amp-img></a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/ganga-stone-sustenance-to-aids-dead-at-79/" rel="bookmark">Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/ganga-stone-sustenance-to-aids-dead-at-79/" title="1:12 PM" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-13T13:12:27-04:00">June 13, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by whodied-admin" rel="author">whodied-admin</a></span></span>
		</div>

	
				</article>

			</div>

		
			<div class="related-post-column clearfix">

				<article id="post-7018">

					<a href="https://www.whodiedtoday.com/robert-hogan-the-veteran-tv-actor-dies-at-87/" rel="bookmark"><amp-img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Robert-Hogan-Veteran-TV-actor-dies-at-87-800x440.jpeg" class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Robert Hogan, Veteran TV actor, dies at 87" title="Robert Hogan, the Veteran TV actor, dies at 87 3" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjQ0MCIgd2lkdGg9IjgwMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Robert-Hogan-Veteran-TV-actor-dies-at-87-800x440.jpeg" alt="Robert Hogan, Veteran TV actor, dies at 87" loading="lazy" title="Robert Hogan, the Veteran TV actor, dies at 87 3"></noscript></amp-img></a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/robert-hogan-the-veteran-tv-actor-dies-at-87/" rel="bookmark">Robert Hogan, the Veteran TV actor, dies at 87</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/robert-hogan-the-veteran-tv-actor-dies-at-87/" title="10:26 PM" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-05T22:26:09-04:00">June 5, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by whodied-admin" rel="author">whodied-admin</a></span></span>
		</div>

	
				</article>

			</div>

		
			<div class="related-post-column clearfix">

				<article id="post-6839">

					<a href="https://www.whodiedtoday.com/charles-grodin-the-heartbreak-kid-actor-dead-at-86/" rel="bookmark"><amp-img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Charles-Grodin-Heartbreak-Kid-Actor-Dead-at-86-800x440.jpeg" class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Charles Grodin Heartbreak Kid Actor Dead at 86" title="Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86 4" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjQ0MCIgd2lkdGg9IjgwMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="800" height="440" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Charles-Grodin-Heartbreak-Kid-Actor-Dead-at-86-800x440.jpeg" alt="Charles Grodin Heartbreak Kid Actor Dead at 86" loading="lazy" title="Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86 4"></noscript></amp-img></a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/charles-grodin-the-heartbreak-kid-actor-dead-at-86/" rel="bookmark">Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/charles-grodin-the-heartbreak-kid-actor-dead-at-86/" title="7:41 PM" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-18T19:41:46-04:00">May 18, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by whodied-admin" rel="author">whodied-admin</a></span></span>
		</div>

	
				</article>

			</div>

		
			<div class="related-post-column clearfix">

				<article id="post-6810">

					<a href="https://www.whodiedtoday.com/dead-at-88-is-lloyd-price-rb-pioneer/" rel="bookmark"><amp-img width="420" height="210" src="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Lloyd-Price-dead-at-88-420x210.jpeg" class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Lloyd Price dead at 88" title="Dead at 88 is Lloyd Price, R&amp;B Pioneer Best Known as ‘Mr. Personality 5" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIxMCIgd2lkdGg9IjQyMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="420" height="210" src="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Lloyd-Price-dead-at-88-420x210.jpeg" alt="Lloyd Price dead at 88" loading="lazy" title="Dead at 88 is Lloyd Price, R&amp;B Pioneer Best Known as ‘Mr. Personality 5"></noscript></amp-img></a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/dead-at-88-is-lloyd-price-rb-pioneer/" rel="bookmark">Dead at 88 is Lloyd Price, R&amp;B Pioneer Best Known as ‘Mr. Personality</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/dead-at-88-is-lloyd-price-rb-pioneer/" title="9:12 AM" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-08T09:12:38-04:00">May 8, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by whodied-admin" rel="author">whodied-admin</a></span></span>
		</div>

	
				</article>

			</div>

		
			<div class="related-post-column clearfix">

				<article id="post-6802">

					<a href="https://www.whodiedtoday.com/actress-olympia-dukakis-dead-at-89/" rel="bookmark"><amp-img width="420" height="210" src="https://www.whodiedtoday.com/wp-content/uploads/2021/05/actress-Olympia-Dukakis-died-at-89-420x210.jpeg" class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Veteran U.S. Actress Olympia Dukakis dead at 89" title="Veteran U.S. Actress Olympia Dukakis dead at 89 6" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIxMCIgd2lkdGg9IjQyMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="420" height="210" src="https://www.whodiedtoday.com/wp-content/uploads/2021/05/actress-Olympia-Dukakis-died-at-89-420x210.jpeg" alt="Veteran U.S. Actress Olympia Dukakis dead at 89" loading="lazy" title="Veteran U.S. Actress Olympia Dukakis dead at 89 6"></noscript></amp-img></a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/actress-olympia-dukakis-dead-at-89/" rel="bookmark">Veteran U.S. Actress Olympia Dukakis dead at 89</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/actress-olympia-dukakis-dead-at-89/" title="5:13 PM" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-01T17:13:53-04:00">May 1, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by whodied-admin" rel="author">whodied-admin</a></span></span>
		</div>

	
				</article>

			</div>

		
			<div class="related-post-column clearfix">

				<article id="post-6798">

					<a href="https://www.whodiedtoday.com/former-us-vice-president-walter-mondale-dead-93/" rel="bookmark"><amp-img width="420" height="210" src="https://www.whodiedtoday.com/wp-content/uploads/2021/04/Former-US-Vice-President-Walter-Mondale-under-President-Jimmy-Carter-dead-93-420x210.jpeg" class="attachment-themezee-related-posts size-themezee-related-posts wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Former U.S. Vice President Walter Mondale, under President Jimmy Carter dead 93" title="Former U.S. Vice President Walter Mondale, under President Jimmy Carter dead 93 7" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIxMCIgd2lkdGg9IjQyMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="420" height="210" src="https://www.whodiedtoday.com/wp-content/uploads/2021/04/Former-US-Vice-President-Walter-Mondale-under-President-Jimmy-Carter-dead-93-420x210.jpeg" alt="Former U.S. Vice President Walter Mondale, under President Jimmy Carter dead 93" loading="lazy" title="Former U.S. Vice President Walter Mondale, under President Jimmy Carter dead 93 7"></noscript></amp-img></a>
					<header class="entry-header">

						<h4 class="entry-title"><a href="https://www.whodiedtoday.com/former-us-vice-president-walter-mondale-dead-93/" rel="bookmark">Former U.S. Vice President Walter Mondale, under President Jimmy Carter dead 93</a></h4>
					</header><!-- .entry-header -->

					
		<div class="entry-meta">

		<span class="meta-date"><a href="https://www.whodiedtoday.com/former-us-vice-president-walter-mondale-dead-93/" title="10:15 PM" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-19T22:15:06-04:00">April 19, 2021</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by whodied-admin" rel="author">whodied-admin</a></span></span>
		</div>

	
				</article>

			</div>

		
		</div>

	</div>

</div>
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span data-amp-bind-text='commentform_post_7075.replyToName ? "Leave a Reply to " + commentform_post_7075.replyToName + "" : "Leave a Reply"' i-amphtml-binding>Leave a Reply</span> <small><a id="cancel-comment-reply-link" href="/dead-at-85-is-mudcat-grant-former-twins-pitcher/#respond" hidden data-amp-bind-hidden='commentform_post_7075.values.comment_parent == "0"' on='tap:AMP.setState( {"commentform_post_7075":{"replyToName":"","values":{"comment_parent":"0"}}} )' i-amphtml-binding>Cancel reply</a></small></h3><form method="post" id="commentform" class="comment-form" novalidate action-xhr="https://www.whodiedtoday.com/wp-comments-post.php?_wp_amp_action_xhr_converted=1" target="_top" on='submit:AMP.setState( { "commentform_post_7075": { submitting: true } } );submit-error:AMP.setState( { "commentform_post_7075": { submitting: false } } );submit-success:AMP.setState( { commentform_post_7075: {"values":{"submit":"Post Comment","comment_post_ID":"7075","comment_parent":"0","akismet_comment_nonce":"0264c32f60","ak_js":"235","comment":"","ak_hp_textarea":""},"submitting":false,"replyToName":""} } )'><amp-state id="commentform_post_7075" class="i-amphtml-layout-container" i-amphtml-layout="container"><script type="application/json">{"values":{"author":"","email":"","url":"","submit":"Post Comment","comment_post_ID":"7075","comment_parent":"0","akismet_comment_nonce":"0264c32f60","ak_js":"235","comment":"","ak_hp_textarea":""},"submitting":false,"replyToName":""}</script></amp-state><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required" data-amp-bind-disabled="commentform_post_7075.submitting" data-amp-bind-text="commentform_post_7075.values.comment" on='change:AMP.setState( { commentform_post_7075: { values: { "comment": event.value } } } )' i-amphtml-binding></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" data-amp-bind-disabled="commentform_post_7075.submitting" data-amp-bind-value="commentform_post_7075.values.author" on='change:AMP.setState( { commentform_post_7075: { values: { "author": event.value } } } )' i-amphtml-binding></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" data-amp-bind-disabled="commentform_post_7075.submitting" data-amp-bind-value="commentform_post_7075.values.email" on='change:AMP.setState( { commentform_post_7075: { values: { "email": event.value } } } )' i-amphtml-binding></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" data-amp-bind-disabled="commentform_post_7075.submitting" data-amp-bind-value="commentform_post_7075.values.url" on='change:AMP.setState( { commentform_post_7075: { values: { "url": event.value } } } )' i-amphtml-binding></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes"> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" data-amp-bind-disabled="commentform_post_7075.submitting" data-amp-bind-value="commentform_post_7075.values.submit" on='change:AMP.setState( { commentform_post_7075: { values: { "submit": event.value } } } )' i-amphtml-binding> <input type="hidden" name="comment_post_ID" value="7075" id="comment_post_ID" data-amp-bind-disabled="commentform_post_7075.submitting" data-amp-bind-value="commentform_post_7075.values.comment_post_ID" on='change:AMP.setState( { commentform_post_7075: { values: { "comment_post_ID": event.value } } } )' i-amphtml-binding>
<input type="hidden" name="comment_parent" id="comment_parent" value="0" data-amp-bind-disabled="commentform_post_7075.submitting" data-amp-bind-value="commentform_post_7075.values.comment_parent" on='change:AMP.setState( { commentform_post_7075: { values: { "comment_parent": event.value } } } )' i-amphtml-binding>
</p><p data-amp-original-style="display: none;" class="amp-wp-224b51a"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0264c32f60" data-amp-bind-disabled="commentform_post_7075.submitting" data-amp-bind-value="commentform_post_7075.values.akismet_comment_nonce" on='change:AMP.setState( { commentform_post_7075: { values: { "akismet_comment_nonce": event.value } } } )' i-amphtml-binding></p><input type="hidden" id="ak_js" name="ak_js" value="235" data-amp-bind-disabled="commentform_post_7075.submitting" data-amp-bind-value="commentform_post_7075.values.ak_js" on='change:AMP.setState( { commentform_post_7075: { values: { "ak_js": event.value } } } )' i-amphtml-binding><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" data-amp-bind-disabled="commentform_post_7075.submitting" data-amp-bind-text="commentform_post_7075.values.ak_hp_textarea" on='change:AMP.setState( { commentform_post_7075: { values: { "ak_hp_textarea": event.value } } } )' data-amp-original-style="display: none !important;" class="amp-wp-3e2e7c3" i-amphtml-binding></textarea><div class="amp-wp-default-form-message" submit-error=""><template type="amp-mustache"><p class="{{#redirecting}}amp-wp-form-redirecting{{/redirecting}}">{{#message}}{{{message}}}{{/message}}{{^message}}Your submission failed. <small>The server responded with {{status_text}} (code {{status_code}}). Please contact the developer of this form processor to improve this message. <a href="https://amp-wp.org/?p=5463" target="_blank" rel="nofollow noreferrer noopener">Learn More</a></small>{{/message}}</p></template></div><div class="amp-wp-default-form-message" submit-success=""><template type="amp-mustache"><p class="{{#redirecting}}amp-wp-form-redirecting{{/redirecting}}">{{#message}}{{{message}}}{{/message}}{{^message}}It appears your submission was successful. <small>Even though the server responded OK, it is possible the submission was not processed. Please contact the developer of this form processor to improve this message. <a href="https://amp-wp.org/?p=5463" target="_blank" rel="nofollow noreferrer noopener">Learn More</a></small>{{/message}}</p></template></div><div class="amp-wp-default-form-message" submitting=""><template type="amp-mustache"><p>Submitting…</p></template></div></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->

		</main><!-- #main -->

		
	<section id="secondary" class="sidebar widget-area" role="complementary">

		<div id="tzwb-recent-posts-5" class="widget tzwb-recent-posts"><h3 class="widget-title">Latest Death</h3>
		<div class="tzwb-content tzwb-clearfix">

			<ul class="tzwb-posts-list">
				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/ganga-stone-sustenance-to-aids-dead-at-79/" title="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79">
							<amp-img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Ganga-Stone-the-lady-who-gave-sustenance-to-AIDS-patients-dead-at-79-150x150.jpeg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79" title="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79 8" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjE1MCIgd2lkdGg9IjE1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Ganga-Stone-the-lady-who-gave-sustenance-to-AIDS-patients-dead-at-79-150x150.jpeg" alt="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79" loading="lazy" title="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79 8"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/ganga-stone-sustenance-to-aids-dead-at-79/" title="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79">
						Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/" title="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL">
							<amp-img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL.-150x150.jpeg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL." data-hero-candidate="" title="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL 9" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjE1MCIgd2lkdGg9IjE1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL.-150x150.jpeg" alt="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL." loading="lazy" title="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL 9"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/" title="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL">
						Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/robert-hogan-the-veteran-tv-actor-dies-at-87/" title="Robert Hogan, the Veteran TV actor, dies at 87">
							<amp-img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Robert-Hogan-Veteran-TV-actor-dies-at-87-150x150.jpeg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Robert Hogan, Veteran TV actor, dies at 87" title="Robert Hogan, the Veteran TV actor, dies at 87 10" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjE1MCIgd2lkdGg9IjE1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Robert-Hogan-Veteran-TV-actor-dies-at-87-150x150.jpeg" alt="Robert Hogan, Veteran TV actor, dies at 87" loading="lazy" title="Robert Hogan, the Veteran TV actor, dies at 87 10"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/robert-hogan-the-veteran-tv-actor-dies-at-87/" title="Robert Hogan, the Veteran TV actor, dies at 87">
						Robert Hogan, the Veteran TV actor, dies at 87					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/charles-grodin-the-heartbreak-kid-actor-dead-at-86/" title="Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86">
							<amp-img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Charles-Grodin-Heartbreak-Kid-Actor-Dead-at-86-150x150.jpeg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Charles Grodin Heartbreak Kid Actor Dead at 86" title="Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86 11" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjE1MCIgd2lkdGg9IjE1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Charles-Grodin-Heartbreak-Kid-Actor-Dead-at-86-150x150.jpeg" alt="Charles Grodin Heartbreak Kid Actor Dead at 86" loading="lazy" title="Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86 11"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/charles-grodin-the-heartbreak-kid-actor-dead-at-86/" title="Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86">
						Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/dead-at-88-is-lloyd-price-rb-pioneer/" title="Dead at 88 is Lloyd Price, R&amp;B Pioneer Best Known as ‘Mr. Personality">
							<amp-img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Lloyd-Price-dead-at-88-75x75.jpeg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Lloyd Price dead at 88" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Lloyd-Price-dead-at-88-75x75.jpeg 75w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Lloyd-Price-dead-at-88-150x150.jpeg 150w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Lloyd-Price-dead-at-88-90x90.jpeg 90w" sizes="(max-width: 75px) 100vw, 75px" title="Dead at 88 is Lloyd Price, R&amp;B Pioneer Best Known as ‘Mr. Personality 12" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijc1IiB3aWR0aD0iNzUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Lloyd-Price-dead-at-88-75x75.jpeg" alt="Lloyd Price dead at 88" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Lloyd-Price-dead-at-88-75x75.jpeg 75w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Lloyd-Price-dead-at-88-150x150.jpeg 150w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Lloyd-Price-dead-at-88-90x90.jpeg 90w" sizes="(max-width: 75px) 100vw, 75px" title="Dead at 88 is Lloyd Price, R&amp;B Pioneer Best Known as ‘Mr. Personality 12"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/dead-at-88-is-lloyd-price-rb-pioneer/" title="Dead at 88 is Lloyd Price, R&amp;B Pioneer Best Known as ‘Mr. Personality">
						Dead at 88 is Lloyd Price, R&amp;B Pioneer Best Known as ‘Mr. Personality					</a>

							</li></ul>

		</div>

		</div><div id="tzwb-recent-posts-4" class="widget tzwb-recent-posts"><h3 class="widget-title">Random  Post Today</h3>
		<div class="tzwb-content tzwb-clearfix">

			<ul class="tzwb-posts-list">
				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/k-c-jones-boston-celtics-hall-of-famer-died-at-88/" title="K.C. Jones Boston Celtics Hall of Famer Died at 88">
							<amp-img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2020/12/K.C.-Jones-Boston-Celtics-Hall-of-Famer-Died-at-88-75x75.jpg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="K.C. Jones Boston Celtics Hall of Famer Died at 88" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/12/K.C.-Jones-Boston-Celtics-Hall-of-Famer-Died-at-88-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/K.C.-Jones-Boston-Celtics-Hall-of-Famer-Died-at-88-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/K.C.-Jones-Boston-Celtics-Hall-of-Famer-Died-at-88-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px" title="K.C. Jones Boston Celtics Hall of Famer Died at 88 13" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijc1IiB3aWR0aD0iNzUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2020/12/K.C.-Jones-Boston-Celtics-Hall-of-Famer-Died-at-88-75x75.jpg" alt="K.C. Jones Boston Celtics Hall of Famer Died at 88" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/12/K.C.-Jones-Boston-Celtics-Hall-of-Famer-Died-at-88-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/K.C.-Jones-Boston-Celtics-Hall-of-Famer-Died-at-88-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/K.C.-Jones-Boston-Celtics-Hall-of-Famer-Died-at-88-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px" title="K.C. Jones Boston Celtics Hall of Famer Died at 88 13"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/k-c-jones-boston-celtics-hall-of-famer-died-at-88/" title="K.C. Jones Boston Celtics Hall of Famer Died at 88">
						K.C. Jones Boston Celtics Hall of Famer Died at 88					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/gordie-howe-dies-at-88/" title="Gordie Howe dies at 88">
							<amp-img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2016/06/Gordie-Howe-dies-at-88-75x75.png" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Gordie Howe dies at 88" srcset="https://www.whodiedtoday.com/wp-content/uploads/2016/06/Gordie-Howe-dies-at-88-75x75.png 75w, https://www.whodiedtoday.com/wp-content/uploads/2016/06/Gordie-Howe-dies-at-88-150x150.png 150w, https://www.whodiedtoday.com/wp-content/uploads/2016/06/Gordie-Howe-dies-at-88-90x90.png 90w" sizes="(max-width: 75px) 100vw, 75px" title="Gordie Howe dies at 88 14" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijc1IiB3aWR0aD0iNzUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2016/06/Gordie-Howe-dies-at-88-75x75.png" alt="Gordie Howe dies at 88" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2016/06/Gordie-Howe-dies-at-88-75x75.png 75w, https://www.whodiedtoday.com/wp-content/uploads/2016/06/Gordie-Howe-dies-at-88-150x150.png 150w, https://www.whodiedtoday.com/wp-content/uploads/2016/06/Gordie-Howe-dies-at-88-90x90.png 90w" sizes="(max-width: 75px) 100vw, 75px" title="Gordie Howe dies at 88 14"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/gordie-howe-dies-at-88/" title="Gordie Howe dies at 88">
						Gordie Howe dies at 88					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/former-top-mlb-prospect-andy-marte-33-killed-in-car-crash/" title="Former top MLB prospect Andy Marte, 33, killed in car crash">
							<amp-img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2017/01/sddefault-2-75x75.jpg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Former top MLB prospect Andy Marte, 33, killed in car crash 15" srcset="https://www.whodiedtoday.com/wp-content/uploads/2017/01/sddefault-2-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2017/01/sddefault-2-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2017/01/sddefault-2-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px" title="Former top MLB prospect Andy Marte, 33, killed in car crash 16" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijc1IiB3aWR0aD0iNzUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2017/01/sddefault-2-75x75.jpg" alt="Former top MLB prospect Andy Marte, 33, killed in car crash 15" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2017/01/sddefault-2-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2017/01/sddefault-2-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2017/01/sddefault-2-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px" title="Former top MLB prospect Andy Marte, 33, killed in car crash 16"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/former-top-mlb-prospect-andy-marte-33-killed-in-car-crash/" title="Former top MLB prospect Andy Marte, 33, killed in car crash">
						Former top MLB prospect Andy Marte, 33, killed in car crash					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/brazilian-official-who-met-trump-test-positive-for-coronavirus/" title="Brazilian Official Who Met Trump Last Weekend Tests Positive For Coronavirus – NPR">
							<amp-img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-75x75.png" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Brazilian Official Who Met Trump Last Weekend Tests Positive For Coronavirus - NPR 17" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-75x75.png 75w, https://www.whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-150x150.png 150w, https://www.whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-90x90.png 90w" sizes="(max-width: 75px) 100vw, 75px" title="Brazilian Official Who Met Trump Last Weekend Tests Positive For Coronavirus - NPR 18" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijc1IiB3aWR0aD0iNzUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-75x75.png" alt="Brazilian Official Who Met Trump Last Weekend Tests Positive For Coronavirus - NPR 17" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-75x75.png 75w, https://www.whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-150x150.png 150w, https://www.whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-90x90.png 90w" sizes="(max-width: 75px) 100vw, 75px" title="Brazilian Official Who Met Trump Last Weekend Tests Positive For Coronavirus - NPR 18"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/brazilian-official-who-met-trump-test-positive-for-coronavirus/" title="Brazilian Official Who Met Trump Last Weekend Tests Positive For Coronavirus – NPR">
						Brazilian Official Who Met Trump Last Weekend Tests Positive For Coronavirus – NPR					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/justice-john-paul-stevens-dies-at-99/" title="Justice John Paul Stevens, Former Supreme Court  dead at 99">
							<amp-img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2019/07/cropped-John-Paul-Stevens-75x75.png" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Justice John Paul Stevens, Former Supreme Court dead at 99 19" srcset="https://www.whodiedtoday.com/wp-content/uploads/2019/07/cropped-John-Paul-Stevens-75x75.png 75w, https://www.whodiedtoday.com/wp-content/uploads/2019/07/cropped-John-Paul-Stevens-150x150.png 150w, https://www.whodiedtoday.com/wp-content/uploads/2019/07/cropped-John-Paul-Stevens-90x90.png 90w" sizes="(max-width: 75px) 100vw, 75px" title="Justice John Paul Stevens, Former Supreme Court dead at 99 20" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijc1IiB3aWR0aD0iNzUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2019/07/cropped-John-Paul-Stevens-75x75.png" alt="Justice John Paul Stevens, Former Supreme Court dead at 99 19" loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2019/07/cropped-John-Paul-Stevens-75x75.png 75w, https://www.whodiedtoday.com/wp-content/uploads/2019/07/cropped-John-Paul-Stevens-150x150.png 150w, https://www.whodiedtoday.com/wp-content/uploads/2019/07/cropped-John-Paul-Stevens-90x90.png 90w" sizes="(max-width: 75px) 100vw, 75px" title="Justice John Paul Stevens, Former Supreme Court dead at 99 20"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/justice-john-paul-stevens-dies-at-99/" title="Justice John Paul Stevens, Former Supreme Court  dead at 99">
						Justice John Paul Stevens, Former Supreme Court  dead at 99					</a>

							</li></ul>

		</div>

		</div><div id="archives-2" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown" on="change:AMP.navigateTo(url=event.value)">
			
			<option value="">Select Month</option>
				<option value="https://www.whodiedtoday.com/2021/06/"> June 2021  (3)</option>
	<option value="https://www.whodiedtoday.com/2021/05/"> May 2021  (4)</option>
	<option value="https://www.whodiedtoday.com/2021/04/"> April 2021  (5)</option>
	<option value="https://www.whodiedtoday.com/2021/03/"> March 2021  (3)</option>
	<option value="https://www.whodiedtoday.com/2021/02/"> February 2021  (5)</option>
	<option value="https://www.whodiedtoday.com/2021/01/"> January 2021  (10)</option>
	<option value="https://www.whodiedtoday.com/2020/12/"> December 2020  (31)</option>
	<option value="https://www.whodiedtoday.com/2020/11/"> November 2020  (7)</option>
	<option value="https://www.whodiedtoday.com/2020/10/"> October 2020  (9)</option>
	<option value="https://www.whodiedtoday.com/2020/09/"> September 2020  (3)</option>
	<option value="https://www.whodiedtoday.com/2020/08/"> August 2020  (7)</option>
	<option value="https://www.whodiedtoday.com/2020/07/"> July 2020  (17)</option>
	<option value="https://www.whodiedtoday.com/2020/06/"> June 2020  (5)</option>
	<option value="https://www.whodiedtoday.com/2020/05/"> May 2020  (14)</option>
	<option value="https://www.whodiedtoday.com/2020/04/"> April 2020  (17)</option>
	<option value="https://www.whodiedtoday.com/2020/03/"> March 2020  (21)</option>
	<option value="https://www.whodiedtoday.com/2020/02/"> February 2020  (11)</option>
	<option value="https://www.whodiedtoday.com/2020/01/"> January 2020  (8)</option>
	<option value="https://www.whodiedtoday.com/2019/12/"> December 2019  (6)</option>
	<option value="https://www.whodiedtoday.com/2019/10/"> October 2019  (3)</option>
	<option value="https://www.whodiedtoday.com/2019/09/"> September 2019  (1)</option>
	<option value="https://www.whodiedtoday.com/2019/08/"> August 2019  (4)</option>
	<option value="https://www.whodiedtoday.com/2019/07/"> July 2019  (7)</option>
	<option value="https://www.whodiedtoday.com/2019/06/"> June 2019  (1)</option>
	<option value="https://www.whodiedtoday.com/2019/05/"> May 2019  (2)</option>
	<option value="https://www.whodiedtoday.com/2019/03/"> March 2019  (3)</option>
	<option value="https://www.whodiedtoday.com/2019/02/"> February 2019  (5)</option>
	<option value="https://www.whodiedtoday.com/2019/01/"> January 2019  (6)</option>
	<option value="https://www.whodiedtoday.com/2018/12/"> December 2018  (4)</option>
	<option value="https://www.whodiedtoday.com/2018/11/"> November 2018  (2)</option>
	<option value="https://www.whodiedtoday.com/2018/10/"> October 2018  (3)</option>
	<option value="https://www.whodiedtoday.com/2018/09/"> September 2018  (2)</option>
	<option value="https://www.whodiedtoday.com/2018/08/"> August 2018  (6)</option>
	<option value="https://www.whodiedtoday.com/2018/07/"> July 2018  (1)</option>
	<option value="https://www.whodiedtoday.com/2018/06/"> June 2018  (3)</option>
	<option value="https://www.whodiedtoday.com/2018/05/"> May 2018  (3)</option>
	<option value="https://www.whodiedtoday.com/2018/04/"> April 2018  (7)</option>
	<option value="https://www.whodiedtoday.com/2018/02/"> February 2018  (1)</option>
	<option value="https://www.whodiedtoday.com/2018/01/"> January 2018  (1)</option>
	<option value="https://www.whodiedtoday.com/2017/12/"> December 2017  (1)</option>
	<option value="https://www.whodiedtoday.com/2017/11/"> November 2017  (2)</option>
	<option value="https://www.whodiedtoday.com/2017/10/"> October 2017  (1)</option>
	<option value="https://www.whodiedtoday.com/2017/08/"> August 2017  (4)</option>
	<option value="https://www.whodiedtoday.com/2017/07/"> July 2017  (3)</option>
	<option value="https://www.whodiedtoday.com/2017/06/"> June 2017  (2)</option>
	<option value="https://www.whodiedtoday.com/2017/05/"> May 2017  (5)</option>
	<option value="https://www.whodiedtoday.com/2017/04/"> April 2017  (8)</option>
	<option value="https://www.whodiedtoday.com/2017/03/"> March 2017  (2)</option>
	<option value="https://www.whodiedtoday.com/2017/02/"> February 2017  (7)</option>
	<option value="https://www.whodiedtoday.com/2017/01/"> January 2017  (13)</option>
	<option value="https://www.whodiedtoday.com/2016/12/"> December 2016  (29)</option>
	<option value="https://www.whodiedtoday.com/2016/11/"> November 2016  (36)</option>
	<option value="https://www.whodiedtoday.com/2016/10/"> October 2016  (27)</option>
	<option value="https://www.whodiedtoday.com/2016/09/"> September 2016  (36)</option>
	<option value="https://www.whodiedtoday.com/2016/08/"> August 2016  (21)</option>
	<option value="https://www.whodiedtoday.com/2016/07/"> July 2016  (131)</option>
	<option value="https://www.whodiedtoday.com/2016/06/"> June 2016  (13)</option>
	<option value="https://www.whodiedtoday.com/2016/05/"> May 2016  (1)</option>
	<option value="https://www.whodiedtoday.com/2016/04/"> April 2016  (3)</option>
	<option value="https://www.whodiedtoday.com/2016/03/"> March 2016  (7)</option>
	<option value="https://www.whodiedtoday.com/2016/02/"> February 2016  (6)</option>
	<option value="https://www.whodiedtoday.com/2016/01/"> January 2016  (8)</option>
	<option value="https://www.whodiedtoday.com/2015/12/"> December 2015  (2)</option>
	<option value="https://www.whodiedtoday.com/2015/11/"> November 2015  (2)</option>
	<option value="https://www.whodiedtoday.com/2015/10/"> October 2015  (2)</option>
	<option value="https://www.whodiedtoday.com/2015/09/"> September 2015  (7)</option>
	<option value="https://www.whodiedtoday.com/2015/08/"> August 2015  (10)</option>
	<option value="https://www.whodiedtoday.com/2015/07/"> July 2015  (9)</option>
	<option value="https://www.whodiedtoday.com/2015/06/"> June 2015  (6)</option>
	<option value="https://www.whodiedtoday.com/2015/05/"> May 2015  (8)</option>
	<option value="https://www.whodiedtoday.com/2015/04/"> April 2015  (8)</option>
	<option value="https://www.whodiedtoday.com/2015/03/"> March 2015  (2)</option>
	<option value="https://www.whodiedtoday.com/2015/02/"> February 2015  (8)</option>
	<option value="https://www.whodiedtoday.com/2015/01/"> January 2015  (18)</option>
	<option value="https://www.whodiedtoday.com/2014/12/"> December 2014  (7)</option>
	<option value="https://www.whodiedtoday.com/2014/11/"> November 2014  (11)</option>
	<option value="https://www.whodiedtoday.com/2014/10/"> October 2014  (21)</option>
	<option value="https://www.whodiedtoday.com/2014/09/"> September 2014  (6)</option>
	<option value="https://www.whodiedtoday.com/2014/08/"> August 2014  (10)</option>
	<option value="https://www.whodiedtoday.com/2014/07/"> July 2014  (5)</option>
	<option value="https://www.whodiedtoday.com/2014/06/"> June 2014  (6)</option>
	<option value="https://www.whodiedtoday.com/2014/05/"> May 2014  (3)</option>
	<option value="https://www.whodiedtoday.com/2014/04/"> April 2014  (6)</option>
	<option value="https://www.whodiedtoday.com/2014/03/"> March 2014  (2)</option>
	<option value="https://www.whodiedtoday.com/2014/02/"> February 2014  (3)</option>
	<option value="https://www.whodiedtoday.com/2014/01/"> January 2014  (2)</option>
	<option value="https://www.whodiedtoday.com/2013/12/"> December 2013  (3)</option>
	<option value="https://www.whodiedtoday.com/2013/08/"> August 2013  (1)</option>
	<option value="https://www.whodiedtoday.com/2013/07/"> July 2013  (1)</option>
	<option value="https://www.whodiedtoday.com/2013/05/"> May 2013  (1)</option>
	<option value="https://www.whodiedtoday.com/2013/04/"> April 2013  (1)</option>
	<option value="https://www.whodiedtoday.com/2013/03/"> March 2013  (2)</option>
	<option value="https://www.whodiedtoday.com/2013/02/"> February 2013  (1)</option>
	<option value="https://www.whodiedtoday.com/2012/12/"> December 2012  (2)</option>
	<option value="https://www.whodiedtoday.com/2012/11/"> November 2012  (4)</option>
	<option value="https://www.whodiedtoday.com/2012/10/"> October 2012  (1)</option>
	<option value="https://www.whodiedtoday.com/2012/09/"> September 2012  (2)</option>
	<option value="https://www.whodiedtoday.com/2012/08/"> August 2012  (1)</option>
	<option value="https://www.whodiedtoday.com/2012/07/"> July 2012  (1)</option>
	<option value="https://www.whodiedtoday.com/2012/05/"> May 2012  (2)</option>
	<option value="https://www.whodiedtoday.com/2012/03/"> March 2012  (2)</option>
	<option value="https://www.whodiedtoday.com/2012/02/"> February 2012  (1)</option>
	<option value="https://www.whodiedtoday.com/2012/01/"> January 2012  (2)</option>
	<option value="https://www.whodiedtoday.com/2011/12/"> December 2011  (3)</option>
	<option value="https://www.whodiedtoday.com/2011/11/"> November 2011  (4)</option>
	<option value="https://www.whodiedtoday.com/2011/10/"> October 2011  (3)</option>
	<option value="https://www.whodiedtoday.com/2011/08/"> August 2011  (1)</option>
	<option value="https://www.whodiedtoday.com/2011/07/"> July 2011  (1)</option>
	<option value="https://www.whodiedtoday.com/2011/06/"> June 2011  (2)</option>
	<option value="https://www.whodiedtoday.com/2011/05/"> May 2011  (2)</option>
	<option value="https://www.whodiedtoday.com/2011/04/"> April 2011  (1)</option>
	<option value="https://www.whodiedtoday.com/2011/03/"> March 2011  (1)</option>
	<option value="https://www.whodiedtoday.com/2011/01/"> January 2011  (2)</option>
	<option value="https://www.whodiedtoday.com/2010/12/"> December 2010  (1)</option>
	<option value="https://www.whodiedtoday.com/2010/11/"> November 2010  (4)</option>
	<option value="https://www.whodiedtoday.com/2010/10/"> October 2010  (10)</option>
	<option value="https://www.whodiedtoday.com/2010/09/"> September 2010  (9)</option>
	<option value="https://www.whodiedtoday.com/2010/08/"> August 2010  (3)</option>
	<option value="https://www.whodiedtoday.com/2010/07/"> July 2010  (1)</option>
	<option value="https://www.whodiedtoday.com/2008/11/"> November 2008  (4)</option>
	<option value="https://www.whodiedtoday.com/2008/05/"> May 2008  (1)</option>
	<option value="https://www.whodiedtoday.com/2008/04/"> April 2008  (2)</option>
	<option value="https://www.whodiedtoday.com/2008/03/"> March 2008  (4)</option>
	<option value="https://www.whodiedtoday.com/2008/02/"> February 2008  (1)</option>
	<option value="https://www.whodiedtoday.com/2008/01/"> January 2008  (2)</option>
	<option value="https://www.whodiedtoday.com/2007/11/"> November 2007  (1)</option>
	<option value="https://www.whodiedtoday.com/2007/10/"> October 2007  (3)</option>
	<option value="https://www.whodiedtoday.com/2007/09/"> September 2007  (1)</option>
	<option value="https://www.whodiedtoday.com/2007/08/"> August 2007  (1)</option>
	<option value="https://www.whodiedtoday.com/2007/06/"> June 2007  (13)</option>
	<option value="https://www.whodiedtoday.com/2006/06/"> June 2006  (1)</option>

		</select>


			</div>
	</section><!-- #secondary -->

	
	</div><!-- #content -->

	
			<div id="footer-widgets-bg" class="footer-widgets-background">

				<div id="footer-widgets-wrap" class="footer-widgets-wrap container">

					<div id="footer-widgets" class="footer-widgets clearfix" role="complementary">

						
							<div class="footer-widget-column widget-area">
								<aside id="nav_menu-5" class="widget widget_nav_menu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-4234" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4234"><a href="https://www.whodiedtoday.com/us/">About us</a></li>
<li id="menu-item-4235" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4235"><a href="https://www.whodiedtoday.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-4233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4233"><a href="https://www.whodiedtoday.com/who-died-today/1-famous-person-who-died-today-in-the-world/">Famous People Who died today in 2020 somewhere in the world</a></li>
<li id="menu-item-4236" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4236"><a href="https://www.whodiedtoday.com/terms-and-conditions/">Terms And Conditions</a></li>
</ul></div></aside>							</div>

						
						
						
						
							<div class="footer-widget-column widget-area">
								<aside id="tzwb-recent-posts-6" class="widget tzwb-recent-posts">
		<div class="tzwb-content tzwb-clearfix">

			<ul class="tzwb-posts-list">
				
					<li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/ganga-stone-sustenance-to-aids-dead-at-79/" title="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79">
							<amp-img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Ganga-Stone-the-lady-who-gave-sustenance-to-AIDS-patients-dead-at-79-150x150.jpeg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79" title="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79 21" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjE1MCIgd2lkdGg9IjE1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Ganga-Stone-the-lady-who-gave-sustenance-to-AIDS-patients-dead-at-79-150x150.jpeg" alt="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79" loading="lazy" title="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79 21"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/ganga-stone-sustenance-to-aids-dead-at-79/" title="Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79">
						Ganga Stone, the lady who gave sustenance to AIDS patients, dead at 79					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/" title="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL">
							<amp-img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL.-150x150.jpeg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL." data-hero-candidate="" title="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL 22" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjE1MCIgd2lkdGg9IjE1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Dead-at-85-is-Mudcat-Grant-the-1st-Black-20-game-winner-in-AL.-150x150.jpeg" alt="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL." loading="lazy" title="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL 22"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/dead-at-85-is-mudcat-grant-former-twins-pitcher/" title="Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL">
						Dead at 85 is Mudcat Grant, the 1st Black 20-game winner in AL					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/robert-hogan-the-veteran-tv-actor-dies-at-87/" title="Robert Hogan, the Veteran TV actor, dies at 87">
							<amp-img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Robert-Hogan-Veteran-TV-actor-dies-at-87-150x150.jpeg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Robert Hogan, Veteran TV actor, dies at 87" title="Robert Hogan, the Veteran TV actor, dies at 87 23" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjE1MCIgd2lkdGg9IjE1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Robert-Hogan-Veteran-TV-actor-dies-at-87-150x150.jpeg" alt="Robert Hogan, Veteran TV actor, dies at 87" loading="lazy" title="Robert Hogan, the Veteran TV actor, dies at 87 23"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/robert-hogan-the-veteran-tv-actor-dies-at-87/" title="Robert Hogan, the Veteran TV actor, dies at 87">
						Robert Hogan, the Veteran TV actor, dies at 87					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/charles-grodin-the-heartbreak-kid-actor-dead-at-86/" title="Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86">
							<amp-img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Charles-Grodin-Heartbreak-Kid-Actor-Dead-at-86-150x150.jpeg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Charles Grodin Heartbreak Kid Actor Dead at 86" title="Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86 24" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjE1MCIgd2lkdGg9IjE1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="150" height="150" src="https://www.whodiedtoday.com/wp-content/uploads/2021/06/Charles-Grodin-Heartbreak-Kid-Actor-Dead-at-86-150x150.jpeg" alt="Charles Grodin Heartbreak Kid Actor Dead at 86" loading="lazy" title="Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86 24"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/charles-grodin-the-heartbreak-kid-actor-dead-at-86/" title="Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86">
						Charles Grodin ‘The Heartbreak Kid’ Actor, Unrivaled Talk Show Curmudgeon Dead at 86					</a>

				
					</li><li class="tzwb-has-thumbnail">
						<a href="https://www.whodiedtoday.com/covid-19-virus-surge-breaks-record-again-in-indian/" title="Pressure rises for India lockdown as covid-19 virus surge breaks record again.">
							<amp-img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-75x75.jpg" class="attachment-tzwb-thumbnail size-tzwb-thumbnail wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Pressure rises for India lockdown as covid-19 virus surge breaks record again." srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px" title="Pressure rises for India lockdown as covid-19 virus surge breaks record again. 25" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijc1IiB3aWR0aD0iNzUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img width="75" height="75" src="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-75x75.jpg" alt="Pressure rises for India lockdown as covid-19 virus surge breaks record again." loading="lazy" srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-75x75.jpg 75w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-150x150.jpg 150w, https://www.whodiedtoday.com/wp-content/uploads/2021/05/Pressure-rises-for-India-lockdown-as-covid-19-virus-surge-breaks-record-again-90x90.jpg 90w" sizes="(max-width: 75px) 100vw, 75px" title="Pressure rises for India lockdown as covid-19 virus surge breaks record again. 25"></noscript></amp-img>						</a>

				
					<a href="https://www.whodiedtoday.com/covid-19-virus-surge-breaks-record-again-in-indian/" title="Pressure rises for India lockdown as covid-19 virus surge breaks record again.">
						Pressure rises for India lockdown as covid-19 virus surge breaks record again.					</a>

							</li></ul>

		</div>

		</aside>							</div>

						
					</div>

				</div>

			</div>

			
	<div class="footer-wrap">

		
		<footer id="colophon" class="site-footer">

						
	<div id="footer-line" class="site-info">

				
			<span class="footer-text">
				Who Died Today - CAKAFETEINC Family of Web Sites 
			</span>

					
	</div>

	
		</footer><!-- #colophon -->

	</div>

	
</div><!-- #page -->

<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-1472193-15","config":{"UA-1472193-15":{"groups":"default","linker":{"domains":["www.whodiedtoday.com"]}}}}}</script></amp-analytics><amp-analytics id="c545036a-b24a-47ed-9f80-60aaf43caad9" type="googleanalytics" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"account":"\ud83d\udc49 Provide site tracking ID here (e.g. UA-1472193-15) \ud83d\udc48"},"triggers":{"trackPageview":{"on":"visible","request":"pageview"}}}</script></amp-analytics>

</body></html>
