<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class=no-js lang=en-US prefix="og: https://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta http-equiv=Content-Type content="text/html; charset=UTF-8"/>
<meta name=viewport content='width=device-width, initial-scale=1, user-scalable=yes'/>
<link rel=profile href="http://gmpg.org/xfn/11"/>
<link rel=pingback href="https://www.whodiedtoday.com/xmlrpc.php"/>
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style><link rel=stylesheet id=wp-block-library-css href='https://www.whodiedtoday.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0' type='text/css' media=all /><link rel=stylesheet id=themezee-magazine-blocks-css href='https://www.whodiedtoday.com/wp-content/plugins/themezee-magazine-blocks/assets/css/themezee-magazine-blocks.css?ver=1.1.3' type='text/css' media=all /><style id=global-styles-inline-css>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</style><link rel=stylesheet id=js_composer_front-css href='https://www.whodiedtoday.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.9.0' type='text/css' media=all /><link crossorigin=anonymous rel=stylesheet id=jeg_customizer_font-css href='//fonts.googleapis.com/css?family=Inter%3Aregular%2C600%7CInder%3A500%7CArchitects+Daughter%3Areguler&#038;display=swap&#038;ver=1.2.6' type='text/css' media=all /><link rel=stylesheet id=font-awesome-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/fonts/font-awesome/font-awesome.min.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=jnews-icon-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/fonts/jegicon/jegicon.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=jscrollpane-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/jquery.jscrollpane.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=oknav-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/okayNav.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=magnific-popup-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/magnific-popup.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=chosen-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/chosen/chosen.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=jnews-main-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/main.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=jnews-pages-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/pages.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=jnews-responsive-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/responsive.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=jnews-pb-temp-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/pb-temp.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=jnews-js-composer-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/js-composer-frontend.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=jnews-style-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/style.css?ver=10.6.4' type='text/css' media=all /><link rel=stylesheet id=jnews-darkmode-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/css/darkmode.css?ver=10.6.4' type='text/css' media=all /><style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><style>#amp-mobile-version-switcher{left:0;position:absolute;width:100%;z-index:100}#amp-mobile-version-switcher>a{background-color:#444;border:0;color:#eaeaea;display:block;font-family:-apple-system,BlinkMacSystemFont,Segoe UI,Roboto,Oxygen-Sans,Ubuntu,Cantarell,Helvetica Neue,sans-serif;font-size:16px;font-weight:600;padding:15px 0;text-align:center;text-decoration:none}#amp-mobile-version-switcher>a:active,#amp-mobile-version-switcher>a:focus,#amp-mobile-version-switcher>a:hover{text-decoration:underline}</style><script>
!function(){var e={};e.g=function(){if("object"==typeof globalThis)return globalThis;try{return this||new Function("return this")()}catch(e){if("object"==typeof window)return window}}(),function(n){let{ampUrl:t,isCustomizePreview:r,isAmpDevMode:o,noampQueryVarName:s,noampQueryVarValue:i,disabledStorageKey:a,mobileUserAgents:c,regexRegex:u}=n;if("undefined"==typeof sessionStorage)return;const d=new RegExp(u);if(!c.some((e=>{const n=e.match(d);return!(!n||!new RegExp(n[1],n[2]).test(navigator.userAgent))||navigator.userAgent.includes(e)})))return;e.g.addEventListener("DOMContentLoaded",(()=>{const e=document.getElementById("amp-mobile-version-switcher");if(!e)return;e.hidden=!1;const n=e.querySelector("a[href]");n&&n.addEventListener("click",(()=>{sessionStorage.removeItem(a)}))}));const g=o&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(sessionStorage.getItem(a)||r||g)return;const m=new URL(location.href),h=new URL(t);h.hash=m.hash,m.searchParams.has(s)&&i===m.searchParams.get(s)?sessionStorage.setItem(a,"1"):h.href!==m.href&&(window.stop(),location.replace(h.href))}({"ampUrl":"https:\/\/www.whodiedtoday.com\/what-actor-died-today-ages-20-to-100\/?amp=1","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}();
</script>
<script>var jnews_ajax_url='/?ajax-request=jnews'</script>
<script>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</script>
<title>What Actor Died Today Ages 20 to 100 - Who Died Today</title>
<meta name=description content="What Actor Died Today on the big screen, TV show, comedian or other."/>
<meta name=robots content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel=canonical href="https://www.whodiedtoday.com/what-actor-died-today-ages-20-to-100/"/>
<meta property=og:locale content=en_US />
<meta property=og:type content=article />
<meta property=og:title content="What Actor Died Today Ages 20 to 100 - Who Died Today"/>
<meta property=og:description content="What Actor Died Today on the big screen, TV show, comedian or other."/>
<meta property=og:url content="https://www.whodiedtoday.com/what-actor-died-today-ages-20-to-100/"/>
<meta property=og:site_name content="Who Died Today"/>
<meta property=og:updated_time content=2022-05-28T11:44:57-04:00 />
<meta property=og:image content="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Famous-Who-People-Death-2022.jpeg"/>
<meta property=og:image:secure_url content="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Famous-Who-People-Death-2022.jpeg"/>
<meta property=og:image:width content=1280 />
<meta property=og:image:height content=720 />
<meta property=og:image:alt content="What Actor Died Today Ages 20 to 100"/>
<meta property=og:image:type content="image/jpeg"/>
<meta name=twitter:card content=summary_large_image />
<meta name=twitter:title content="What Actor Died Today Ages 20 to 100 - Who Died Today"/>
<meta name=twitter:description content="What Actor Died Today on the big screen, TV show, comedian or other."/>
<meta name=twitter:image content="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Famous-Who-People-Death-2022.jpeg"/>
<meta name=twitter:label1 content="Time to read"/>
<meta name=twitter:data1 content="Less than a minute"/>
<link rel=dns-prefetch href='/'/>
<link rel=dns-prefetch href='//www.googletagmanager.com'/>
<link rel=dns-prefetch href='//fonts.googleapis.com'/>
<link rel=dns-prefetch href='//s.w.org'/>
<link rel=preconnect href='https://fonts.gstatic.com'/>
<link rel=alternate type="application/rss+xml" title="Who Died Today &raquo; Feed" href="https://www.whodiedtoday.com/feed/"/>
<link rel=alternate type="application/rss+xml" title="Who Died Today &raquo; Comments Feed" href="https://www.whodiedtoday.com/comments/feed/"/>
<script>window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.whodiedtoday.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);</script>
<link rel=preload as=font type='font/woff2' crossorigin id=font-awesome-webfont-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/fonts/font-awesome/fonts/fontawesome-webfont.woff2?v=4.7.0' type='text/css' media=all />
<link rel=preload as=font type='font/woff' crossorigin id=jnews-icon-webfont-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/fonts/jegicon/fonts/jegicon.woff' type='text/css' media=all />
<link rel=preload as=font type='font/woff2' crossorigin id=vc-font-awesome-brands-webfont-css href='https://www.whodiedtoday.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/webfonts/fa-brands-400.woff2' type='text/css' media=all />
<link rel=preload as=font type='font/woff2' crossorigin id=vc-font-awesome-regular-webfont-css href='https://www.whodiedtoday.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/webfonts/fa-regular-400.woff2' type='text/css' media=all />
<link rel=preload as=font type='font/woff2' crossorigin id=vc-font-awesome-solid-webfont-css href='https://www.whodiedtoday.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/webfonts/fa-solid-900.woff2' type='text/css' media=all />
<script src='https://www.whodiedtoday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id=jquery-core-js></script>
<script src='https://www.whodiedtoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id=jquery-migrate-js></script>
<script src='https://www.googletagmanager.com/gtag/js?id=UA-1472193-15' id=google_gtagjs-js async></script>
<script id=google_gtagjs-js-after>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}gtag('set','linker',{"domains":["www.whodiedtoday.com"]});gtag("js",new Date());gtag("set","developer_id.dZTNiMT",true);gtag("config","UA-1472193-15",{"anonymize_ip":true});</script>
<link rel="https://api.w.org/" href="https://www.whodiedtoday.com/wp-json/"/><link rel=alternate type="application/json" href="https://www.whodiedtoday.com/wp-json/wp/v2/pages/9679"/><link rel=EditURI type="application/rsd+xml" title=RSD href="https://www.whodiedtoday.com/xmlrpc.php?rsd"/>
<link rel=wlwmanifest type="application/wlwmanifest+xml" href="https://www.whodiedtoday.com/wp-includes/wlwmanifest.xml"/>
<meta name=generator content="WordPress 6.0"/>
<link rel=shortlink href='https://www.whodiedtoday.com/?p=9679'/>
<link rel=alternate type="application/json+oembed" href="https://www.whodiedtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.whodiedtoday.com%2Fwhat-actor-died-today-ages-20-to-100%2F"/>
<link rel=alternate type="text/xml+oembed" href="https://www.whodiedtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.whodiedtoday.com%2Fwhat-actor-died-today-ages-20-to-100%2F&#038;format=xml"/>
<meta name=generator content="Site Kit by Google 1.75.0"/>
<meta name=google-adsense-platform-account content=ca-host-pub-2644536267352236>
<meta name=google-adsense-platform-domain content=sitekit.withgoogle.com>
<meta name=generator content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<link rel=amphtml href="https://www.whodiedtoday.com/what-actor-died-today-ages-20-to-100/?amp=1"><link rel=alternate type="text/html" media="only screen and (max-width: 640px)" href="https://www.whodiedtoday.com/what-actor-died-today-ages-20-to-100/?amp=1"><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Person","url":"https:\/\/www.whodiedtoday.com\/","name":"WHODIEDTODAY.COM","sameAs":["#","#","#"]}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/www.whodiedtoday.com\/#website","url":"https:\/\/www.whodiedtoday.com\/","name":"","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.whodiedtoday.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel=icon href="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo-32x32.jpeg" sizes=32x32 />
<link rel=icon href="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo-192x192.jpeg" sizes=192x192 />
<link rel=apple-touch-icon href="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo-180x180.jpeg"/>
<meta name=msapplication-TileImage content="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo-270x270.jpeg"/>
<script>var _paq=window._paq=window._paq||[];_paq.push(["setDocumentTitle",document.domain+"/"+document.title]);_paq.push(["setCookieDomain","*.www.whodiedtoday.com"]);_paq.push(['trackPageView']);_paq.push(['enableLinkTracking']);(function(){var u="https://cakafeteinc.com/";_paq.push(['setTrackerUrl',u+'matomo.php']);_paq.push(['setSiteId','1']);var d=document,g=d.createElement('script'),s=d.getElementsByTagName('script')[0];g.async=true;g.src=u+'matomo.js';s.parentNode.insertBefore(g,s);})();</script><noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<link rel=icon href="www.whodiedtoday.com/favicon.ico">
<link rel=stylesheet id=jnews-scheme-css href='https://www.whodiedtoday.com/wp-content/themes/jnews/data/import/writy/scheme.css?ver=10.6.4' type='text/css' media=all /><style id=jeg_dynamic_css data-type=jeg_custom-css>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</style><style>
					.no_thumbnail .jeg_thumb,
					.thumbnail-container.no_thumbnail {
					    display: none !important;
					}
					.jeg_search_result .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
					.jeg_sidefeed .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
					.jeg_pl_sm.no_thumbnail .jeg_postblock_content {
					    margin-left: 0;
					}
					.jeg_postblock_11 .no_thumbnail .jeg_postblock_content,
					.jeg_postblock_12 .no_thumbnail .jeg_postblock_content,
					.jeg_postblock_12.jeg_col_3o3 .no_thumbnail .jeg_postblock_content  {
					    margin-top: 0;
					}
					.jeg_postblock_15 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_postblock_19 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_postblock_24 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_sidefeed .jeg_pl_md_box .jeg_postblock_content {
					    position: relative;
					}
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa {
					    color: #212121 !important;
					} 
					.jnews-dark-mode .jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,
					.jnews-dark-mode .jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,
					.jnews-dark-mode .jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa {
					    color: #fff !important;
					} 
				</style></head>
<body class="page-template-default page page-id-9679 wp-embed-responsive non-logged-in jeg_toggle_light jnews jsc_normal wpb-js-composer js-comp-ver-6.9.0 vc_responsive">
<div class="jeg_ad jeg_ad_top jnews_header_top_ads">
<div class='ads-wrapper  '><div class=ads_code><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-4823718395360608" crossorigin=anonymous></script></div><div class=ads-text>ADVERTISEMENT</div></div> </div>
<div class=jeg_viewport>
<div class=jeg_header_wrapper>
<div class=jeg_header_instagram_wrapper>
</div>
<div class="jeg_header normal">
<div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper  jeg_navbar_normal">
<div class=container>
<div class=jeg_nav_row>
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_logo jeg_desktop_logo">
<div class=site-title>
<a href="https://www.whodiedtoday.com/" style="padding: 0px 0px 0px 0px;">
whodiedtoday.com	</a>
</div>
</div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_main_menu_wrapper">
<div class=jeg_mainmenu_wrap><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation=animate><li id=menu-item-9161 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9161 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com">Home</a></li>
<li id=menu-item-8715 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8715 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/who-died-today-in-2022/">2022</a></li>
<li id=menu-item-8716 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8716 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/who-died-today-2021/">2021</a></li>
<li id=menu-item-8717 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8717 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/famous-people-who-died-today-in-2020/">2020</a></li>
<li id=menu-item-9163 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9163 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/celebrity-actor-who-died/">Celebrity</a></li>
<li id=menu-item-9188 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9188 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/who-died-on-dominica/">Dominica</a></li>
<li id=menu-item-9162 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9162 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/who-important-died-today/">More Important people</a></li>
</ul></div></div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item jeg_dark_mode">
<label class=dark_mode_switch>
<input type=checkbox class=jeg_dark_mode_toggle>
<span class="slider round"></span>
</label>
</div>
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_modal_expand">
<a href="#" class=jeg_search_toggle><i class="fa fa-search"></i></a>
<form action="https://www.whodiedtoday.com/" class=jeg_search_form target=_top>
<input name=s class=jeg_search_input placeholder=Search... type=text value="" autocomplete=off>
<button aria-label="Search Button" type=submit class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<div class="jeg_search_result jeg_search_hide with_result">
<div class=search-result-wrapper>
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div>
<div class="jeg_nav_item jeg_button_1">
<a href="#" class="btn default " target=_blank>
<i class=""></i>
Get Started	</a>
</div> </div>
</div>
</div>
</div>
</div></div> </div>
<div class=jeg_header_sticky>
<div class=sticky_blankspace></div>
<div class="jeg_header normal">
<div class=jeg_container>
<div data-mode=scroll class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
<div class=container>
<div class=jeg_nav_row>
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_logo">
<div class=site-title>
<a href="https://www.whodiedtoday.com/">
<img class=jeg_logo_img src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg" srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg 2x" alt=WHODiedTODAY.COM data-light-src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg" data-light-srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/cropped-whodiedtoday-logo.jpeg 2x" data-dark-src="https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark.png" data-dark-srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark.png 1x, https://www.whodiedtoday.com/wp-content/uploads/2022/01/logo_dark@2x.png 2x"> </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_main_menu_wrapper">
<div class=jeg_mainmenu_wrap><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation=animate><li id=menu-item-9161 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9161 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com">Home</a></li>
<li id=menu-item-8715 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8715 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/who-died-today-in-2022/">2022</a></li>
<li id=menu-item-8716 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8716 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/who-died-today-2021/">2021</a></li>
<li id=menu-item-8717 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8717 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/famous-people-who-died-today-in-2020/">2020</a></li>
<li id=menu-item-9163 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9163 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/celebrity-actor-who-died/">Celebrity</a></li>
<li id=menu-item-9188 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9188 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/who-died-on-dominica/">Dominica</a></li>
<li id=menu-item-9162 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9162 bgnav" data-item-row=default><a href="https://www.whodiedtoday.com/who-important-died-today/">More Important people</a></li>
</ul></div></div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item jeg_dark_mode">
<label class=dark_mode_switch>
<input type=checkbox class=jeg_dark_mode_toggle>
<span class="slider round"></span>
</label>
</div>
<div class="jeg_nav_item jeg_nav_search">
<div class="jeg_search_wrapper jeg_search_no_expand round">
<a href="#" class=jeg_search_toggle><i class="fa fa-search"></i></a>
<form action="https://www.whodiedtoday.com/" class=jeg_search_form target=_top>
<input name=s class=jeg_search_input placeholder=Search... type=text value="" autocomplete=off>
<button aria-label="Search Button" type=submit class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<div class="jeg_search_result jeg_search_hide with_result">
<div class=search-result-wrapper>
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div>	</div>
</div> </div>
</div>
</div>
</div> </div>
</div>
</div>
</div>
<div class=jeg_navbar_mobile_wrapper>
<div class=jeg_navbar_mobile data-mode=scroll>
<div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
<div class=container>
<div class=jeg_nav_row>
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class=jeg_nav_item>
<a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
<div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_mobile_logo">
<div class=site-title>
<a href="https://www.whodiedtoday.com/">
WHO DIED	</a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
<a href="#" class=jeg_search_toggle><i class="fa fa-search"></i></a>
<form action="https://www.whodiedtoday.com/" class=jeg_search_form target=_top>
<input name=s class=jeg_search_input placeholder=Search... type=text value="" autocomplete=off>
<button aria-label="Search Button" type=submit class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<div class="jeg_search_result jeg_search_hide with_result">
<div class=search-result-wrapper>
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div>
</div></div>
<div class=sticky_blankspace style="height: 60px;"></div> </div>
<div class="jeg_main jeg_sidebar_none">
<div class=jeg_container>
<div class="jeg_content jeg_singlepage">
<div class=container>
<div class=row>
<div class="jeg_main_content col-md-12">
<div class="jeg_breadcrumbs jeg_breadcrumb_container">
<div id=breadcrumbs><span class="">
<a href="https://www.whodiedtoday.com">Home</a>
</span><i class="fa fa-angle-right"></i><span class=breadcrumb_last_link>
<a href="">What Actor Died Today Ages 20 to 100</a>
</span></div> </div>
<div class=entry-header>
<h1 class=jeg_post_title>What Actor Died Today Ages 20 to 100</h1>
</div>
<div class="jeg_featured featured_image"><a href="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Famous-Who-People-Death-2022.jpeg"><div class="thumbnail-container animate-lazy" style="padding-bottom:56.228%"><img width=1140 height=641 src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="What Actor Died Today Ages 20 to 100" data-src="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Famous-Who-People-Death-2022-1140x641.jpeg" data-sizes=auto data-expand=700 title="What Actor Died Today Ages 20 to 100 1 what actor died today"></div></a></div>
<div class="entry-content ">
<div class=content-inner>
<p>What actor died today from the movies, or TV shows? Comedians or others.</p>
<div class="wp-block-themezee-magazine-blocks-grid tz-magazine-block"><div class="tz-magazine-grid-columns tz-magazine-grid-columns-3"><div class=tz-post-wrap><article id=post-9675 class="tz-magazine-post post-9675 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-in-2022 tag-actor tag-america tag-breaking-news tag-died tag-dies tag-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/actor-ray-liotta-goodfellas-star-dead-at-67/" rel=bookmark><img width=1140 height=570 src="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Ray-Liotta-Goodfellas-Star-Dead-At-67.jpeg" class="attachment-full size-full wp-post-image" alt="Actor Ray Liotta &#039;Goodfellas’ Star Dead At 67" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Ray-Liotta-Goodfellas-Star-Dead-At-67.jpeg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Ray-Liotta-Goodfellas-Star-Dead-At-67-300x150.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Ray-Liotta-Goodfellas-Star-Dead-At-67-150x75.jpeg 150w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Ray-Liotta-Goodfellas-Star-Dead-At-67-768x384.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Ray-Liotta-Goodfellas-Star-Dead-At-67-360x180.jpeg 360w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Ray-Liotta-Goodfellas-Star-Dead-At-67-750x375.jpeg 750w" sizes="(max-width: 1140px) 100vw, 1140px" title="Actor Ray Liotta &#039;Goodfellas&#039; Star Dead At 67 2 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/actor-ray-liotta-goodfellas-star-dead-at-67/" rel=bookmark>Actor Ray Liotta &#8216;Goodfellas&#8217; Star Dead At 67</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/actor-ray-liotta-goodfellas-star-dead-at-67/" title="12:25 AM" rel=bookmark><time class="published updated" datetime=2022-05-27T00:25:05-04:00>May 27, 2022</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Ray Liotta was born on December 18, 1954, and died on May 26, 2022. He was an American actor and producer. Liotta was known for playing Shoeless Joe <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/actor-ray-liotta-goodfellas-star-dead-at-67/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-9652 class="tz-magazine-post post-9652 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-in-2022 tag-actor tag-actress tag-america tag-breaking-news tag-died tag-dies tag-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/dead-at-81-is-actor-maggie-peterson/" rel=bookmark><img width=1140 height=570 src="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Dead-at-81-actor-Maggie-Peterson.jpeg" class="attachment-full size-full wp-post-image" alt="Dead at 81 actor Maggie Peterson" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Dead-at-81-actor-Maggie-Peterson.jpeg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Dead-at-81-actor-Maggie-Peterson-300x150.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Dead-at-81-actor-Maggie-Peterson-150x75.jpeg 150w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Dead-at-81-actor-Maggie-Peterson-768x384.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Dead-at-81-actor-Maggie-Peterson-360x180.jpeg 360w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Dead-at-81-actor-Maggie-Peterson-750x375.jpeg 750w" sizes="(max-width: 1140px) 100vw, 1140px" title="Dead at 81 actor Maggie Peterson | The Andy Griffith Show. 3 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/dead-at-81-is-actor-maggie-peterson/" rel=bookmark>Dead at 81 actor Maggie Peterson | The Andy Griffith Show.</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/dead-at-81-is-actor-maggie-peterson/" title="7:54 PM" rel=bookmark><time class="published updated" datetime=2022-05-17T19:54:40-04:00>May 17, 2022</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Maggie Peterson, whose character on “The Andy Griffith Show” developed a memorable infatuation with Mayberry sheriff Andy Taylor, has died, her family said Monday. She <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/dead-at-81-is-actor-maggie-peterson/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-9635 class="tz-magazine-post post-9635 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-in-2022 tag-actor tag-america tag-breaking-news tag-died tag-dies tag-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/actor-fred-ward-the-right-stuff-fame-died/" rel=bookmark><img width=1140 height=570 src="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Fred-Ward-The-Right-Stuff-fame-Dead-at-76.jpeg" class="attachment-full size-full wp-post-image" alt="Actor Fred Ward, &#039;The Right Stuff&#039; fame, Dead at 76" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Fred-Ward-The-Right-Stuff-fame-Dead-at-76.jpeg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Fred-Ward-The-Right-Stuff-fame-Dead-at-76-300x150.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Fred-Ward-The-Right-Stuff-fame-Dead-at-76-150x75.jpeg 150w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Fred-Ward-The-Right-Stuff-fame-Dead-at-76-768x384.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Fred-Ward-The-Right-Stuff-fame-Dead-at-76-360x180.jpeg 360w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Actor-Fred-Ward-The-Right-Stuff-fame-Dead-at-76-750x375.jpeg 750w" sizes="(max-width: 1140px) 100vw, 1140px" title="Actor Fred Ward, &#039;The Right Stuff&#039; fame, Dead at 76 4 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/actor-fred-ward-the-right-stuff-fame-died/" rel=bookmark>Actor Fred Ward, &#8216;The Right Stuff&#8217; fame, Dead at 76</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/actor-fred-ward-the-right-stuff-fame-died/" title="9:44 AM" rel=bookmark><time class="published updated" datetime=2022-05-15T09:44:50-04:00>May 15, 2022</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>NEW YORK (AP) — Fred Ward, a veteran actor who brought a fierce tenderness to tough-guy roles in such films as &quot;The Right Stuff,&quot; &quot;The <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/actor-fred-ward-the-right-stuff-fame-died/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-9624 class="tz-magazine-post post-9624 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-in-2022 tag-actor tag-actress tag-breaking-news tag-died tag-dies tag-in-south-korean-music tag-korean tag-korean-actress tag-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/kang-soo-yeon-top-korean-actress-dead-at-55/" rel=bookmark><img width=1140 height=570 src="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kang-Soo-Yeon-Veteran-Korean-Actress-Dead-at-55.jpeg" class="attachment-full size-full wp-post-image" alt="Kang Soo-Yeon, Veteran Korean Actress, Dead at 55" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kang-Soo-Yeon-Veteran-Korean-Actress-Dead-at-55.jpeg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kang-Soo-Yeon-Veteran-Korean-Actress-Dead-at-55-300x150.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kang-Soo-Yeon-Veteran-Korean-Actress-Dead-at-55-150x75.jpeg 150w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kang-Soo-Yeon-Veteran-Korean-Actress-Dead-at-55-768x384.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kang-Soo-Yeon-Veteran-Korean-Actress-Dead-at-55-360x180.jpeg 360w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kang-Soo-Yeon-Veteran-Korean-Actress-Dead-at-55-750x375.jpeg 750w" sizes="(max-width: 1140px) 100vw, 1140px" title="Kang Soo-Yeon, Veteran Korean Actress, Dead at 55 5 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/kang-soo-yeon-top-korean-actress-dead-at-55/" rel=bookmark>Kang Soo-Yeon, Veteran Korean Actress, Dead at 55</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/kang-soo-yeon-top-korean-actress-dead-at-55/" title="9:16 PM" rel=bookmark><time class="published updated" datetime=2022-05-08T21:16:51-04:00>May 8, 2022</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>The Korea Herald reported that the actress Kang Soo-Yeon died on Saturday following a cerebral hemorrhage, two days after being taken to a hospital in Southern <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/kang-soo-yeon-top-korean-actress-dead-at-55/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-9611 class="tz-magazine-post post-9611 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-in-2022 tag-actor tag-breaking-news tag-canadian-actor tag-died tag-dies tag-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/dead-at-80-is-canadian-actor-kenneth-welsh/" rel=bookmark><img width=1140 height=570 src="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kenneth-Welsh-CanadianActor-Dead-at-80.jpeg" class="attachment-full size-full wp-post-image" alt="Kenneth Welsh CanadianActor, Dead at 80" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kenneth-Welsh-CanadianActor-Dead-at-80.jpeg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kenneth-Welsh-CanadianActor-Dead-at-80-300x150.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kenneth-Welsh-CanadianActor-Dead-at-80-150x75.jpeg 150w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kenneth-Welsh-CanadianActor-Dead-at-80-768x384.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kenneth-Welsh-CanadianActor-Dead-at-80-360x180.jpeg 360w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Kenneth-Welsh-CanadianActor-Dead-at-80-750x375.jpeg 750w" sizes="(max-width: 1140px) 100vw, 1140px" title="Kenneth Welsh, &#039;The Day After Tomorrow&#039; Actor, Dead at 80 6 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/dead-at-80-is-canadian-actor-kenneth-welsh/" rel=bookmark>Kenneth Welsh, &#8216;The Day After Tomorrow&#8217; Actor, Dead at 80</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/dead-at-80-is-canadian-actor-kenneth-welsh/" title="10:32 PM" rel=bookmark><time class="published updated" datetime=2022-05-07T22:32:05-04:00>May 7, 2022</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>80-year-old Kenneth Welsh, the actor known for his memorable villain from Twin Peaks and his roles in hit films such as The Day After Tomorrow <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/dead-at-80-is-canadian-actor-kenneth-welsh/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-9602 class="tz-magazine-post post-9602 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-in-2022 tag-actor tag-actress tag-america tag-breaking-news tag-died tag-dies tag-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/actress-joanna-barnes-dead-at-87/" rel=bookmark><img width=1140 height=570 src="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Joanna-Barnes-The-Parent-Trap-and-Tarzan-Actress-died-at-age-at-87.jpeg" class="attachment-full size-full wp-post-image" alt="Joanna Barnes The Parent Trap and Tarzan Actress died at age at 87" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/05/Joanna-Barnes-The-Parent-Trap-and-Tarzan-Actress-died-at-age-at-87.jpeg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Joanna-Barnes-The-Parent-Trap-and-Tarzan-Actress-died-at-age-at-87-300x150.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Joanna-Barnes-The-Parent-Trap-and-Tarzan-Actress-died-at-age-at-87-150x75.jpeg 150w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Joanna-Barnes-The-Parent-Trap-and-Tarzan-Actress-died-at-age-at-87-768x384.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Joanna-Barnes-The-Parent-Trap-and-Tarzan-Actress-died-at-age-at-87-360x180.jpeg 360w, https://www.whodiedtoday.com/wp-content/uploads/2022/05/Joanna-Barnes-The-Parent-Trap-and-Tarzan-Actress-died-at-age-at-87-750x375.jpeg 750w" sizes="(max-width: 1140px) 100vw, 1140px" title="Joanna Barnes, The Parent Trap and Tarzan Actress, Dead at 87 7 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/actress-joanna-barnes-dead-at-87/" rel=bookmark>Joanna Barnes, The Parent Trap and Tarzan Actress, Dead at 87</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/actress-joanna-barnes-dead-at-87/" title="11:59 PM" rel=bookmark><time class="published updated" datetime=2022-05-01T23:59:45-04:00>May 1, 2022</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Joanna Barnes, an actress, known for her roles in&nbsp;The Parent Trap&nbsp;and&nbsp;Tarzan: The Ape Man, has died. She was 87. The actress passed Friday at her <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/actress-joanna-barnes-dead-at-87/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div></div></div>
<div class="wp-block-themezee-magazine-blocks-grid tz-magazine-block"><div class="tz-magazine-grid-columns tz-magazine-grid-columns-3"><div class=tz-post-wrap><article id=post-9555 class="tz-magazine-post post-9555 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-in-2022 tag-actor tag-actress tag-america tag-breaking-news tag-comedy tag-died tag-dies tag-hollywood tag-news tag-seinfeld"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/actor-estelle-harris-dead-at-93/" rel=bookmark><img width=1140 height=570 src="https://www.whodiedtoday.com/wp-content/uploads/2022/04/Estelle-Harris-April-22-1928-–-April-2-2022.jpeg" class="attachment-full size-full wp-post-image" alt="Estelle Harris (née Nussbaum; April 22, 1928 – April 2, 2022" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/04/Estelle-Harris-April-22-1928-–-April-2-2022.jpeg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2022/04/Estelle-Harris-April-22-1928-–-April-2-2022-300x150.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2022/04/Estelle-Harris-April-22-1928-–-April-2-2022-1024x512.jpeg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2022/04/Estelle-Harris-April-22-1928-–-April-2-2022-768x384.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2022/04/Estelle-Harris-April-22-1928-–-April-2-2022-360x180.jpeg 360w, https://www.whodiedtoday.com/wp-content/uploads/2022/04/Estelle-Harris-April-22-1928-–-April-2-2022-750x375.jpeg 750w" sizes="(max-width: 1140px) 100vw, 1140px" title="Estelle Harris, ‘Seinfeld’ and ‘Toy Story actor, dead at 93 8 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/actor-estelle-harris-dead-at-93/" rel=bookmark>Estelle Harris, ‘Seinfeld’ and ‘Toy Story actor, dead at 93</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/actor-estelle-harris-dead-at-93/" title="10:36 AM" rel=bookmark><time class="published updated" datetime=2022-04-03T10:36:35-04:00>April 3, 2022</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Estelle Harris, who hollered her way into TV history as George Costanza&#039;s short-fused mother on &quot;Seinfeld&quot; and voiced Mrs. Potato Head in the &quot;Toy Story&quot; <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/actor-estelle-harris-dead-at-93/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-9279 class="tz-magazine-post post-9279 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-in-2022 tag-actor tag-actress tag-america tag-breaking-news tag-died tag-dies tag-hollywood tag-hollywood-producer tag-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/frank-pesce-top-gun-actor-dead-at-75/" rel=bookmark><img width=1140 height=570 src="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Top-Gun-and-Beverly-Hills-Cop-actor-Frank-Pesce-dead-at-75.jpeg" class="attachment-full size-full wp-post-image" alt="Top Gun and Beverly Hills Cop actor Frank Pesce, dead at 75" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Top-Gun-and-Beverly-Hills-Cop-actor-Frank-Pesce-dead-at-75.jpeg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2022/02/Top-Gun-and-Beverly-Hills-Cop-actor-Frank-Pesce-dead-at-75-300x150.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2022/02/Top-Gun-and-Beverly-Hills-Cop-actor-Frank-Pesce-dead-at-75-1024x512.jpeg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2022/02/Top-Gun-and-Beverly-Hills-Cop-actor-Frank-Pesce-dead-at-75-768x384.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2022/02/Top-Gun-and-Beverly-Hills-Cop-actor-Frank-Pesce-dead-at-75-360x180.jpeg 360w, https://www.whodiedtoday.com/wp-content/uploads/2022/02/Top-Gun-and-Beverly-Hills-Cop-actor-Frank-Pesce-dead-at-75-750x375.jpeg 750w" sizes="(max-width: 1140px) 100vw, 1140px" title="Frank Pesce, Top Gun and Beverly Hills Cop actor, dead at 75 9 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/frank-pesce-top-gun-actor-dead-at-75/" rel=bookmark>Frank Pesce, Top Gun and Beverly Hills Cop actor, dead at 75</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/frank-pesce-top-gun-actor-dead-at-75/" title="11:27 PM" rel=bookmark><time class="published updated" datetime=2022-02-16T23:27:01-05:00>February 16, 2022</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Frank Pesce, the actor whose career includes roles in&nbsp;Beverly Hills Cop, Top Gun, and&nbsp;Miami Vice, has died. He was 75.&nbsp; Pesce&#039;s girlfriend Tammy Scher told&nbsp;Deadline&nbsp;the <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/frank-pesce-top-gun-actor-dead-at-75/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-9214 class="tz-magazine-post post-9214 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-in-2022 tag-actor tag-breaking-news tag-died tag-dies tag-hollywood tag-movies tag-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/" rel=bookmark><img width=1140 height=570 src="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82.jpeg" class="attachment-full size-full wp-post-image" alt="Bob Wall, who Co-Star in Bruce Lee&#039;s &#039;Enter the Dragon,&#039; Dead at 82" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82.jpeg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-300x150.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-1024x512.jpeg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-768x384.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-360x180.jpeg 360w, https://www.whodiedtoday.com/wp-content/uploads/2022/02/Bob-Wall-who-Co-Star-in-Bruce-Lees-Enter-the-Dragon-Dead-at-82-750x375.jpeg 750w" sizes="(max-width: 1140px) 100vw, 1140px" title="Bob Wall, who Co-Star in Bruce Lee&#039;s &#039;Enter the Dragon,&#039; Dead at 82 10 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/" rel=bookmark>Bob Wall, who Co-Star in Bruce Lee&#8217;s &#8216;Enter the Dragon,&#8217; Dead at 82</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/" title="4:23 PM" rel=bookmark><time class="published updated" datetime=2022-02-05T16:23:16-05:00>February 5, 2022</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>The martial arts expert and stuntman Bob Wall, best known for playing henchman O&#039;Hara opposite Bruce Lee in the 1973 martial arts classic &quot;Enter the <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/bob-wall-co-star-in-enter-the-dragon-dead-at-82/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-6238 class="tz-magazine-post post-6238 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-2020 tag-ali-velshi tag-best-of-sean-connery-james-bond tag-hollywood tag-james-bond-efter-sean-connery tag-james-bond-sean-connery-collection tag-scotland tag-sean-connery-en-james-bond tag-sean-connery-james-bond-aston-martin-poster tag-sean-connery-james-bond-cast tag-sean-connery-james-bond-champagne tag-sean-connery-james-bond-clips tag-sean-connery-james-bond-clothes tag-sean-connery-james-bond-style tag-u-s-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/james-bond-first-actor-sean-connery-dead-at-70/" rel=bookmark><img width=1200 height=675 src="https://www.whodiedtoday.com/wp-content/uploads/2020/10/6238_James-Bond-first-Actor-Sean-dead-at-90.jpg" class="attachment-full size-full wp-post-image" alt="Sean Connery James Bond first Actor Sean Connery Dead at 70" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/10/6238_James-Bond-first-Actor-Sean-dead-at-90.jpg 1200w, https://www.whodiedtoday.com/wp-content/uploads/2020/10/6238_James-Bond-first-Actor-Sean-dead-at-90-300x169.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2020/10/6238_James-Bond-first-Actor-Sean-dead-at-90-1024x576.jpg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2020/10/6238_James-Bond-first-Actor-Sean-dead-at-90-768x432.jpg 768w, https://www.whodiedtoday.com/wp-content/uploads/2020/10/6238_James-Bond-first-Actor-Sean-dead-at-90-678x381.jpg 678w" sizes="(max-width: 1200px) 100vw, 1200px" title="James Bond first Actor Sean Connery Dead at 70 11 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/james-bond-first-actor-sean-connery-dead-at-70/" rel=bookmark>James Bond first Actor Sean Connery Dead at 70</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/james-bond-first-actor-sean-connery-dead-at-70/" title="6:38 PM" rel=bookmark><time class="published updated" datetime=2020-10-31T18:38:42-04:00>October 31, 2020</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Connery is best known for his role as the aforementioned super spy in the 007 franchise. He also played seminal roles in other classics like <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/james-bond-first-actor-sean-connery-dead-at-70/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-5883 class="tz-magazine-post post-5883 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-celebrity-actor-who-died category-who-important-died-today tag-6150 tag-actress tag-breast-cancer tag-cancer tag-celebrity-deaths tag-entertainment tag-entertainment-news tag-for-the-lofe-of-the-game tag-gotti tag-hollywood tag-hollywood-reporter tag-hollywood-reporter-news tag-jelly-preston-john-travolta tag-jerry-maguiire tag-john-travolta tag-john-travolta-wife tag-kelly-preston tag-kelly-preston-breast-cancer tag-kelly-preston-cancer tag-kelly-preston-dead tag-kelly-preston-dies tag-news tag-spacecamp tag-the-hollywood-reporter tag-thr tag-thr-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/kelly-preston-john-travolta-wife-dead-at-57/" rel=bookmark><img width=1200 height=675 src="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5883_Kelly-Preston-born-Kelly-Kamalelehua-Smith-October-13-1962-–-died-July-12-2020.jpg" class="attachment-full size-full wp-post-image" alt="Kelly Preston The actress Kelly Preston, the wife of John Travolta dead at 57" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/07/5883_Kelly-Preston-born-Kelly-Kamalelehua-Smith-October-13-1962-–-died-July-12-2020.jpg 1200w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5883_Kelly-Preston-born-Kelly-Kamalelehua-Smith-October-13-1962-–-died-July-12-2020-300x169.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5883_Kelly-Preston-born-Kelly-Kamalelehua-Smith-October-13-1962-–-died-July-12-2020-1024x576.jpg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5883_Kelly-Preston-born-Kelly-Kamalelehua-Smith-October-13-1962-–-died-July-12-2020-768x432.jpg 768w, https://www.whodiedtoday.com/wp-content/uploads/2020/07/5883_Kelly-Preston-born-Kelly-Kamalelehua-Smith-October-13-1962-–-died-July-12-2020-678x381.jpg 678w" sizes="(max-width: 1200px) 100vw, 1200px" title="The actress Kelly Preston, the wife of John Travolta dead at 57 12 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/kelly-preston-john-travolta-wife-dead-at-57/" rel=bookmark>The actress Kelly Preston, the wife of John Travolta dead at 57</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/kelly-preston-john-travolta-wife-dead-at-57/" title="12:00 AM" rel=bookmark><time class="published updated" datetime=2020-07-14T00:00:41-04:00>July 14, 2020</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Actress Kelly Preston, died Sunday after a private two-year battle with breast cancer. Kelly Preston starred in movies as &quot;Space Camp,&quot; &quot;Jerry Maguire,&quot; and most <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/kelly-preston-john-travolta-wife-dead-at-57/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-2908 class="tz-magazine-post post-2908 post tz-type-post status-publish format-video has-post-thumbnail hentry category-who-died-today-2020 tag-broadway tag-broadway-the-golden-age tag-debbie-reynolds tag-golden-age tag-golden-age-of-broadway tag-golden-age-of-hollywood tag-hollywood tag-jane-powell tag-mgm tag-mgm-musicals tag-rick-mckay post_format-post-format-video"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/debbie-reynolds-1932-2016-in-rick-mckays-broadway-beyond-the-golden-age/" rel=bookmark><img width=1280 height=720 src="https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-12.jpg" class="attachment-full size-full wp-post-image" alt="DEBBIE REYNOLDS (1932-2016) in Rick McKay&#039;s &quot;Broadway BEYOND the Golden Age&quot;" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-12.jpg 1280w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-12-300x169.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-12-1024x576.jpg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-12-768x432.jpg 768w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-12-750x422.jpg 750w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-12-1140x641.jpg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-12-153x86.jpg 153w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-12-170x96.jpg 170w, https://www.whodiedtoday.com/wp-content/uploads/2016/12/maxresdefault-12-50x28.jpg 50w" sizes="(max-width: 1280px) 100vw, 1280px" title="DEBBIE REYNOLDS (1932-2016) in Rick McKay&#039;s &quot;Broadway BEYOND the Golden Age&quot; 13 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/debbie-reynolds-1932-2016-in-rick-mckays-broadway-beyond-the-golden-age/" rel=bookmark>DEBBIE REYNOLDS (1932-2016) in Rick McKay&#8217;s &#8220;Broadway BEYOND the Golden Age&#8221;</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/debbie-reynolds-1932-2016-in-rick-mckays-broadway-beyond-the-golden-age/" title="6:44 PM" rel=bookmark><time class="published updated" datetime=2016-12-29T18:44:45-05:00>December 29, 2016</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>DEBBIE REYNOLDS (1932-2016) is one of the stars of Rick McKay&#039;s upcoming film, &quot;Broadway: BEYOND the Golden Age&quot; and these are just a few moments <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/debbie-reynolds-1932-2016-in-rick-mckays-broadway-beyond-the-golden-age/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div></div></div>
<div class="wp-block-themezee-magazine-blocks-grid tz-magazine-block"><div class="tz-magazine-grid-columns tz-magazine-grid-columns-3"><div class=tz-post-wrap><article id=post-9397 class="tz-magazine-post post-9397 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-in-2022 tag-actor tag-actors tag-actors-who-died-young tag-breaking-news tag-died tag-dies tag-news"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/traci-braxton-of-braxton-family-values-died/" rel=bookmark><img width=1140 height=570 src="https://www.whodiedtoday.com/wp-content/uploads/2022/03/Dead-at-50-is-Singer-Traci-Braxton-of-Braxton-Family-Values.jpeg" class="attachment-full size-full wp-post-image" alt="Dead at 50 is Singer Traci Braxton of Braxton Family Values" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2022/03/Dead-at-50-is-Singer-Traci-Braxton-of-Braxton-Family-Values.jpeg 1140w, https://www.whodiedtoday.com/wp-content/uploads/2022/03/Dead-at-50-is-Singer-Traci-Braxton-of-Braxton-Family-Values-300x150.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2022/03/Dead-at-50-is-Singer-Traci-Braxton-of-Braxton-Family-Values-1024x512.jpeg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2022/03/Dead-at-50-is-Singer-Traci-Braxton-of-Braxton-Family-Values-768x384.jpeg 768w, https://www.whodiedtoday.com/wp-content/uploads/2022/03/Dead-at-50-is-Singer-Traci-Braxton-of-Braxton-Family-Values-360x180.jpeg 360w, https://www.whodiedtoday.com/wp-content/uploads/2022/03/Dead-at-50-is-Singer-Traci-Braxton-of-Braxton-Family-Values-750x375.jpeg 750w" sizes="(max-width: 1140px) 100vw, 1140px" title="Dead at 50 is Singer Traci Braxton of Braxton Family Values 14 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/traci-braxton-of-braxton-family-values-died/" rel=bookmark>Dead at 50 is Singer Traci Braxton of Braxton Family Values</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/traci-braxton-of-braxton-family-values-died/" title="10:43 PM" rel=bookmark><time class="published updated" datetime=2022-03-12T22:43:37-05:00>March 12, 2022</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>NEW YORK (AP) — Singer Traci Braxton, featured with her family in the reality television series &quot;Braxton Family Values,&quot; died at age 50 on Saturday. <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/traci-braxton-of-braxton-family-values-died/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-6491 class="tz-magazine-post post-6491 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-celebrity-actor-who-died category-who-died-today-2020 tag-1967-tony-award tag-actors tag-actress tag-broadway-theatre tag-cabaret tag-entertainers tag-entertainment-culture tag-golde tag-greenport tag-human-interest tag-mayor tag-peg-murray tag-sally-bowles tag-susan-lucci tag-the-suffolk-times tag-the-tony-award tag-theatre tag-tony-award"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/peg-murray-died-at-96-following-a-stroke/" rel=bookmark><img width=1200 height=675 src="https://www.whodiedtoday.com/wp-content/uploads/2020/12/Peg-Murray-who-first-appeared-on-Broadway-in-1956-died-at-96-following-a-stroke.jpg" class="attachment-full size-full wp-post-image" alt="Peg Murray who first appeared on Broadway in 1956 died at 96 following a stroke" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/12/Peg-Murray-who-first-appeared-on-Broadway-in-1956-died-at-96-following-a-stroke.jpg 1200w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/Peg-Murray-who-first-appeared-on-Broadway-in-1956-died-at-96-following-a-stroke-300x169.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/Peg-Murray-who-first-appeared-on-Broadway-in-1956-died-at-96-following-a-stroke-1024x576.jpg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/Peg-Murray-who-first-appeared-on-Broadway-in-1956-died-at-96-following-a-stroke-768x432.jpg 768w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/Peg-Murray-who-first-appeared-on-Broadway-in-1956-died-at-96-following-a-stroke-678x381.jpg 678w" sizes="(max-width: 1200px) 100vw, 1200px" title="Peg Murray, who first appeared on Broadway in 1956, a recipient of the Tony Award in 1967, died at 96 following a stroke. 15 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/peg-murray-died-at-96-following-a-stroke/" rel=bookmark>Peg Murray, who first appeared on Broadway in 1956, a recipient of the Tony Award in 1967, died at 96 following a stroke.</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/peg-murray-died-at-96-following-a-stroke/" title="12:01 PM" rel=bookmark><time class="published updated" datetime=2020-12-20T12:01:00-05:00>December 20, 2020</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Peg Murray, who won a 1967 Tony Award for Fräulein Kost&#039;s portrayal in&nbsp;Cabaret&nbsp;and later recurred for 13 years on ABC&#039;s daytime drama&nbsp;All My Children, died <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/peg-murray-died-at-96-following-a-stroke/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-6408 class="tz-magazine-post post-6408 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-who-died-today-2020 tag-actors tag-actress tag-asia-ray-smith tag-disaster-accident tag-dynasty tag-entertainment-culture tag-human-interest tag-los-angeles tag-mamie-johnson tag-marguerite tag-marguerite-ray tag-new-orleans tag-redd-foxx tag-the-east-bay-times tag-the-odd-couple tag-the-young-and-the-restless tag-veronica-redd"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/actress-marguerite-ray-dies-at-89/" rel=bookmark><img width=1200 height=675 src="https://www.whodiedtoday.com/wp-content/uploads/2020/12/Marguerite-Ray-Dies-at-84.jpg" class="attachment-full size-full wp-post-image" alt="Marguerite Ray Dies: ‘The Young And The Restless’ Actress was 89" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/12/Marguerite-Ray-Dies-at-84.jpg 1200w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/Marguerite-Ray-Dies-at-84-300x169.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/Marguerite-Ray-Dies-at-84-1024x576.jpg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/Marguerite-Ray-Dies-at-84-768x432.jpg 768w, https://www.whodiedtoday.com/wp-content/uploads/2020/12/Marguerite-Ray-Dies-at-84-678x381.jpg 678w" sizes="(max-width: 1200px) 100vw, 1200px" title="Marguerite Ray ‘The Young And The Restless’ Actress Dies at 89 16 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/actress-marguerite-ray-dies-at-89/" rel=bookmark>Marguerite Ray ‘The Young And The Restless’ Actress Dies at 89</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/actress-marguerite-ray-dies-at-89/" title="9:09 PM" rel=bookmark><time class="published updated" datetime=2020-12-10T21:09:03-05:00>December 10, 2020</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Marguerite Ray, an actress who had a 10-year stint on&nbsp;The Young and the Restless&nbsp;and was a regular on Redd Foxx&#039;s 1980s&nbsp;&nbsp;Sanford and Son&nbsp;sequel series, has <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/actress-marguerite-ray-dies-at-89/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-5735 class="tz-magazine-post post-5735 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-celebrity-actor-who-died category-people-that-died-today-celebs-who-died-today tag-a-mighty-wind tag-actor tag-actors tag-actress tag-best-in-show tag-christopher-guest tag-comedic-actor tag-emmy tag-emmy-winning-comedic-actor tag-entertainment-culture tag-environment tag-fred-willard tag-fred-willard-rise tag-hope-mulbarger tag-human-interest tag-imdb tag-jamie-lee-curtis tag-jimmy-kimmel tag-mary tag-michael-eisenstadt tag-modern-family tag-space-force tag-sports tag-steve-carell tag-steve-carrell tag-this-is-spinal-tap-best-in-show-and-anchorman tag-twitter tag-ty-burrell tag-waiting-for-guffman tag-willard tag-writer-and-director"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/emmy-winning-comedic-actor-fred-willard-dead-at-86/" rel=bookmark><img width=1200 height=675 src="https://www.whodiedtoday.com/wp-content/uploads/2020/05/Emmy-winning-comedic-actor-Fred-Willard-is-dead-at-86.jpg" class="attachment-full size-full wp-post-image" alt="Emmy-winning comedic actor Fred Willard dead at 86" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2020/05/Emmy-winning-comedic-actor-Fred-Willard-is-dead-at-86.jpg 1200w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/Emmy-winning-comedic-actor-Fred-Willard-is-dead-at-86-300x169.jpg 300w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/Emmy-winning-comedic-actor-Fred-Willard-is-dead-at-86-1024x576.jpg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/Emmy-winning-comedic-actor-Fred-Willard-is-dead-at-86-768x432.jpg 768w, https://www.whodiedtoday.com/wp-content/uploads/2020/05/Emmy-winning-comedic-actor-Fred-Willard-is-dead-at-86-678x381.jpg 678w" sizes="(max-width: 1200px) 100vw, 1200px" title="Emmy-winning comedic actor Fred Willard dead at 86 17 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/emmy-winning-comedic-actor-fred-willard-dead-at-86/" rel=bookmark>Emmy-winning comedic actor Fred Willard dead at 86</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/emmy-winning-comedic-actor-fred-willard-dead-at-86/" title="2:38 PM" rel=bookmark><time class="published updated" datetime=2020-05-17T14:38:12-04:00>May 17, 2020</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Fred Willard, the comedic actor whose improv style kept him relevant for more than 50 years in films, dies at 86. His daughter said in <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/emmy-winning-comedic-actor-fred-willard-dead-at-86/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-5470 class="tz-magazine-post post-5470 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-famous-people-who-died-today-in-2020 category-who-important-died-today tag-a-season-on-the-brink tag-actor tag-actors tag-actress tag-bobby-knight tag-brian-dennehy tag-brian-dennehy-dead tag-dennehy tag-elizabeth-dennehy tag-emmy tag-english-language-films tag-hamilton tag-humans tag-jennifer tag-long-days-journey-into-night tag-peter-segal tag-surnames tag-sylvester-stallone tag-theatre"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/veteran-actor-brian-dennehy-dead-at-81/" rel=bookmark><img width=1365 height=455 src="https://www.whodiedtoday.com/wp-content/uploads/2021/07/Veteran-actor-Brian-Dennehy-Dead-at-81.jpeg" class="attachment-full size-full wp-post-image" alt="Veteran actor Brian Dennehy Dead at 81" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2021/07/Veteran-actor-Brian-Dennehy-Dead-at-81.jpeg 1365w, https://www.whodiedtoday.com/wp-content/uploads/2021/07/Veteran-actor-Brian-Dennehy-Dead-at-81-300x100.jpeg 300w, https://www.whodiedtoday.com/wp-content/uploads/2021/07/Veteran-actor-Brian-Dennehy-Dead-at-81-1024x341.jpeg 1024w, https://www.whodiedtoday.com/wp-content/uploads/2021/07/Veteran-actor-Brian-Dennehy-Dead-at-81-768x256.jpeg 768w" sizes="(max-width: 1365px) 100vw, 1365px" title="Veteran actor Brian Dennehy Dead at 81 18 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/veteran-actor-brian-dennehy-dead-at-81/" rel=bookmark>Veteran actor Brian Dennehy Dead at 81</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/veteran-actor-brian-dennehy-dead-at-81/" title="7:21 PM" rel=bookmark><time class="published updated" datetime=2020-04-16T19:21:58-04:00>April 16, 2020</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>The 81-year-old actor Brian Dennehy died on Wednesday, April 15, from natural causes his daughter said. She added her father&#039;s death was not coronavirus-related <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/veteran-actor-brian-dennehy-dead-at-81/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div><div class=tz-post-wrap><article id=post-4515 class="tz-magazine-post post-4515 post tz-type-post status-publish format-standard has-post-thumbnail hentry category-celebrity-actor-who-died category-who-important-died-today tag-actors tag-actress tag-diahann-carroll tag-domestic-worker tag-ebony tag-emmy tag-golden-globe tag-music-art-high-school tag-united-states"><figure class="tz-entry-image entry-image"><a href="https://www.whodiedtoday.com/diahann-carroll-black-actress-dead-at-84/" rel=bookmark><img width=1200 height=675 src="https://www.whodiedtoday.com/wp-content/uploads/2019/10/Actress-Diahann-Carroll-dead-at-84.png" class="attachment-full size-full wp-post-image" alt="Actress Diahann Carroll dead at 84" loading=lazy srcset="https://www.whodiedtoday.com/wp-content/uploads/2019/10/Actress-Diahann-Carroll-dead-at-84.png 1200w, https://www.whodiedtoday.com/wp-content/uploads/2019/10/Actress-Diahann-Carroll-dead-at-84-300x169.png 300w, https://www.whodiedtoday.com/wp-content/uploads/2019/10/Actress-Diahann-Carroll-dead-at-84-1024x576.png 1024w, https://www.whodiedtoday.com/wp-content/uploads/2019/10/Actress-Diahann-Carroll-dead-at-84-768x432.png 768w, https://www.whodiedtoday.com/wp-content/uploads/2019/10/Actress-Diahann-Carroll-dead-at-84-678x381.png 678w" sizes="(max-width: 1200px) 100vw, 1200px" title="A Star has left us - Actress Diahann Carroll dead at 84 19 what actor died today"></a></figure><header class="tz-entry-header entry-header"><h2 class="tz-entry-title entry-title"><a href="https://www.whodiedtoday.com/diahann-carroll-black-actress-dead-at-84/" rel=bookmark>A Star has left us &#8211; Actress Diahann Carroll dead at 84</a></h2><div class="tz-entry-meta entry-meta"><span class="tz-meta-date meta-date tz-meta-field"><a href="https://www.whodiedtoday.com/diahann-carroll-black-actress-dead-at-84/" title="8:53 PM" rel=bookmark><time class="published updated" datetime=2019-10-05T20:53:38-04:00>October 5, 2019</time></a></span><span class="tz-meta-author meta-author tz-meta-field author vcard"><a class="url fn n" href="https://www.whodiedtoday.com/author/whodied-admin/" title="View all posts by News Contributor" rel=author>News Contributor</a></span></div></header><div class="tz-entry-content entry-content"><p>Diahann Carroll made a number of films during her career and was nominated for an Academy Award for Claudine in 1974. It wasn&#039;t until she <span class=tz-excerpt-more>[&hellip;]</span></p><p class="tz-read-more read-more"><a href="https://www.whodiedtoday.com/diahann-carroll-black-actress-dead-at-84/" class="tz-more-link more-link" rel=bookmark>Continue Reading</a></p></div></article></div></div></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="jeg_ad jnews_above_footer_ads "><div class='ads-wrapper  '><div class=ads_code><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-4823718395360608" crossorigin=anonymous></script></div><div class=ads-text>ADVERTISEMENT</div></div></div>
</div>
</div>
<div class=footer-holder id=footer data-id=footer>
<div class="jeg_footer jeg_footer_6 normal">
<div class="jeg_footer_container jeg_container">
<div class=jeg_footer_content>
<div class=container>
<div class="jeg_footer_primary clearfix">
<div class="footer_widget widget_recent_comments" id=recent-comments-6><div class="jeg_footer_heading jeg_footer_heading_1"><h3 class=jeg_footer_title><span>Recent Comments</span></h3></div><ul id=recentcomments><li class=recentcomments><span class=comment-author-link>Toy Pupanbai</span> on <a href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-221">Tribute to Sir Patrick Moore who died today.</a></li><li class=recentcomments><span class=comment-author-link>An artist theory on the physics of 'Time' as a physical process. Quantum Atom Theory</span> on <a href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-222">Tribute to Sir Patrick Moore who died today.</a></li><li class=recentcomments><span class=comment-author-link>Toy Pupanbai</span> on <a href="https://www.whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-220">Tribute to Sir Patrick Moore who died today.</a></li><li class=recentcomments><span class=comment-author-link>jvon2000</span> on <a href="https://www.whodiedtoday.com/a-tribute-to-my-dog-who-died-today-february-16-2012/#comment-218">A tribute to my dog, who died today, February 16, 2012</a></li><li class=recentcomments><span class=comment-author-link>Patricio Garcete</span> on <a href="https://www.whodiedtoday.com/a-tribute-to-my-dog-who-died-today-february-16-2012/#comment-219">A tribute to my dog, who died today, February 16, 2012</a></li></ul></div> </div>
</div>
</div>
<div class="jeg_footer_instagram_wrapper jeg_container">
</div>
<div class="jeg_footer_tiktok_wrapper jeg_container">
</div>
<div class=jeg_footer_bottom>
<div class=container>
<div class=footer_right>
</div>
<p class=copyright> © 2022 <a href="http://jwww.fredwhite.ca" title="CAKAFETEINC FAMILY OF WEBSITES">CAKAFETEINC FAMILY OF WEBSITES</a> - Review -Products <a href="http://www.review-products.ca" title=review-products.ca>Review Products</a>. </p>
</div>
</div>
</div>
</div> </div>
<div class=jscroll-to-top>
<a href="#back-to-top" class=jscroll-to-top_link><i class="fa fa-angle-up"></i></a>
</div>
</div>
<div id=jeg_off_canvas class=normal>
<a href="#" class=jeg_menu_close><i class=jegicon-cross></i></a>
<div class=jeg_bg_overlay></div>
<div class=jeg_mobile_wrapper>
<div class=nav_wrap>
<div class=item_main>
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
<a href="#" class=jeg_search_toggle><i class="fa fa-search"></i></a>
<form action="https://www.whodiedtoday.com/" class=jeg_search_form target=_top>
<input name=s class=jeg_search_input placeholder=Search... type=text value="" autocomplete=off>
<button aria-label="Search Button" type=submit class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<div class="jeg_search_result jeg_search_hide with_result">
<div class=search-result-wrapper>
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div><div class=jeg_aside_item>
<ul class=jeg_mobile_menu><li id=menu-item-9658 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9658"><a href="https://www.whodiedtoday.com/">Home</a></li>
<li id=menu-item-8935 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8935"><a href="https://www.review-products.ca/">Review Products</a></li>
<li id=menu-item-8936 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8936"><a href="https://www.estopandshop.com/">eStopandshop</a></li>
<li id=menu-item-8937 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8937"><a href="https://www.fredwhite.ca">Websit Family</a></li>
<li id=menu-item-9686 class="menu-item menu-item-type-post_type menu-item-object-page current-menu-item page_item page-item-9679 current_page_item menu-item-9686"><a href="https://www.whodiedtoday.com/what-actor-died-today-ages-20-to-100/" aria-current=page>What Actor Died Today Ages 20 to 100</a></li>
</ul></div> </div>
<div class=item_bottom>
<div class="jeg_aside_item socials_widget nobg">
<a href="#" target=_blank rel='external noopener nofollow' class=jeg_facebook><i class="fa fa-facebook"></i> </a><a href="#" target=_blank rel='external noopener nofollow' class=jeg_twitter><i class="fa fa-twitter"></i> </a><a href="#" target=_blank rel='external noopener nofollow' class=jeg_instagram><i class="fa fa-instagram"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
<p>© 2022 <a href="http://jwww.fredwhite.ca" title="CAKAFETEINC FAMILY OF WEBSITES">CAKAFETEINC FAMILY OF WEBSITES</a> - Review -Products <a href="http://www.review-products.ca" title=review-products.ca>Review Products</a>.</p>
</div> </div>
</div> </div>
</div><script>var jfla=[]</script><div class=jnews-cookie-law-policy>This website uses cookies. By continuing to use this website you are giving consent to cookies being used. Visit our <a href="#">Privacy and Cookie Policy</a>. <button data-expire=7 class="btn btn-cookie">I Agree</button></div><script async defer src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script><script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:'ca-pub-4823718395360608',enable_page_level_ads:true,vignettes:{google_ad_channel:'ca-pub-4823718395360608'},overlays:{google_ad_channel:'ca-pub-4823718395360608'}});</script>	<div id=amp-mobile-version-switcher hidden>
<a rel="" href="https://www.whodiedtoday.com/what-actor-died-today-ages-20-to-100/?amp=1">
Go to mobile version	</a>
</div>
<script src='https://www.whodiedtoday.com/wp-includes/js/comment-reply.min.js?ver=6.0' id=comment-reply-js></script>
<script src='https://www.whodiedtoday.com/wp-includes/js/hoverIntent.min.js?ver=1.10.2' id=hoverIntent-js></script>
<script src='https://www.whodiedtoday.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id=imagesloaded-js></script>
<script src='https://www.whodiedtoday.com/wp-content/plugins/js_composer/assets/lib/bower/isotope/dist/isotope.pkgd.min.js?ver=6.9.0' id=isotope-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/lazysizes.js?ver=10.6.4' id=lazysizes-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/ls.bgset.js?ver=10.6.4' id=bgset-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/superfish.js?ver=10.6.4' id=superfish-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/theia-sticky-sidebar.js?ver=10.6.4' id=theia-sticky-sidebar-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.waypoints.js?ver=10.6.4' id=waypoint-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.scrollTo.js?ver=10.6.4' id=scrollto-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.parallax.js?ver=10.6.4' id=parallax-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.okayNav.js?ver=10.6.4' id=okaynav-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.mousewheel.js?ver=10.6.4' id=mousewheel-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/modernizr-custom.js?ver=10.6.4' id=modernizr-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.smartresize.js?ver=10.6.4' id=smartresize-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/chosen.jquery.js?ver=10.6.4' id=chosen-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.magnific-popup.js?ver=10.6.4' id=magnific-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.jnewsgif.js?ver=10.6.4' id=jnews-gif-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.jsticky.js?ver=10.6.4' id=jnews-sticky-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.transit.min.js?ver=10.6.4' id=jquery-transit-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/jquery.module.js?ver=10.6.4' id=jnews-landing-module-js></script>
<script id=jnews-main-js-extra>var jnewsoption={"login_reload":"https:\/\/www.whodiedtoday.com\/what-actor-died-today-ages-20-to-100","popup_script":"magnific","single_gallery":"","ismobile":"1","isie":"","sidefeed_ajax":"","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"0","isblog":"","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"1","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"whodiedtoday.com","zoom_button":"0"};</script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/main.js?ver=10.6.4' id=jnews-main-js></script>
<script src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/darkmode.js?ver=10.6.4' id=jnews-darkmode-js></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.whodiedtoday.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=10.6.4' id='html5shiv-js'></script>
<![endif]-->
<div class="jeg_ad jnews_mobile_sticky_ads "><div class='ads-wrapper  '><div class=ads_code><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-4823718395360608" crossorigin=anonymous></script></div></div></div><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Webpage","headline":"What Actor Died Today Ages 20 to 100","url":"https:\/\/www.whodiedtoday.com\/what-actor-died-today-ages-20-to-100\/","image":{"@type":"ImageObject","url":"https:\/\/www.whodiedtoday.com\/wp-content\/uploads\/2022\/05\/Famous-Who-People-Death-2022.jpeg","width":1280,"height":720}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.whodiedtoday.com","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.whodiedtoday.com?pagename=what-actor-died-today-ages-20-to-100","name":"What Actor Died Today Ages 20 to 100"}}]}</script>
<script>;!function(){"use strict";window.jnews=window.jnews||{},window.jnews.first_load=window.jnews.first_load||{},window.jnews.first_load=function(){var e=this,t=jnews.library,n="object"==typeof jnews&&"object"==typeof jnews.library;e.data=null,e.run_ajax=!0,e.run_loginregister=!0,e.clear=function(){e.run_ajax=!0,e.run_loginregister=!0,e.data=null},e.init=function(){n&&(t.globalBody.querySelectorAll(".jeg_popup_account").length&&jnews.loginregister&&e.run_loginregister&&(e.run_loginregister=!1,jnews.loginregister.init(),jnews.loginregister.hook_form()),jfla.length&&e.run_ajax&&(e.run_ajax=!1,e.do_ajax({action:"jnews_first_load_action",jnews_id:jnewsoption.postid,load_action:jfla})))},e.update_counter=function(){if(n){var o={total_view:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_views_count .counts"),total_share:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_share_count .counts"),total_comment:t.globalBody.querySelectorAll(".jeg_meta_comment a span")};t.forEach(Object.entries(e.data.counter),(function([e,n]){o[e].length&&t.forEach(o[e],(function(e,o){t.setText(e,n)}))}))}},e.do_ajax=function(o){if(n){var a=new XMLHttpRequest;a.onreadystatechange=function(){XMLHttpRequest.DONE===a.readyState&&200==a.status&&(e.data=JSON.parse(a.responseText),e.data.counter&&"object"==typeof e.data.counter&&e.update_counter())},a.open("POST",jnews_ajax_url,!0),a.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=UTF-8"),a.send(t.httpBuildQuery(o))}}},window.jnews.first_load=new window.jnews.first_load,jnews.first_load.init()}();</script></body>
</html>
